Help and Support
 

powered byLive Search

Vous recevez un code d'erreur « 0x80070002 » ou « 0x80070003 » après avoir téléchargé une mise à jour à partir de Windows Update, de Microsoft Update ou d'un serveur WSUS

Numéro d'article:910336
Dernière mise à jour:mercredi 5 décembre 2007
Version:2.2

Symptômes

Vous téléchargez une mise à jour à partir de l'un des emplacements suivants :
?le site Web Microsoft Windows Update ;
?le site Web Microsoft Update ;
?le serveur Microsoft Windows Server Update Services (WSUS).
Après le téléchargement, la mise à jour échoue et un X rouge peut être affiché en regard de la mise à jour. Dans ce cas, l'un des codes d'erreur suivants s'affiche :
?0x80070002
?0x80070003
Remarque Pour afficher les messages d'erreur, vous devez cliquer sur le X rouge en regard de la mise à jour concernée sur la page Web Consulter l'historique des mises à jour.

Retour au début

Cause

Ce problème se produit lorsque certains fichiers de la mise à jour sont manquants, même si la mise à jour a été téléchargée et extraite correctement.

Retour au début

Résolution

Pour résoudre ce problème, supprimez le répertoire de téléchargement, puis accédez à nouveau aux emplacements de la mise à jour. Pour cela, procédez comme suit :
1.Arrêtez le service Mises à jour automatiques. Pour cela, procédez comme suit :
a. Cliquez sur Démarrer, sur Exécuter, tapez services.msc, puis cliquez sur OK.
b. Cliquez avec le bouton droit sur le service Mises à jour automatiques, puis cliquez sur Arrêter.
c. Réduisez le composant logiciel enfichable Services.
2.Renommez le dossier SoftwareDistribution. Pour cela, procédez comme suit :
a. Cliquez sur Démarrer, puis sur Exécuter, tapez cmd, puis cliquez sur OK.
b. Tapez cd %windir%, puis appuyez sur ENTRÉE.
c. Tapez ren SoftwareDistribution SDTemp et appuyez sur ENTRÉE.
d. Tapez exit et appuyez sur ENTRÉE.


Remarque Lorsque vous supprimez le dossier %windir%\softwaredistribution, la liste d'historique est effacée de la section « Consulter l'historique des mises à jour » du site Web Windows Update. Cette action n'affecte pas les mises à jour installées actuellement sur votre ordinateur. Les mises à jour ultérieures apparaîtront dans la liste d'historique.
3.Démarrez le service Mises à jour automatiques. Pour cela, procédez comme suit :
a. Agrandissez le composant logiciel enfichable Services.
b. Cliquez avec le bouton droit sur le service Mises à jour automatiques, puis cliquez sur Démarrer.
c. Fermez la fenêtre du composant logiciel enfichable Services.
4.Accédez à nouveau au site Web Microsoft Windows Update ou Microsoft Update ou au serveur WSUS, puis téléchargez une mise à jour.
5. Si vous recevez les mêmes erreurs, vérifiez que vous avez effectué correctement les étapes 1 à  3.
6.Si vous ne pouvez toujours pas installer la mise à jour, reportez-vous à l'article suivant de la Base de connaissances Microsoft :
906602 (http://support.microsoft.com/kb/906602/) Comment faire pour résoudre les problèmes d'installation de Windows Update, de Microsoft Update et de Windows Server Update Services

Retour au début


Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
?Microsoft Update
?Microsoft Software Update Services 1.0
?Microsoft Windows Update

Retour au début

Mots-clés : 
kbtshoot KB910336

Retour au début

L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Traductions disponibles

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.