Recebe um código de erro "0x80070002" ou "0x80070003" depois de transferir uma actualização a partir do Windows Update, do Microsoft Update ou dos Windows Server Update Services

Artigo: 910336 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Corrigir o problema automaticamente

Corrigir este problema
Correcção de problemas da Microsoft 50202

Nota Esta solução de correcção contempla dois modos - Predefinido e Agressivo. Recomendamos que execute a solução de correcção no modo Predefinido para determinar se o problema do Windows Update é resolvido antes de executá-la no modo Agressivo.

Nota Se preferir corrigir o problema sozinho, consulte a secção "Deixar-me corrigir o problema".

Nota Este assistente pode estar apenas em inglês; contudo, a correcção automática também funciona em versões do Windows noutros idiomas.

Nota Se não estiver a trabalhar no computador que tem o problema, pode guardar a Solução de Correcção numa unidade flash ou num CD e, depois, executá-la no computador que tem o problema.
Esta informação foi útil? Envie-nos os seus comentários

Sintomas

Transfere uma actualização a partir de uma das seguintes localizações:
  • O Web site Microsoft Windows Update
  • O Web site Microsoft Update
  • O servidor Microsoft Windows Server Update Services (WSUS)
Após a transferência, a actualização poderá falhar e poderá ser apresentado um X vermelho junto da mesma. Neste caso, receberá um dos seguintes códigos de erro:
  • 0x80070002
  • 0x80070003
Nota: para ver mensagens de erro, tem de clicar no X vermelho junto à actualização falhada, na página Web Rever o histórico de actualizações.

Causa

Este problema ocorre quando faltam alguns ficheiros na actualização, embora a mesma tenha sido transferida e extraída com êxito.

Deixar-me corrigir o problema

Para corrigir este problema sozinho, remova o directório de transferências e depois consulte novamente as localizações de actualizações.
  1. Pare o serviço Actualizações automáticas. Para tal, siga estes passos:
    1. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
    2. Clique com o botão direito do rato no serviço Actualizações automáticas e clique em Parar.
    3. Minimize o snap-in Serviços.
  2. Mude o nome do directório SoftwareDistribution. Para tal, siga estes passos:
    1. Clique em Iniciar, clique em Executar, escreva cmd e clique em OK.
    2. Escreva cd %windir% e prima ENTER.
    3. Escreva ren SoftwareDistribution SDTemp e prima ENTER
    4. Escreva exit e prima ENTER.


    Nota: quando remover a pasta %windir%\softwaredistribution, a lista do histórico é apagada da secção "Rever o histórico de actualizações", do Web site Windows Update. Esta acção não afectará as actualizações actualmente instaladas no computador. As actualizações subsequentes serão apresentadas na lista do histórico.
  3. Inicie o serviço Actualizações automáticas. Para tal, siga estes passos:
    1. Maximize o snap-in Serviços.
    2. Clique com o botão direito do rato no serviço Actualizações automáticas e clique em Iniciar.
    3. Feche a janela do snap-in Serviços.
  4. Visite novamente o Web site Windows Update, o Web site Microsoft Update ou o servidor WSUS e transfira uma actualização.
  5. Se continuar a receber os mesmos erros, verifique se efectuou correctamente os passos 1 a 3.
  6. Se continuar a não conseguir instalar a actualização, consulte o seguinte artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
    906602 Como resolver problemas de instalação do Windows Update, do Microsoft Update e dos Windows Server Update Services

Propriedades

Artigo: 910336 - Última revisão: sexta-feira, 29 de Julho de 2011 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Update
  • Microsoft Windows Update
Palavras-chave: 
kbtshoot kbmsifixme kbfixme KB910336

Submeter comentários