Você recebe um código de erro "0x80070002" ou "0x80070003" após fazer o download da atualização do Windows Update, Microsoft Update ou Windows Server Update Services

ID do artigo: 910336 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Corrige o problema automaticamente

Corrigir este problema
Microsoft Fix it 50202

Observação Esta Solução de Correção possui dois modos, Padrão e Agressivo. Você deve executar a correção Corrigir no modo Padrão e determinar se ela resolve o problema com o Windows Update antes de executá-la no modo Agressivo.

Observação: Se preferir corrigir o problema sozinho, vá para a seção "Desejo corrigir sozinho".

Observação Esse assistente pode estar apenas em inglês, mas a correção automática também funciona para versões do Windows em outros idiomas.

Observação Se você não está no computador com problemas, salve a solução Corrigir em uma unidade flash ou um CD e execute-a no computador que esteja com o problema.
Essas informações foram úteis? Envie seus comentários

Sintomas

Você baixa uma atualização por um dos seguintes locais:
  • Site do Microsoft Windows Update
  • O site do Microsoft Update
  • Servidor do WSUS (Microsoft Windows Server Update Services)
Após fazer isto, a atualização pode falhar e um X vermelho pode ser exibido adjacente à atualização. Neste caso, um dos seguintes códigos de erro pode ser exibido:
  • 0x80070002
  • 0x80070003
Observação Para exibir as mensagens de erro, é necessário clicar no X vermelho adjacente à atualização que falhou na página da Web Revisar histórico de atualizações.

Causa

Esse problema ocorre quando alguns arquivos estão faltando na atualização, mesmo que a atualização tenha sido baixada e extraída com êxito.

Desejo corrigir sozinho

Para corrigir este problema sozinho, remova o diretório de download e visite os locais de atualização novamente.
  1. Pare o serviço Atualizações Automáticas. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar, em Executar, digite services.msc e clique em OK.
    2. Clique com o botão direito do mouse no serviço Atualizações automáticas e clique em Parar.
    3. Minimize o snap-in de serviços.
  2. Renomeie o diretório SoftwareDistribution. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar, em Executar, digite cmd e clique em OK.
    2. Digite cd %windir%, e pressione ENTER.
    3. Digite ren SoftwareDistribution SDTemp e pressione ENTER.
    4. Digite exit e pressione ENTER.


    Observação Ao remover a pasta %windir%\softwaredistribution, a lista do histórico será apagada da seção "Revisar atualizações" da página do Windows Update. Esta ação não afetará as atualizações já instaladas no computador. Atualizações posteriores serão exibidas na lista do histórico
  3. Inicie o serviço Atualizações Automáticas. Para fazer isto, execute as seguintes etapas:
    1. Maximize o snap-in de serviços.
    2. Clique com o botão direito do mouse no serviço Atualizações automáticas e clique em Iniciar.
    3. Feche a janela do snap-in de serviços.
  4. Visite o site do Windows Update na Web, a página do Microsoft Update na Web ou o servidor do WSUS novamente e faça o download da atualização.
  5. Se os mesmos erros continuarem a ser exibidos, verifique se você executou as etapas de 1 a 3 corretamente.
  6. Se ainda não for possível instalar a atualização, visualize o seguinte artigo da Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
    906602 Como solucionar problemas de instalação do Windows Update, Microsoft Update e Windows Server Update Services

Propriedades

ID do artigo: 910336 - Última revisão: quinta-feira, 28 de julho de 2011 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Update
  • Microsoft Windows Update
Palavras-chave: 
kbtshoot kbmsifixme kbfixme KB910336

Submeter comentários