Article ID: 910339 - Last Review: October 31, 2011 - Revision: 7.0

How to troubleshoot Windows Update or Microsoft Update when you are repeatedly offered an update

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SYMPTOMS

When you use Microsoft Windows Update, Microsoft Update, or Automatic Updates , you are repeatedly offered an update after the update has been installed. Additionally, Automatic Updates may repeatedly download and install the same update.

CAUSE

This problem may occur when one of the following conditions is true:
  • An error occurred during installation. The update was not installed.
  • The update was installed, however, a file was not updated when the computer restarted.

RESOLUTION

To identify the method to use to resolve the problem, determine whether the update was installed. Then, use one of the methods in the "Troubleshoot the problem" section.

Determine whether the update was installed

To determine whether the update was installed, use one of the following methods.

Method 1: Review the installation history

To review the installation history, follow these steps:
  1. Click Start, point to All Programs, and then click Windows Update or Microsoft Update.
  2. On the Web site, click Review your update history.
  3. Locate the most recent entry for the specific update.
  4. Note the color of the icon in the Status column. If the icon is green, the update was installed. If the icon is red, the update was not installed.

Method 2: Examine the installation log file

Note This method applies only to updates for Windows. Updates for Office do not create this log file.

To examine the installation log file, click Start, click Run, type %Windir%\KBnnnnnn.log, and then press ENTER.

Note In this command, nnnnnn represents the number of the Knowledge Base article about the update.

If an entry that is similar to the following is present, the update was installed.

Note In this sample entry, x represents a numeric value.
RebootNecessary = x,WizardInput = x, DontReboot = x, ForceRestart = x

Troubleshoot the problem

To troubleshoot the problem, use one of the following methods, depending on whether the update was installed.

How to troubleshoot the problem if the update was not installed

If a red icon or an error message appears next to the update on the update Web site, visit the following Microsoft Web site for more information about how to troubleshoot the problem:
906602  (http://support.microsoft.com/kb/906602/ ) How to troubleshoot Windows Update, Microsoft Update, and Windows Server Update Services installation issues

How to troubleshoot the problem if the update was installed

If a green icon appears next to the update on the update Web site, and you have installed the update at least three times, use the following methods to troubleshoot the problem. Use each method in turn. If a method does not solve the problem, go on to the next method.
Method 1: Reset Windows Update components and then try updating your computer

To reset the Windows Update components automatically, click the Fix it button or link. Click Run in the File Download dialog box, and then follow the steps in the Fix it wizard.

Note this Fix it Solution has two modes Default and Aggressive. You should run the Fix it solution in Default mode and determine whether it resolves your problem with Windows Update before you ru it in Aggressive mode.

Fix this problem
Microsoft Fix it 50202



Note this wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note if you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.
For more information about how to reset Windows Update components, visit the following Microsoft Website:
971058 How do I reset Windows Update components?
Method 2: Scan your PC for viruses and malicious software with the Microsoft Safety Scanner.
Scan your PC with the Microsoft Safety Scanner to remove viruses and other malicious software.

To scan your PC with the Microsoft Safety Scanner, click the following link:

http://www.microsoft.com/security/scanner/ (http://www.microsoft.com/security/scanner/)
Method 3: Use antispyware software and antivirus software to scan the computer
Use spyware-fighting software and antivirus software to scan the computer. Low-cost and trial versions of this software is generally available on the Internet.

To download and install Windows Defender antispyware, click the following link:

http://www.microsoft.com/athome/security/spyware/software/default.mspx (http://www.microsoft.com/athome/security/spyware/software/default.mspx)

To download and install Microsoft Security Essentials antivirus, click the following link:

http://www.microsoft.com/en-us/security_essentials/default.aspx (http://www.microsoft.com/en-us/security_essentials/default.aspx)

Method 4: Manually download and Install the update in Safe Mode
Install the update in Safe Mode. To do this, follow these steps:
  1. Download the update. To do this, follow these steps:
    1. Visit the Microsoft Download Web site:
      http://www.microsoft.com/downloads (http://www.microsoft.com/downloads)
    2. In the Search for a download box, type the number of the Knowledge Base article that describes the update, and then click Go.
    3. Download the update, and then save it to the desktop.
  2. Install the update. To do this, follow these steps:
    1. Double-click the downloaded file to install it.

      If you are prompted to restart the computer, do so.
    2. Visit the Windows Update or Microsoft Update Web site to verify whether the update is offered again. If you are offered the update again, continue to the next step.
  3. Install the update in Safe Mode. Safe Mode disables most running processes and services. These services include the Windows Update service. Installing an update in Safe Mode is a quick test to verify whether an application or process is interfering with the installation. To install in Safe Mode, follow these steps:
    1. Restart the computer.
    2. As the computer starts, press the F8 key.
    3. Use the arrow keys to choose Safe Mode, and then press ENTER.
    4. Double-click the file that you downloaded in step 1 to install the file.
    5. When the installation is finished, restart the computer.
    6. Visit the Windows Update or Microsoft Update Web site to verify whether the update is offered. Alternatively, wait until Automatic Updates runs again.
Method 5: Contact Microsoft Product Support for help
Contact Microsoft Product Support for help. To contact Microsoft Product Support, follow these steps:
  1. Click Start, point to All Programs, and then click Windows Update or Microsoft Update.
  2. Click Get help and support, and then follow the instructions on the Web site.
Additional Resources:

976982 (http://support.microsoft.com/kb/976982) You receive error 0x643, error code 0x80070643 or updates may be re-offered when you try to install .NET Framework updates when using Windows Update or Microsoft Updates



APPLIES TO
  • Microsoft Update
  • Microsoft Windows Update
  • Windows Defender
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