Você recebe o erro 0x80240020 ao usar o site do Windows Update, o site do Microsoft Update ou o WSUS para instalar atualizações

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Sumário

Este artigo descreve como resolver mensagens de erro que você pode receber ao tentar baixar atualizações do site do Microsoft Windows Update, do site do Microsoft Update ou de um servidor do Microsoft Windows Server Updates Services (WSUS). Para solucionar esse problema, a seção "Resolução" inclui etapas para o Microsoft Windows 2000, Windows Server 2003 e Windows XP. Este artigo também inclui uma seção "Solução alternativa". Você pode seguir as etapas na seção "Solução alternativa" se as etapas na seção "Resolução" não resolverem o problema.

Sintomas

Ao tentar baixar e instalar atualizações do site do Microsoft Windows Update, do site do Microsoft Update ou de um servidor do Windows Server Update Services (WSUS), você pode receber a seguinte mensagem de erro:
0x80240020

Causa

Esse problema ocorre se o serviço Atualizações automáticas não for capaz de representar o usuário que efetuou logon para concluir o download e instalar a atualização.

Resolução

Para resolver este problema em um computador executando o Windows 2000, siga as etapas na Seção A. Para resolver este problema em um computador executando o Windows Server 2000 ou Windows XP, siga as etapas na Seção B.

Seção A: Windows 2000

Etapa 1: Efetue logon e execute o Microsoft Internet Explorer como um usuário membro do grupo local Administradores

  1. Faça logon no computador como membro do grupo de Administradores local.
  2. Clique com o botão direito no ícone Internet Explorer , clique em Executar como e execute o programa como um usuário membro do grupo de Administradores local.
  3. Visite o site do Windows Update, o site do Microsoft Update ou estabeleça uma conexão com um servidor do WSUS.

Etapa 2: verificar se o Cliente para redes Microsoft está instalado

  1. Clique em Iniciar, em Executar, digite ncpa.cple clique em OK.
  2. Clique com o botão direito na conexão de área local associada com o adaptador de rede e clique em Propriedades.
  3. Verifique se Cliente para Redes Microsoft é exibido na caixa Esta conexão usa estes itens . Verifique se a caixa de seleção ao lado de Cliente para Redes Microsoft está selecionada. Se Cliente para Redes Microsoft não é exibido na caixa Esta conexão usa estes itens , siga estas etapas:
    1. Clique em Instalar, em Cliente e em Adicionar.
    2. Clique em Cliente para Redes Microsoft, em OK e em Sim .

Etapa 3: Verifique se o Serviço de Transferência Inteligente de Segundo Plano e o Serviço de Notificação de Eventos do Sistema são iniciados

Observação O Serviço de Transferência Inteligente de Segundo Plano (BITS) depende do Serviço de Notificação de Eventos do Sistema (SENS) no Windows 2000.
  1. Clique em Iniciar, em Executar, digite services.msc e clique em OK.
  2. Na lista Nome , clique duas vezes em Notificação de Eventos do Sistema.
  3. Na caixa de diálogo Tipo de Inicialização , clique em Automático.
  4. Clique em Iniciar, aguarde até o serviço iniciar e clique em OK.
  5. Repita as etapas de 2 a 4 desse procedimento para o Serviço de Transferência Inteligente em Segundo Plano.

Etapa 4: Fazer o login na sessão do console do Windows 2000 Server

Observação Essa etapa se aplica apenas ao Windows 2000 Server.

Observação O Serviço de Transferência Inteligente de Segundo Plano não oferece suporte a sessões de Serviços de Terminal no Windows 2000. O Serviço de Transferência Inteligente de Segundo Plano pode enviar o trabalho de download apenas usando as credenciais do computador. Se o firewall ou o proxy exigir autenticação no nível do usuário, o trabalho de download falhará.
  1. Faça logon localmente no computador. Não use uma sessão do Terminal Services.
  2. Visite o site do Windows Update, o site do Microsoft Update ou estabeleça uma conexão com um servidor do WSUS.

Etapa 5: Verifique se as entradas de Registro a seguir estão presentes

Importante Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. No entanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para obter mais proteção, faça um backup do Registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:
322756 Como fazer backup e restaurar o Registro no Windows
  1. Clique em Iniciar, em Executar, digite Regedit e clique em OK.
  2. Expanda a seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\SensLogn
  3. Verifique se as entradas de Registro a seguir estão presentes:
    Recolher esta tabelaExpandir esta tabela
    NomeTipo do valorDados do valor
    AssíncronaDWORD00000001
    DLLNameCadeia de caracteresWlNotify.dll
    ImpersonateDWORD00000001
    LockCadeia de caracteresSensLockEvent
    LogoffCadeia de caracteresSensLogoffEvent
    LogonCadeia de caracteresSensLogonEvent
    MaxWaitDWORD00000258
    SafeDWORD00000001
    ShutdownCadeia de caracteresSensShutdownEvent
    StartScreenSaverCadeia de caracteresSensStartScreenSaverEvent
    StartShellCadeia de caracteresSensStartShellEvent
    InicializaçãoCadeia de caracteresSensStartupEvent
    StopScreenSaverCadeia de caracteresSensStopScreenSaverEvent
    UnlockCadeia de caracteresSensUnlockEvent
  4. Faça as alterações ou adições necessárias.

    O exemplo a seguir explica como alterar o valor da entrada Shutdown do Registro:
    1. Clique com o botão direito em Desligamento e clique em Modificar.
    2. Na caixa de diálogo Dados do valor , digite SensShutdownEvent para substituir o valor existente e clique em OK.
    O exemplo a seguir explica como adicionar uma nova entrada de Registro:
    1. No painel à esquerda, clique em SensLogn.
    2. Clique em Editar, aponte para Novo e clique no tipo de valor que você deseja. Para nosso exemplo, clique em Valor DWORD.
    3. Digite Representar e pressione ENTER.
    4. Clique com o botão direito em Representar e clique em Modificar.
    5. Na caixa de diálogo Dados do valor , digite 1 e clique em OK.
  5. Clique em Iniciar, em Executar, copie e cole ou digite o seguinte comando na caixa Abrir e clique em OK:
    Regsvr32 wlnotify.dll /s
  6. Se foi feita qualquer alteração no Registro, será necessário reiniciar o computador. Depois, tente novamente baixar e instalar a atualização.

Seção B: Windows Server 2003 e Windows XP

Etapa 1: efetuar logon e executar o Internet Explorer como um usuário membro do grupo local Administradores

  1. Faça logon no computador como membro do grupo de Administradores local.
  2. Clique com o botão direito no ícone Internet Explorer , em Executar como e execute o programa como um usuário membro do grupo de Administradores local.
  3. Visite o site do Windows Update, o site do Microsoft Update ou estabeleça uma conexão com um servidor do WSUS.

Etapa 2: Verifique se as entradas de Registro a seguir estão presentes

Importante Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. No entanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para obter mais proteção, faça um backup do Registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:
322756 Como fazer backup e restaurar o Registro no Windows
  1. Clique em Iniciar, em Executar, digite Regedit e clique em OK.
  2. Expanda a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\SensLogn
  3. Verifique se as entradas de Registro a seguir estão presentes:
    Recolher esta tabelaExpandir esta tabela
    NomeTipo do valorDados do valor
    AssíncronaDWORD00000001
    DisconnectCadeia de caracteresSensDisconnectEvent
    DLLNameCadeia de caracteresWlNotify.dll
    ImpersonateDWORD00000001
    LockCadeia de caracteresSensLockEvent
    LogoffCadeia de caracteresSensLogoffEvent
    LogonCadeia de caracteresSensLogonEvent
    MaxWaitDWORD00000258
    PostShellCadeia de caracteresSensPostShellEvent
    ReconnectCadeia de caracteresSensReconnectEvent
    SafeDWORD00000001
    ShutdownCadeia de caracteresSensShutdownEvent
    StartScreenSaverCadeia de caracteresSensStartScreenSaverEvent
    StartShellCadeia de caracteresSensStartShellEvent
    InicializaçãoCadeia de caracteresSensStartupEvent
    StopScreenSaverCadeia de caracteresSensStopScreenSaverEvent
    UnlockCadeia de caracteresSensUnlockEvent
  4. Faça as alterações ou adições necessárias.

    O exemplo a seguir explica como alterar o valor da entrada Shutdown do Registro:
    1. Clique com o botão direito em Desligamento e clique em Modificar.
    2. Na caixa de diálogo Dados do valor , digite SensShutdownEvent para substituir o valor existente e clique em OK.
    O exemplo a seguir explica como adicionar uma nova entrada de Registro:
    1. No painel à esquerda, clique em SensLogn.
    2. Clique em Editar, aponte para Novo e clique no tipo de valor que você deseja. Para nosso exemplo, clique em Valor DWORD.
    3. Digite Representar e pressione ENTER.
    4. Clique com o botão direito em Representar e clique em Modificar.
    5. Na caixa de diálogo Dados do valor , digite 1 e clique em OK.
  5. Se foi feita qualquer alteração no Registro, será necessário reiniciar o computador. Depois, tente novamente baixar e instalar a atualização.
Observação As subchaves do Registro e valores na tabela na etapa 3 aplicam-se somente ao Windows Server 2003 e Windows XP. Não é possível importar essas subchaves e valores do Registro de um computador com base em Windows Server 2003 ou Windows XP para um computador com base em Windows 2000.

Seção C: Windows Vista e Windows Server 2008

Etapa 1: Faça o login no computador como Administrador ou como um usuário com Permissões administrativas

  1. Faça o login como um usuário que é administrador local ou é um membro do grupo de Administradores local.
  2. Visite o site do Windows Update ou o site do Microsoft Update e verifique se há atualizações
Para obter mais informações sobre as contas do Administrador, visite o seguinte site da Microsoft:
http://windows.microsoft.com/pt-br/windows-vista/What-is-an-administrator-account


Observação Para verificar o tipo de login atual, siga estas etapas:
  1. Clique no botão Iniciar
    Recolher esta imagemExpandir esta imagem
    e
    clique no ícone de usuário no canto superior direito do menu Iniciar .
  2. Na seção Fazer alterações em sua conta , clique em Gerenciar contas de usuário.
  3. Localize seu nome de usuário conectado atualmente na seção Nome de usuário . Se você estiver listado como no grupo de Administradores, você está conectado com permissões administrativas.

Etapa 2: Verifique se o Serviço de Transferência Inteligente de Segundo Plano e o Serviço de Notificação de Eventos do Sistema são iniciados

  1. Clique no botão Iniciar
    Recolher esta imagemExpandir esta imagem
    ,
    digite services.msc na área do texto Iniciar Pesquisa e clique em services.msc na lista de programas.
  2. Clique duas vezes em Serviço de Transferência Inteligente em Segundo Plano.
  3. Na seção Status do Serviço , certifique-se de que o serviço está listado como Iniciado.
  4. Se o status é listado como Parado, clique em Iniciar e em OK.
  5. Tente instalar as atualizações novamente.

Etapa 3: Verifique a Resolução de Nomes no computador

  1. Feche as janelas do navegador do Windows Update ou Microsoft Update.
  2. Clique no botão Iniciar
    Recolher esta imagemExpandir esta imagem
    ,
    digite Prompt de Comandoe, na lista de resultados, clique com o botão direito em Prompt de Comando e clique em Executar como Administrador. Caso uma senha de administrador ou uma confirmação seja solicitada, digite a senha ou clique em Continuar.
  3. Na janela Prompt de Comando, digite os seguintes comandos. Pressione ENTER após cada comando:
    nslookup
    ns
    o nome do seu computador
    Observação Nesta etapa, substitua o nome do seu computador pelo nome do seu computador. Para localizar o nome do computador, clique no botão Iniciar
    Recolher esta imagemExpandir esta imagem
    ,
    clique com o botão direito em Computador e clique em Propriedades. O nome do seu computador está listado na seção Nome do computador, domínio e configurações do grupo de trabalho .
  4. Ao pressionar ENTER após digitar o nome do computador no prompt de comando, você deverá ver o endereço IP do seu Sistema de Nome de Domínio (DNS) retornar.
  5. Tente instalar as atualizações novamente.

Como Contornar

Como solução alternativa, configure Atualizações automáticas para baixar e instalar atualizações. Para fazer isso, execute as seguintes etapas:

Windows 2000

  1. Clique em Iniciar, aponte para Configurações e clique em Painel de Controle.
  2. Clique duas vezes em Atualizações Automáticas.
  3. Clique em Baixar as atualizações automaticamente e instale-as no agendamento que eu especificar.
  4. Clique para selecionar o dia e hora que você deseja baixar e instalar as atualizações e clique em OK.

Windows XP

  1. Clique em Iniciar e em Painel de Controle
  2. Clique duas vezes em Atualizações Automáticas.
  3. Clique em Automático (recomendável).
  4. Clique para selecionar o dia e hora que você deseja baixar e instalar as atualizações e clique em OK.

Windows Server 2003

  1. Clique em Iniciar e em Painel de Controle.
  2. Clique duas vezes em Atualizações Automáticas.
  3. Clique para marcar as seguintes caixas de seleção:
    Manter meu computador atualizado. Com esta configuração habilitada, o software Windows Update pode ser atualizado, automaticamente, antes de serem aplicadas outras atualizações.
  4. Clique em Baixar as atualizações automaticamente e instale-as no agendamento que eu especificar.
  5. Clique para selecionar o dia e hora que você deseja baixar e instalar as atualizações e clique em OK.
Para obter informações adicionais sobre como agendar as Atualizações automáticas, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft :
327838 Como agendar atualizações automáticas no Windows Server 2003, Windows XP e Windows 2000
Windows Vista e Windows Server 2008
  1. Abra o Windows Update. Para fazer isso, clique no botão Iniciar
    Recolher esta imagemExpandir esta imagem
    ,
    clique em Todos os Programas e em Windows Update.
  2. No painel à esquerda, clique em Alterar configurações.
  3. Clique na opção de atualização automática que deseja.
  4. Para receber atualizações importantes e recomendadas para o computador, em Atualizações recomendadas, clique para selecionar a caixa de diálogo Incluir as atualizações recomendadas ao baixar, instalar ou notificar-me sobre atualizações .
  5. Clique em OK.

    Caso uma senha de administrador ou uma confirmação seja solicitada, digite a senha ou forneça a confirmação.

Referências

Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft :
902093 Como ler o arquivo Windowsupdate.log

Propriedades

ID do artigo: 910341 - Última revisão: quinta-feira, 13 de outubro de 2011 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Update
  • Microsoft Windows Update
Palavras-chave: 
kbtshoot kbprb KB910341

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