How to upgrade a Dexterity-based application in Microsoft Dynamics GP by using the Dexterity Source Code Control Service

Article ID: 910527 - View products that this article applies to.
Expand all | Collapse all

On This Page

SUMMARY

To upgrade a Dexterity-based application in Microsoft Dynamics GP or in Microsoft Business Solutions - Great Plains, you must use the Dexterity Source Code Control Service.

INTRODUCTION

This article describes how to upgrade a Dexterity-based application by using the Dexterity Source Control Service. The following steps upgrade an application from the old Dexterity version to your new Dexterity version.

MORE INFORMATION

The following steps assume that you have already installed Microsoft Visual SourceSafe 6.0 (VSS) and the Dexterity Source Code Control Service (DSCCS). The DSCCS can be installed from the Tools\Dex\DSCCS folder on Microsoft Great Plains CD 2.

Step 1: Set up the DSCCS.

  1. Click Start, and then click Control Panel.
  2. Click Dexterity SCCS.
  3. In the Provider list, click Microsoft Visual SourceSafe.
  4. Click Browse, and then locate and click the SrcSafe.ini initialization file. By default, the path is as follows:
    C:\Program Files\Microsoft Visual Studio\VSS\SrcSafe.ini
  5. Click OK.

Step 2: Set up VSS.

  1. Click Start, point to All Programs, point to Microsoft Visual SourceSafe, and then click Visual SourceSafe 6.0 Admin.
  2. Log on as the Admin user.
  3. Click Users, and then click Add User. The program creates a user for your user name without a password.
  4. Click Start, point to All Programs, point to Microsoft Visual SourceSafe, and then click Visual SourceSafe 6.0.
  5. Log on as your user name.
  6. Click the root node on the tree, and then click Create Project on the File menu.
  7. Type the name of your development project. For example, type Project. The project can be the name of the dictionary or the name of the chunk file.

Step 3: Create the development environment.

  1. Make sure that your development project is in a subfolder of your new Dexterity installation. The C:\Dex800\Project subfolder is used as an example in this procedure.
  2. Copy the old development dictionary that contains your code to the subfolder. For example, copy the Proj_Dyn.dic dictionary file to the C:\Dex800\Project subfolder.

    Note Make sure that you also copy the associated *.dat and *.idx tables so that you keep your references and worksets together.
  3. Copy the Dexterity new Dex.ini file to this subfolder. For example, the copy operation will have the following path:
    C:\Dex800\Project\Dex.ini
  4. Create a shortcut for the Dexterity new Dex.exe file, and then move the shortcut to this subfolder.
  5. Modify the shortcut for Dex.exe. Add the path of the dictionary and the path of the Dex.ini file to the target as parameters. For example, the path will appear as follows:
    C:\Dex800\Dex.exe C:\Dex800\Project\Proj_Dyn.dic C:\Dex800\Project\Dex.ini
    Always use this shortcut when you are developing this project from now on. Each project must have its own Dex.ini file. The settings for the Dexterity Source Code Control Service are stored in the Dex.ini file.

Step 4: Create a connection to VSS.

  1. Start Dexterity by using the shortcut. Your dictionary will be directly loaded.
  2. On the Edit menu, click Options, and then click the Source Control tab.
  3. Set the Repository Name field to the computer that is running the Dexterity Source Control Service. If you are using the local Dexterity Source Code Control Service, set the Repository Name field to localhost.
  4. Type your user name.
  5. Leave the password blank.
  6. In the Project Name field, type Project.
  7. Set the Temp File Location field to the local Temp folder.
  8. Make sure that the Original Dictionary field is set to the old Dexterity original Dynamics.dic file without modifications. For example, the original dictionary is C:\Dyn750\Dynamics.dic.
  9. Click to select all three check boxes.
  10. Validate the connection.
  11. Add \750 to the name in the Project Name field, For example, the project name field will be Project\750.
  12. Click OK.
You will now have separate subprojects for each version. However, the validate feature does not understand subprojects.

Step 5: Perform the initial check-in of the old Dexterity code.

  1. In Dexterity, click Source Control on the Explorer menu, and then click Update SCC State.
  2. For each item in the Alternate Form and Report lists, you must open the form or report to change the state from Main Product. Double-click the item to open the form definition or report definition window, and then click OK.
  3. On the Explorer menu, click Source Control, and then click Check In.
  4. Click Insert All, and then type a description. For example, type Initial 7.50 Check-In. Click Check in, and then close the window.
  5. On the Explorer menu, click Source Control, and then click Update Index File.

Step 6: Perform the initial check-in of the old Dexterity code as the start of the new Dexterity project.

  1. On the Edit menu, click Options, and then click Source Control. In the Project Name field, change \750 to \850.
  2. Click OK.
  3. In Dexterity, click Source Control on the Explorer menu, and then click Update SCC State.
  4. For each item in the Alternate Form and Report lists, you must open the form or report to change the state from Main Product. Double-click the item to open the form definition or report definition window, and then click OK.
  5. In the code, note any references that add palette items or toolbar menu items, and then delete the code to avoid errors later.
  6. On the Explorer menu, click Source Control, and then click Check In.
  7. Click Insert All, and then type a description. For example, type Initial 8.00 Check In. Click Check In, and then close the window.
  8. On the Explorer menu, click Source Control, and then click Update Index File.

Step 7: Prepare for the new Dexterity project.

  1. Make sure that you have a backup of the old Dexterity Development dictionary. Then, delete it. For example, delete C:\Dex800\Project\Proj_Dyn.dic.
  2. Copy an unmodified new Dynamics.dic file from your Microsoft Dynamics GP installation into the folder, and then rename it Proj_Dyn.dic. This dictionary will become your new development dictionary.
  3. On the Edit menu, click Options, and then click Source Control. In the Original Dictionary field, change the path of the new Dexterity dictionary. For example, change it to C:\Dyn800\Dynamics.dic.
  4. Click OK.

Step 8: Create a new Dexterity development dictionary.

  1. In Dexterity, click Source Control on the Explorer menu, and then click Update SCC State.
  2. On the Explorer menu, click Source Control, and then click Update.
  3. Click Use Index File. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    894699 How to use an index file and the Great Plains Dexterity source code control functionality to make sure that the resources that you create maintain the same resource ID in different builds and versions of your code
  4. Click OK.
  5. Leave all the resources selected, and then click OK to start the update.
  6. If your code contains references to palettes or toolbars, you may receive errors. If you do receive errors, go to step 9.

Step 9: Fix the code.

  1. Check out any code that is failing. Make the appropriate changes for the new version of Dexterity and Microsoft Dynamics GP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    894701 Tips and references for upgrading your Great Plains Dexterity-based application to Great Plains 8.0 Dexterity
  2. After everything is working in test mode, click Source Control on the Explorer menu, and then click Check In. Check in all the changes.
  3. On the Explorer menu, click Source Control, and then click Update Index File.
Now you are finished. You can create your chunk.

Properties

Article ID: 910527 - Last Review: July 26, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Dynamics GP 2010
  • Dexterity, when used with:
    • Microsoft Dynamics GP 10.0
    • Microsoft Dynamics GP 9.0
    • Microsoft Business Solutions–Great Plains 8.0
Keywords: 
kbmbsmigrate kbhowto KB910527

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com