Possibile blocco della creazione guidata MiniSetup di Sysprep quando si esegue il procedura guidata per installazione di un Microsoft Windows XP con Service Pack 2 immagine

Traduzione articoli Traduzione articoli
Identificativo articolo: 910678 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si esegue il guidata di MiniSetup di Sysprep per installare Microsoft Windows XP con immagine del Service Pack 2 (SP2), la procedura guidata potrebbe bloccarsi dopo l'avvio il processo di installazione driver video. Questo problema si verifica se la voce di OempnpDriversPath nel file Sysprep.inf punta a Intel video driver aggiornati sul sito Web Dell o sul sito Web di Intel.

Si nota questo problema se il driver video Intel Ŕ stato impostato utilizzando il Services.exe - installazione comando.

Cause

Questo problema si verifica a causa di un problema con il thread di interfaccia utente grafica nel processo Services.exe. All'avvio del processo di Services.exe, gli eventi seguenti si verificano nel seguente ordine:
  1. Vengono inizializzati tutti i file DLL collegata in modo statico.
  2. Il file Acgenral.dll carica il file di Shell32.dll.
  3. File Comctl32.dll viene caricato il file Shell32.dll anche se Services.exe non utilizza mai il file binario.
  4. Quando viene eseguito il thread svcctrlMain per il file Shell32.dll un \ funzione, il thread svcctrlMain trasforma in un thread di modalitÓ grafica. Inoltre, il processo Services.exe si trasforma in un processo in modalitÓ GUI.
  5. Il thread svcctrlMain interrompe l'esecuzione quando il processo Services.exe Ŕ ancora in esecuzione.
Quando si verificano questi eventi vengono terminati tutti gli aspetti modalitÓ GUI di Services.exe, ma Services.exe Impossibile ripristinare la modalitÓ GUI.

Quando il modulo di coinstallazione driver di periferica Intel viene avviato nel processo Services.exe, la funzione di UpdateDriverForPlugAndPlayDevices chiama il file Newdev.dll. Il file di Newdev.dll verrÓ eseguito nel contesto di Services.exe perchÚ Ŕ un processo plug and play. Tuttavia, non vi Ŕ alcun aspetto modalitÓ GUI al processo che Ŕ visibile all'utente. Di conseguenza, Newdev.dll crea un file invisibile all'utente con alcune impostazioni di proprietÓ predefinite. Quindi, Newdev.dll tenta di eseguire automaticamente il file. Tuttavia, Newdev.dll Impossibile eseguire il file in modo invisibile all'utente perchÚ Services.exe Impossibile ripristinare la modalitÓ GUI.

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per applicare questo aggiornamento rapido (hotfix), Ŕ necessario Windows XP Service Pack 2 (SP2) installato nel computer. ╚ necessario che siano tutti i aggiornamenti di Windows pi¨ aggiornate disponibili installati nel computer. ╚ necessario l'aggiornamento rapido KB883667 installato nel computer.

NecessitÓ di riavvio

Non Ŕ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaformaRequisiti SPRamo del servizio
Acadproc.dll5.1.2600.279539.42414/11 / 200514: 58x 86SP2SP2QFE

Informazioni

Per ulteriori informazioni sulla terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft


I prodotti di terze parti che in questo articolo viene descritto sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia, implicita o di altra natura, relativa alle prestazioni o all'affidabilitÓ di questi prodotti.

ProprietÓ

Identificativo articolo: 910678 - Ultima modifica: mercoledý 29 agosto 2007 - Revisione: 2.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Service Pack 2áalle seguenti piattaforme
    • Microsoft Windows XP Professional
Chiavi:á
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbbug kbfix kbpubtypekc KB910678 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 910678
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com