Help and Support

文章编号: 910998 - 最后修改: 2007年10月26日 - 修订: 1.4

FIX: 为应用程序不能播放 WMDRM 保护的内容或获取播放新 WMDRM 保护内容的许可证

展开全部 | 关闭全部

症状

当您使用 Microsoft Windows Media Player 或在 Windows Media Format 9.5 SDK 构建的应用程序时,则您将遇到以下行为:
  • 应用程序无法播放 Windows Media 数字权限管理 (WMDRM) 保护的内容。
  • 应用程序无法获取要播放新 WMDRM 保护内容的许可证。

原因

Microsoft 仍在研究此问题的原因。

解决方案

受支持的修补程序现已提供 Microsoft,但它仅用于更正本文所述的问题。 只适用它于正经历此特定问题的系统。 此修复程序可能会接受进一步的测试。 因此,如果您受此问题的影响不严重,我们建议您等待包含此修复程序下一版本。

要立即解决此问题,与 Microsoft 产品支持服务以获取该修补程序。 有关 Microsoft 产品支持服务电话号码和支持费用信息的完整列表请访问下面的 Microsoft Web 站点:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
请注意 特殊的情况下收通常情况下收取的支持电话电话服务的费用如果,可免 Microsoft 支持专业人员确定某个特定的更新能够解决您的问题。 通常的支持成本将应用于其他支持问题和执行不适用于特定更新的问题。

系统必备组件

您必须具有 Microsoft 知识库 (KB) 文章 891122 要应用此修补程序中介绍该更新。 有关详细信息,单击下面的文章编号,以查看 Microsoft 知识库中的相应:
891122? (http://support.microsoft.com/kb/891122/EN-US/ ) Windows Media 数字权限管理的启用播放机的更新已推出

Windows Media Player 10 在 Windows XP

从 Microsoft 下载中心下载下列文件有:
收起这个图片展开这个图片
Download
Download the WindowsMedia10-KB910998-x86-INTL.exe package now. (http://download.microsoft.com/download/0/e/1/0e179769-7ccf-427b-9160-47ef903cbde5/windowsmedia10-kb910998-x86-intl.exe)

有关如何下载 Microsoft 支持文件的详细信息,单击下面的文章编号,以查看 Microsoft 知识库中的文章:
119591? (http://support.microsoft.com/kb/119591/ ) 如何从联机服务获取 Microsoft 支持文件
Microsoft 扫描病毒此文件。 Microsoft 使用最新的病毒检测软件在发布该文件的日期中获得的。 该文件存储在安全性得到增强防止任何未经授权的更改对文件的服务器上。

文件属性 (或更高版本的文件属性),将程序此修复程序的英文版下表中列出。 该日期和为这些文件的时间按协调世界时 (UTC) 列出。 当您查看文件信息时, 它被转换为本地时间。 要了解 UTC 和本地时间的时差,请使用控制面板中的日期和时间工具 时区 选项卡。
收起该表格展开该表格
文件名称文件版本文件大小日期时间平台操作系统
Blackbox.dll10.0.0.3991290,81607 Dec 200512:05x 86Windows XP
Drmv2clt.dll10.0.0.3991505,34407 Dec 200512:05x 86Windows XP

状态

Microsoft 已确认这是本文"适用于"一节中列出的在 Microsoft 产品。

更多信息

此修补程序不能专门修复的问题与 WMDRM 系统。 应用此修补程序后,WMDRM 系统会尝试重新初始化自身进行正确播放,如果计算机变得无法播放受保护的内容。

WMDRM 系统 reinitializes 时, 用户必须重新获取,或还原当前存储在计算机上的任何受保护内容的许可证。

这篇文章中的信息适用于:
  • Windows Media Format 9.5 Software Development Kit
关键字:?
kbmt kbfix kbqfe kbhotfixserver KB910998 KbMtzh
机器翻译机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。如果您发现了错误并希望帮助我们提高机器翻译技术,请完成文章末尾的在线调查。
点击这里察看该文章的英文版: 910998? (http://support.microsoft.com/kb/910998/en-us/ )
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

文章翻译