文章编号: 910998 - 最后修改: 2007年10月26日 - 修订: 1.4

修复: 应用程序不能播放受 WMDRM 保护的内容或获得许可证才能播放受 WMDRM 保护的新内容

展开全部 | 关闭全部

症状

褰撴偍浣跨敤 Microsoft Windows Media Player 锛屾垨 Windows Media 格式 9.5 SDK 上生成的应用程序椂您遇到以下行为:
  • 应用程序不能播放 Windows 媒体数字权限管理 (WMDRM) 受保护的内容。
  • 应用程序无法获取许可证才能播放受 WMDRM 保护的新内容。

原因

Microsoft 仍调查此问题的原因。

解决方案

受支持的修补程序现已提供从 Microsoft,但只用于解决本文所述的问题。 仅将它应用于出现这一特定问题的系统。 此修补程序可能还会接受进一步的测试。 因此,如果您不会受到严重影响姝 ら 棶棰樺,我们建议您等待包含此修补程序在下一个版本。

要立即解决此问题,请与 Microsoft 产品支持服务获取修复程序。 Microsoft 产品支持服务电话号码和关于支持费用的信息的完整列表,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
注意 在特殊的情况下通常会导致支持电话的费用可能被取消,如果 Microsoft 支持专业人员确定特定的更新才能解决您的问题。 将正常收取支持费用将应用于其他支持问题和对于特定更新程序无法解决的问题。

系统必备组件

您必须具有 891122 要应用此修补程序安装的 Microsoft 知识库 (KB) 文章中介绍的更新。 有关详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
891122? (http://support.microsoft.com/kb/891122/EN-US/ ) 有可用的已启用 Windows 媒体数字权限管理的播放机更新

Windows Media Player Windows XP 上的 10

以下文件是可从 Microsoft 下载中心下载:
收起这个图片展开这个图片
Download
Download the WindowsMedia10-KB910998-x86-INTL.exe package now. (http://download.microsoft.com/download/0/e/1/0e179769-7ccf-427b-9160-47ef903cbde5/windowsmedia10-kb910998-x86-intl.exe)

有关如何下载 Microsoft 的支持文件的详细信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
119591? (http://support.microsoft.com/kb/119591/ ) 濡備綍鑾峰彇 Microsoft 的支持文件从联机服务
Microsoft 扫描此文件的病毒。 Microsoft 使用该文件的过帐日期上可用的最新病毒检测软件。 该文件存储在安全性得到增强的服务器,以帮助防止未经授权的任何更改对该文件。

姝 や 慨琛 ョ ▼ 搴忕殑鑻辨枃鐗堝叿鏈具有文件属性 (或更新的文件属性) 在下表中列出。 日期和时间杩欎簺鏂囦欢鐨勬列出协调世界时 (UTC)。 当您查看文件信息时,将转换为本地时间。 若要 UTC 与本地时间之间差值使用控制面板中日期和时间工具中的 时区 选项卡。
收起该表格展开该表格
文件名称鏂囦欢鐗堟湰文件大小日期时间平台鎿嶄綔绯荤粺
Blackbox.dll10.0.0.3991290,8162005 年十二月 7 日12: 05x86Windows XP
Drmv2clt.dll10.0.0.3991505,3442005 年十二月 7 日12: 05x86Windows XP

状态

Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中有 bug。

更多信息

姝 や 慨琛 ョ ▼ 搴忓没有专门解决与 WMDRM 系统的问题。 搴旂敤姝 や 慨琛 ョ ▼ 搴忓悗,WMDRM 系统在尝试重新初始化自身允许用于正确播放,如果计算机变得无法播放受保护的内容。

当重新初始化 WMDRM 系统时,用户必须重新获取或还原当前存储在计算机的任何受保护内容的许可证。

这篇文章中的信息适用于:
  • Windows Media Format 9.5 Software Development Kit
关键字:?
kbmt kbfix kbqfe kbhotfixserver KB910998 KbMtzh
机器翻译机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 910998? (http://support.microsoft.com/kb/910998/en-us/ )
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。
 

文章翻译