Article ID: 911123 - Last Review: October 4, 2011 - Revision: 6.0

Error: Session Terminated (when connecting an Xbox 360 console to a computer running Windows Media Center)

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SYMPTOMS

When you try to connect your Xbox 360 console to a computer running Microsoft Windows Media Center, you cannot connect, and you receive the following error message on your Xbox 360 console:
Xbox 360 Error Message: Session Terminated
Another user or application on the Windows Media Center-based PC has disconnected this device.

CAUSE

Below you will find information about the various reasons why the connection between a computer running Windows Media Center and an Xbox 360 Media Center Extender might fail, along with solutions for how to fix the problem.

THINGS TO TRY

Solution 1

Programs that are running on the system may be trying to send messages to your Xbox 360 console when it has a session with the Media Center. Unauthorized messages will cause the session between the Media Center and your Xbox 360 console to disconnect.

To resolve this issue in Windows XP, follow these steps:
  1. Click Start, click Run, type eventvwr.msc, and then click OK.
  2. Click Application, and then find any event where Error appears under Type and where Media Remote Manager appears under Source.
  3. Double-click each item that satisfies these two conditions to view the description of the event. Look for a description that is similar to the following:
    Unauthorized window was detected while running the Media Center Experience, with file name 'C:\PROGRA~1\........
    This message will report the program that is trying to send the message to your Xbox 360 console.
  4. Remove or disable the notification service for the application that is listed under Description. For more information about how to remove or disable the notification service for the application, see the manual for the application, or contact the manufacturer of the application.
To resolve this issue in Windows 7 or Windows Vista, follow these steps:
  1. Click Start.
  2. In the Search programs and files box, type event viewer. When Event Viewer appears in the search list, click it.
  3. Click the arrow to the left of Applications and Services Logs, and then click Media Center.
  4. Find any event where Error appears under Type and where Media Remote Manager appears under Source.
  5. Double-click each item that satisfies these two conditions to view the description of the event. Look for a description that is similar to the following:
    Unauthorized window was detected while running the Media Center Experience, with file name 'C:\PROGRA~1\........
  6. Remove or disable the notification service for the application that is listed under Description. For more information about how to remove or disable the notification service for the application, see the manual for the application, or contact the manufacturer of the application.
Try to connect your console to your computer again. If you cannot connect, try Solution 2.

Solution 2 (Windows XP only)

The Xbox 360 console uses Fast-User Switching to connect to a computer that is running Windows Media Center. If Fast-User Switching has been turned off on the computer, the Xbox 360 console will not be able to connect. To make sure that Fast-User Switching is turned on, follow these steps:
  1. On the computer, click Start, click Run, type nusrmgr.cpl, and then click OK.
  2. Click Change the way users log on or off.
  3. Make sure that the Use Fast User Switching box is selected.
  4. Click Apply Options.
Try to connect your console to your computer again. If you cannot connect, try Solution 3.

Solution 3

Sometimes other media programs that are installed on the computer running Windows Media Center (such as Ahead Nero) can prevent your Xbox 360 console from playing the media. Temporarily remove or disable these other media programs to determine whether they are causing the conflict.

Try to connect your console to your computer again. If you cannot connect, try Solution 4.

Solution 4

Certain required firewall ports might not be open on the computer running Windows Media Center. For information about which firewall ports should be open, please see the following article in the Microsoft Knowledge Base:
911728  (http://support.microsoft.com/kb/911728/ ) How to open firewall ports to connect your Xbox 360 console to a Windows Media Center-based computer
If opening those ports does not correct the problem, try Solution 5.

Solution 5

When interactive logon messages are used, the interactive logon message pops up during the Media Center Extender logon procedure and prevents the procedure from completing.

Use the Microsoft Management Console (MMC) manager to disable interactive logon for computers running Windows XP Media Center edition. Interactive logon settings are defined in local or domain computer policies. To review and change these settings, follow these steps:
  1. On your computer running Windows XP Media Center edition, click Start, click Run, type gpedit.msc, and then click OK.
  2. In Group Policy, expand Local Computer Policy, expand Computer Configuration, expand Windows Settings, expand Security Settings, expand Local Policies, and then select Security Options.
  3. Double-click Interactive logon: Message text for users attempting to log on, clear any text for this entry, and then click OK.
  4. Double-click Interactive logon: Message title for users attempting to log on, clear any text for this entry, and then click OK.
  5. On the File menu, click Exit to exit Group Policy.

MORE INFORMATION

For more information about Media Center Extenders, visit the following Microsoft Web site:
http://www.microsoft.com/windows/windows-media-center/default.aspx (http://www.microsoft.com/windows/windows-media-center/default.aspx)
For firewall configuration and troubleshooting steps, visit the following Microsoft Web site:
http://www.microsoft.com/windows/windows-media-center/learn-more/extenders/default.aspx (http://www.microsoft.com/windows/windows-media-center/learn-more/extenders/default.aspx)
The following are other reasons why your connection might be terminated:
  • The Data Execution Prevention (DEP) services in Windows XP Service Pack 2 (SP2) can cause a session to end when it is configured. We are investigating this issue.
  • Your hard drive might be formatted as FAT32. Check the formatting of your hard drive. If your hard drive has been formatted as FAT32, change the hard drives to an NTFS file system basic disk.

    To check the format of your hard drive, click Start, click Computer (or click My Computer, if you are using a version of Windows other than Windows Vista or Windows 7). Right-click your hard drive, and then click Properties. Look at the section titled File system and make sure that it does not say FAT32.
  • The computer's hard drive is using a dynamic disk. Media Center Extenders, such as the Xbox 360 console, do not work under a dynamic disk configuration. You must use basic disks.

Xbox Support

For information about how to contact Xbox Support, please visit the following Microsoft Web site:
http://www.xbox.com/support/contact (http://www.xbox.com/support/contact)
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

APPLIES TO
  • Xbox
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