Chybová zpráva v aplikaci Internet Explorer při pokusu o přístup k webu, která vyžaduje ověřování protokolem Kerberos na počítači se systémem Windows XP: "Chyba HTTP 401 - Neautorizováno: přístup byl odepřen kvůli neplatná pověření"

Překlady článku Překlady článku
ID článku: 911149 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Používáte aplikaci Microsoft Internet Explorer v počítači se systémem Microsoft Windows XP. Při pokusu o přístup k webu, který vyžaduje ověření protokolem Kerberos, můžete obdržet následující chybovou zprávu:
Chyba protokolu HTTP 401 - neoprávněný přístup: Přístup byl odepřen z důvodu neplatných pověření.

Příčina

K tomuto problému může dojít, pokud na webový server používá záznam o prostředku CNAME Domain Name System (DNS) kontaktovat server, který iniciuje ověřování pomocí protokolu Kerberos. (Tento server také vydá lístek protokolu Kerberos.) Přístup k webu pomocí aplikace Internet Explorer, aplikace Internet Explorer používá název hostitele serveru, namísto záznam o prostředku CNAME na kontakt se serverem. Proces ověřování nefunguje, protože pouze hlavní název služby (Service Principal Name – SPN) pro záznam prostředku CNAME je zaregistrován pro účet, který se používá k ověřování.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo řešení potíží je vyžadován, pravděpodobně budete muset vytvořit požadavek na samostatnou službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "K dispozici oprava Hotfix stahování" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Neexistují žádné požadavky.

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním časem a UTC časem kartě časové pásmo v položce Datum a čas v Ovládacích panelech.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Wininet.dll6.0.2800.1545587,26406-Duben 200609: 42X86SP1
Wininet.dll6.0.2900.2882663,55207. Duben 200604: 33X86SP2

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Důležité Tento oddíl, metody nebo úkol obsahuje kroky, které vám sdělit, jak upravit registr. Po nesprávné úpravě registru však mohou nastat závažné problémy. Postupujte proto pečlivě podle uvedených kroků. Pro zvýšení bezpečnosti registr zálohujte jestě před jeho úpravami. Potom můžete v případě potíží registr obnovit. Další informace o zálohování a obnovení registru naleznete následujícím článku znalostní v databáze Microsoft Knowledge Base:
322756Zálohování a obnovení registru v systému Windows


Po instalaci aktualizace softwaru, 911149, povolení této aktualizace pomocí následujícího postupu:
  1. Ukončete aplikaci Internet Explorer.
  2. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a pak klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main
  4. V nabídce Úpravy přejděte na příkaz Nový a klepněte na klíč.
  5. Zadejte FeatureControl a stiskněte klávesu ENTER.
  6. Přejděte na příkaz Nový v nabídce Úpravy
    FeatureControl
    podklíč registru, který jste vytvořili v kroku 5 vybrali a klepněte na klíč.
  7. Zadejte FEATURE_USE_CNAME_FOR_SPN_KB911149 a stiskněte klávesu ENTER.
  8. Nechte podklíč registru
    FEATURE_USE_CNAME_FOR_SPN_KB911149
    vybrána, který vytvořili v kroku 7, v nabídce Úpravy přejděte na Nový příkaz a potom klepněte na položku Hodnota DWORD.
  9. Zadejte Iexplore.exe a stiskněte klávesu ENTER.
  10. Iexplore.exe pravým tlačítkem myši a potom klepněte na příkaz změnit.
  11. V poli Údaj hodnoty zadejte hodnotu 1 a potom klepněte na tlačítko OK.

    Poznámka: Chcete-li se vrátit k předchozí chování pro zpětnou kompatibilitu, obnovit tato hodnota 0x0.
  12. Ukončete program Editor registru.
Poznámka: Klíč oprávnění ovládací prvek FEATURE_USE_CNAME_FOR_SPN_KB911149 mohou obsahovat také dalších aplikací, například:
Explorer\Main\FEATURE_USE_CNAME_FOR_SPN_KB911149\Excel.exe HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
Explorer\Main\FEATURE_USE_CNAME_FOR_SPN_KB911149\Powerpnt.exe HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
Pokud existuje více aplikací, můžete přidat položku DWORD s názvem "*" a hodnotou 1 k aktivaci této funkce u všech nainstalovaných aplikací, které používají adresy URL.

Další informace naleznete v následujících článcích znalostní báze Microsoft Knowledge Base:
326985Jak řešit potíže s protokolem Kerberos ve službě IIS (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 911149 - Poslední aktualizace: 20. února 2010 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Explorer 6.0 na těchto platformách
    • Microsoft Windows XP Professional
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxpsp1fix kbbug kbfix kbqfe kbpubtypekc KB911149 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:911149

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com