Mensaje de error en Internet Explorer al intentar obtener acceso a un sitio Web que requiere la autenticación Kerberos en un equipo: "error HTTP 401 - Unauthorized: Access es denied due to invalid credentials"

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Id. de artículo: 911149 - Ver los productos a los que se aplica este artículo
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Síntomas

Está utilizando Microsoft Internet Explorer en un equipo basado en Microsoft Windows XP. Cuando intenta obtener acceso a un sitio Web que requiere la autenticación Kerberos, es posible que reciba mensaje de error siguientes:
HTTP Error 401 - no autorizado: Acceso denegado debido a credenciales no válidas.

Causa

Este problema puede producirse si el sitio Web utiliza un registro de recursos CNAME en Sistema de nombres de dominio (DNS) para ponerse en contacto con el servidor que inicia la autenticación Kerberos. (Este servidor también emite el vale Kerberos). Cuando utiliza Internet Explorer para tener acceso al sitio Web, Internet Explorer utiliza el nombre de host del servidor en lugar del registro de recursos CNAME para ponerse en contacto con el servidor. El proceso de autenticación no funciona porque sólo el nombre principal de servicio (SPN) para el registro de recursos CNAME está registrado en la cuenta de que se utiliza para la autenticación.

Solución

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los servicios de cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de números de teléfono de Microsoft servicios de soporte técnico y de asistencia al cliente o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No hay requisitos previos.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SP
Wininet.dll6.0.2800.1545587,26406-Abr-200609: 42x 86SP1
Wininet.dll6.0.2900.2882663,55207-Abr-200604: 33x 86SP2

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de seguir estos pasos cuidadosamente. Para conseguir una protección adicional, haga una copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows


Después de aplicar la actualización de software 911149, siga estos pasos para habilitar esta actualización:
  1. Salga de Internet Explorer.
  2. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  3. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main
  4. En el menú Edición, seleccione nuevo y, a continuación, haga clic en clave.
  5. Escriba FeatureControl y, a continuación, presione ENTRAR.
  6. Con la subclave del registro,
    FeatureControl
    que creó en el paso 5 seleccionado, seleccione nuevo en el menú Edición y, a continuación, haga clic en clave.
  7. Escriba FEATURE_USE_CNAME_FOR_SPN_KB911149 y, a continuación, presione ENTRAR.
  8. Con la subclave del registro de
    FEATURE_USE_CNAME_FOR_SPN_KB911149
    había seleccionado creado en el paso 7, seleccione nuevo en el menú Edición y a continuación, haga clic en Valor DWORD.
  9. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  10. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar.
  11. En el cuadro información del valor, escriba 1 y, a continuación, haga clic en Aceptar.

    Nota Para volver al comportamiento anterior para la compatibilidad con versiones anteriores, restablecer este valor a 0 x 0.
  12. Salir del Editor del registro.
Nota La clave de control de característica FEATURE_USE_CNAME_FOR_SPN_KB911149 puede contener también otras aplicaciones, por ejemplo:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FEATURE_USE_CNAME_FOR_SPN_KB911149\Excel.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FEATURE_USE_CNAME_FOR_SPN_KB911149\Powerpnt.exe
Si hay varias aplicaciones, puede agregar una entrada DWORD con el nombre de "*" y un valor de 1 para activar esta característica para todas las aplicaciones instaladas que utilicen direcciones URL.

Para obtener más información, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
326985Cómo solucionar problemas relacionados con Kerberos en IIS
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 911149 - Última revisión: sábado, 20 de febrero de 2010 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0 sobre las siguientes plataformas
    • Microsoft Windows XP Professional
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxpsp1fix kbbug kbfix kbqfe kbpubtypekc KB911149 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 911149

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