Mensagem de erro no Internet Explorer quando você tenta acessar um site que requer a autenticação Kerberos em um computador com Windows XP: "Erro HTTP 401 - não autorizado: acesso negado devido a credenciais inválidas"

Traduções deste artigo Traduções deste artigo
ID do artigo: 911149 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Você está usando o Microsoft Internet Explorer em um computador com Microsoft Windows XP. Quando você tenta acessar um site que requer a autenticação Kerberos, você receberá a seguinte mensagem de erro:
Erro HTTP 401 - não autorizado: Acesso negado devido a credenciais inválidas.

Causa

Esse problema pode ocorrer se o site usa um registro de recurso CNAME no sistema de nomes de domínios (DNS) para entrar em contato com o servidor inicia a autenticação Kerberos. (Este servidor também emite o tíquete Kerberos). Quando você usa o Internet Explorer para acessar o site da Web, o Internet Explorer usa o nome do host do servidor em vez do registro de recurso CNAME para entrar em contato com o servidor. O processo de autenticação não funciona porque somente o nome principal de serviço (SPN) para o registro de recurso CNAME é registrado na conta que é usada para a autenticação.

Resolução

Informações sobre hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Este hotfix pode ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não exibida, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: Se ocorrem problemas adicionais ou se for necessária qualquer solução de problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação: O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque não há um hotfix disponível disponível para esse idioma.

Pré-requisitos

Não há pré-requisitos são necessários.

Requisito de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações do arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas em UTC (hora coordenada universal COORDENADO). Quando você exibe as informações do arquivo, ele é convertido em hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Wininet.dll6.0.2800.1545587,26406 De abril de 200609: 42x 86SP1
Wininet.dll6.0.2900.2882663,55207 De abril de 200604: 33x 86SP2

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Importante Nesta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Portanto, certifique-se de seguir estas etapas cuidadosamente. Para obter mais proteção, faça backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows


Depois de aplicar a atualização de software 911149, siga estas etapas para permitir que esta atualização:
  1. Saia do Internet Explorer.
  2. Clique em Iniciar, clique em Executar, digite regedit e, em seguida, clique em OK.
  3. Localize e clique na seguinte subchave do registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main
  4. No menu Editar, aponte para novo e, em seguida, clique em chave.
  5. Digite FeatureControl e, em seguida, pressione ENTER.
  6. Com a subchave do Registro
    FeatureControl
    que você criou na etapa 5 selecionado, aponte para novo no menu Editar e, em seguida, clique em chave.
  7. Digite FEATURE_USE_CNAME_FOR_SPN_KB911149 e, em seguida, pressione ENTER.
  8. Com a subchave de registro
    FEATURE_USE_CNAME_FOR_SPN_KB911149
    criada na etapa 7, aponte para novo no menu Editar e, em seguida, clique em Valor DWORD selecionados.
  9. Digite iexplore.exe e, em seguida, pressione ENTER.
  10. Clique com o botão direito do mouse iexplore.exe e, em seguida, clique em Modificar.
  11. Na caixa dados do valor, digite 1 e, em seguida, clique em OK.

    Observação: Para reverter para o comportamento anterior para compatibilidade com versões anteriores, redefina esse valor como 0 x 0.
  12. Feche o Editor do registro.
Observação: A chave de controle de recurso FEATURE_USE_CNAME_FOR_SPN_KB911149 também pode conter outros aplicativos, por exemplo:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FEATURE_USE_CNAME_FOR_SPN_KB911149\Excel.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FEATURE_USE_CNAME_FOR_SPN_KB911149\Powerpnt.exe
Se houver vários aplicativos, você pode adicionar uma entrada DWORD com o nome de "*" e um valor de 1 para ativar esse recurso de todos os aplicativos instalados que utilizam URLs.

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
326985Como solucionar problemas relacionados ao Kerberos no IIS
824684Descrição da terminologia padrão usada para descrever as atualizações de software

Propriedades

ID do artigo: 911149 - Última revisão: sábado, 20 de fevereiro de 2010 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxpsp1fix kbbug kbfix kbqfe kbpubtypekc KB911149 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 911149

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com