เกิดข้อผิดพลาดเมื่อคุณพยายามล็อกออแอพลิเคชันเว็บหรือเมื่อคุณเริ่มใช้งานเหตุการณ์เป็นคำบรรยายภาพแบบใน Microsoft Dynamics CRM: "การเข้าถึงถูกปฏิเสธเนื่องจากการข้อมูลประจำตัวที่ไม่ถูกต้อง"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 911353 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
สิ่งสำคัญบทความนี้ประกอบด้วยข้อมูลเกี่ยวกับวิธีการแก้ไขรีจิสทรี ควรตรวจสอบว่าได้สำรองรีจิสทรีก่อนที่จะปรับเปลี่ยน โปรดทำความเข้าใจกับวิธีการคืนค่ารีจิสทรีในกรณีที่เกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีสำรองข้อมูล คืนค่า และปรับเปลี่ยนรีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความใน Microsoft Knowledge Base::
256986คำอธิบายสำหรับ Microsoft Windows Registry
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

อาการ 1

เมื่อคุณพยายามเข้าสู่ระบบโปรแกรมประยุกต์เว็บของ Microsoft Dynamics CRM คุณได้รับข้อความแสดงข้อความแสดงข้อผิดพลาดต่อไปนี้:
ข้อผิดพลาด http 401
ไม่ได้รับอนุญาต: การเข้าถึงถูกปฏิเสธเนื่องจากการข้อมูลประจำตัวที่ไม่ถูกต้อง

อาการ 2

คุณสามารถสร้างเหตุการณ์คำบรรยายภาพแบบอย่าง น้อยหนึ่งที่ใช้งานอยู่ในระบบ Microsoft Dynamics CRM เมื่อคุณเริ่มใช้งานเหตุการณ์เหล่านี้คำบรรยายภาพแบบอย่างใดอย่างหนึ่ง คุณได้รับข้อความแสดงข้อผิดพลาดที่กล่าวถึงในอาการ 1

สาเหตุ

ปัญหานี้อาจเกิดขึ้นสำหรับอย่างน้อยหนึ่งเนื่องจากสาเหตุต่อไปนี้:
  • มีค่าบริการหลักชื่อ (SPN) ที่ซ้ำกันในแผนภูมิของบริการไดเรกทอรี Active Directory
  • การตรวจสอบลูปแบ็คอาจมีการปิดใช้งานใน Microsoft Windows Server 2003
  • Dynamics CRM เว็บไซต์ของ Microsoft ไม่มีอยู่ในLocal Intranetไซต์ใน Microsoft Internet Explorer
  • บัญชีที่ใช้เพื่อเริ่มการทำงานของพูลโปรแกรมประยุกต์ Microsoft Dynamics CRM (CRMAppPool) ไม่มีสิทธิ์ที่ถูกต้อง

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ใช้วิธีการที่เหมาะสมกับสถานการณ์ของคุณ

วิธีที่ 1: ลบค่า SPN ซ้ำกัน

เมื่อคุณพยายามเข้าสู่ เว็บแอพลิเคชันสำหรับ Microsoft Dynamics CRM ข้อความแสดงข้อผิดพลาดต่อไปนี้อาจถูกบันทึกลงในบันทึกของโปรแกรมประยุกต์ในตัวควบคุมโดเมนในโดเมนอย่างน้อยหนึ่งอย่าง:
ชนิดเหตุการณ์: ข้อผิดพลาด
แหล่งที่มาของเหตุการณ์: KDC
ประเภทเหตุการณ์: ไม่มี
รหัสเหตุการณ์: 11
คำอธิบาย: ไม่มีชื่อ host/SERVERNAME.microsoft.com ของ type10 หลายบัญชี
โดยทั่วไป ค่า SPN ซ้ำจะอยู่ในแอตทริบิวต์ ServicePrincipleName ของคอนเทนเนอร์ผู้ใช้ของบัญชีผู้ใช้ที่เริ่มต้น การติดตั้ง Microsoft Dynamics CRM เมื่อต้องการกำหนดตำแหน่งที่แน่นอนของค่า SPN ซ้ำ ใช้เครื่องมือ Ldp.exe

หมายเหตุ:เฉพาะประสบการณ์ผู้ดูแลควรใช้เครื่องมือ Ldp.exe

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการค้นหาค่า SPN ซ้ำ คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
321044รหัสเหตุการณ์ 11 ในบันทึกของระบบของตัวควบคุมโดเมน
หลังจากที่คุณค้นหาค่า SPN ซ้ำ ใช้เครื่องมือ ADSIEdit เพื่อเอาค่า SPN ซ้ำกัน โดยให้ทำตามขั้นตอนต่อไปนี้:
หมายเหตุ
  • เฉพาะประสบการณ์ผู้ดูแลควรใช้เครื่องมือ ADSIEdit
  • เครื่องมือ ADSIEdit ไม่พร้อมใช้งานในชุดเครื่องมือสนับสนุนของ Windows
  • ขั้นตอนต่อไปนี้ลบค่า SPN ซ้ำจากบัญชีผู้ใช้ที่เริ่มต้น การติดตั้ง Microsoft Dynamics CRM อย่างไรก็ตาม คุณสามารถจะตามขั้นตอนเหล่านี้เพื่อลบค่า SPN ซ้ำจากบัญชีคอมพิวเตอร์
  1. เปิด Microsoft Management Console เมื่อต้องการทำเช่นนี้ คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:mmcแล้ว คลิกตกลง.
  2. คลิกแฟ้ม:แล้ว คลิกเพิ่ม/เอาออกสแนปอิน.
  3. คลิกaddคลิกแก้ไข adsiในรายการ คลิกaddแล้ว คลิกปิด.
  4. คลิกขวาแก้ไข adsiแล้ว คลิกการเชื่อมต่อไปการเชื่อมต่อกับโดเมนที่แท้จริง
  5. ขยายโหนดโดเมน แล้ว ค้นหาบัญชีผู้ใช้ที่เริ่มต้น การติดตั้ง Microsoft Dynamics CRM
  6. คลิกขวาบัญชีผู้ใช้ และจากนั้น คลิกคุณสมบัติ.
  7. ในการแอตทริบิวต์คอลัมน์ คลิกสองครั้งServicePrincipleName.
  8. ในหน้าต่างค่า เลือก และทำลบค่าทั้งหมดที่ขึ้นต้น ด้วย โฮสต์/<servername> ค่าเหล่านี้ตรงกับโฮสต์ / <servername>ค่า SPN ที่อยู่ในข้อความแสดงข้อผิดพลาดใน log. แอพลิเคชัน</servername></servername>

วิธีที่ 2: ปิดใช้งานการตรวจสอบย้อนกลับบนเซิร์ฟเวอร์ Microsoft Dynamics CRM

คำเตือนปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง โดยใช้ตัวแก้ไขรีจิสทรี หรือ โดยใช้วิธีอื่น คุณอาจต้องติดตั้งระบบปฏิบัติการใหม่เพื่อแก้ไขปัญหาเหล่านี้ Microsoft ไม่รับประกันว่าจะสามารถแก้ไขปัญหาได้ คุณต้องยอมรับความเสี่ยงด้วยตนเองในการปรับเปลี่ยนรีจิสทรี
  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:regeditแล้ว คลิกตกลง.
  2. ค้นหาและคลิกขวาที่คีย์ย่อยของรีจิสตรีต่อไปนี้::
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa
  3. ชี้ไปที่ใหม่แล้ว คลิกค่า DWORD.
  4. ประเภท:DisableLoopbackCheckแล้ว กด ENTER
  5. คลิกขวาDisableLoopbackCheckแล้ว คลิกปรับเปลี่ยน.
  6. ในการข้อมูลค่า:กล่อง ชนิด1แล้ว คลิกตกลง.
  7. ในการแฟ้ม:เมนู คลิกexit.
หลังจากที่คุณติดตั้งการปรับปรุงการรักษาความปลอดภัย 957097 แอปพลิเคชันเช่น Microsoft SQL Server หรือบริการข้อมูลทางอินเทอร์เน็ต (IIS) อาจล้มเหลวเมื่อทำการร้องขอการรับรองความถูกต้อง NTLM ท้องถิ่นสำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการแก้ไขปัญหานี้ โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base::
957097MS08-068: ช่องโหว่ใน SMB อาจทำให้โค้ดจากระยะไกล
คำเตือนวิธีแก้ปัญหานี้อาจทำให้คอมพิวเตอร์ของคุณหรือเครือข่ายของคุณเสี่ยงการโจมตี โดยผู้ใช้ที่ประสงค์ร้าย หรือซอฟต์แวร์ที่เป็นอันตรายเช่นไวรัส เราไม่แนะนำให้คุณใช้วิธีนี้ เพียงแต่เสนอข้อมูลนี้เพื่อให้คุณสามารถใช้วิธีการนี้ตามดุลยพินิจของคุณเอง คุณต้องยอมรับความเสี่ยงในการใช้วิธีการนี้ด้วยตนเองสำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
896861คุณได้รับข้อผิดพลาด 401.1 เมื่อคุณเรียกดูเว็บไซต์ที่ใช้ การรับรองความถูกต้องรวม และโฮสต์บน IIS 5.1 หรือ IIS 6

วิธีที่ 3: เพิ่ม Dynamics CRM เว็บไซต์ของ Microsoft "อินทราเน็ตเฉพาะที่" ไซต์ใน Internet Explorer

  1. เริ่ม Internet Explorer
  2. ในการเครื่องมือเมนู คลิกตัวเลือกอินเทอร์เน็ต.
  3. คลิกการการรักษาความปลอดภัยแท็บ
  4. คลิกLocal Intranetแล้ว คลิกไซต์.
  5. ในการLocal Intranetกล่องโต้ตอบ คลิกขั้นสูง.
  6. ในการเพิ่มเว็บไซต์นี้ลงในโซนกล่อง พิมพ์ URL สำหรับ Dynamics CRM เว็บไซต์ของ Microsoft และคลิกadd.
  7. ถ้าคุณไม่ได้ใช้เลเยอร์ซ็อกเก็ตที่ปลอดภัย (SSL), คลิกเพื่อยกเลิกการต้องการตรวจสอบเซิร์ฟเวอร์ (https:)สำหรับทุกไซต์ในโซนนี้กล่องกาเครื่องหมาย และจากนั้น คลิกตกลง.

วิธีที่ 4: การเปลี่ยนแปลงพูลโปรแกรมประยุกต์ของ Microsoft Dynamics CRM ในการทำงานภายใต้บัญชีผู้ใช้อื่น

  1. คลิกเริ่มการทำงานชี้ไปที่โปรแกรมทั้งหมดชี้ไปที่เครื่องมือการดูแลระบบแล้ว คลิกโปรแกรมจัดการบริการ (IIS) ของข้อมูลทางอินเทอร์เน็ต.
  2. ขยายชื่อคอมพิวเตอร์
  3. ขยายกลุ่มแอพลิเคชัน.
  4. คลิกขวาCRMAppPoolแล้ว คลิกคุณสมบัติ.
  5. คลิกการรหัสประจำตัวแท็บ
  6. ถ้ามีการใช้พูลโปรแกรมประยุกต์ภาย ใต้บัญชีโดเมน หรือบัญชีระบบภายใน พยายามเปลี่ยนพูลโปรแกรมประยุกต์เรียกใช้ภายใต้บัญชีบริการเครือข่าย เมื่อต้องการทำเช่นนี้ คลิกบริการเครือข่ายในการกำหนดไว้ล่วงหน้ากล่อง
  7. คลิกตกลงเมื่อต้องการปิดการคุณสมบัติ CRMAppPoolกล่องโต้ตอบ
  8. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:iisresetแล้ว คลิกตกลงเมื่อต้อง การหยุดแล้ว เริ่มต้น IIS
  9. เข้าสู่ระบบในโปรแกรมประยุกต์เว็บของ Microsoft Dynamics CRM
หมายเหตุ
  • ขั้นตอนเหล่านี้ได้เฉพาะใน IIS 6.0
  • ถ้าคุณเปลี่ยนบัญชีผู้ใช้ที่เรียกใช้แอพลิเคชันบัญชีบริการเครือข่าย เราขอแนะนำว่า คุณยังเปลี่ยนบัญชีผู้ใช้ที่เริ่มการทำงานของบริการต่อไปนี้บนเซิร์ฟเวอร์ CRM ของ Microsoft:
    • บริการอีเมขนาดใหญ่ของ Microsoft CRM
    • Microsoft CRM ลบบริการ
    • บริการของกระแสงาน Microsoft CRM
    เมื่อต้องการทำเช่นนี้ ทำตามขั้นตอนเหล่านี้สำหรับแต่ละบริการ:
    1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:services.mscแล้ว คลิกตกลง.
    2. คลิกขวาที่การบริการ คลิกคุณสมบัติแล้ว คลิกการเข้าสู่ระบบแท็บ
    3. เปลี่ยนบัญชีผู้ใช้ที่เริ่มต้นบริการกับบัญชีบริการเครือข่าย และจากนั้น คลิกตกลง.
    4. คลิกขวาที่การบริการ และจากนั้น คลิกเริ่มต้นใหม่.

คุณสมบัติ

หมายเลขบทความ (Article ID): 911353 - รีวิวครั้งสุดท้าย: 19 ตุลาคม 2553 - Revision: 2.0
ใช้กับ
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbmbscrm40 kblogin kberrmsg kbtshoot kbmbsmigrate kbprb kbmt KB911353 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:911353

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com