Fehler beim Laden Microsoft Dynamics CRM Funktionalitätsfehler beim Starten von Outlook

Dieser Artikel enthält Lösungen für probleme, die auftreten können, wenn Sie den Microsoft Dynamics CRM Client für Outlook starten.

Gilt für: Microsoft CRM Client für Microsoft Office Outlook®
Ursprüngliche KB-Nummer: 911384

Problembeschreibung

Symptome 1

Wenn Sie den Microsoft Dynamics CRM-Client für Microsoft Office Outlook öffnen, wird die folgende Fehlermeldung angezeigt:

Fehler beim Laden Microsoft CRM Funktionalität. Versuchen Sie, Outlook neu zu starten.

Im Ereignisprotokoll werden Fehlermeldungen protokolliert, die den folgenden ähneln.

Fehlermeldung 1

Die Beschreibung für ereignis-ID ( 2 ) in Source ( Microsoft CRM ) wurde nicht gefunden. Der lokale Computer verfügt möglicherweise nicht über die erforderlichen Registrierungsinformationen oder Meldungs-DLL-Dateien, um Meldungen von einem Remotecomputer anzuzeigen. Möglicherweise können Sie das Flag /AUXSOURCE= verwenden, um diese Beschreibung abzurufen. Weitere Informationen finden Sie unter Hilfe und Support.

Die folgenden Informationen sind Teil des Ereignisses. MSCRM-Plattformfehlerbericht:

Fehler: Ausnahme von HRESULT: 0x80040220. Fehlermeldung: Ausnahme von HRESULT: 0x80040220. Fehlerdetails: Details zu diesem Fehler wurden von der Plattform nicht bereitgestellt. Source File: Not available Line Number: Not available Stack Trace Info: at System.Web.UI.Page.HandleError(Exception e) at System.Web.UI.Page.ProcessRequestMain() at System.Web.UI.Page.ProcessRequest() at System.Web.Web.. UI.Page.ProcessRequest(HttpContext context) at System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolescher& abgeschlossenSynchron).

Fehlermeldung 2

Die Beschreibung für die Ereignis-ID ( 16930 ) in der Quelle ( MSCRMAddin ) wurde nicht gefunden. Der lokale Computer verfügt möglicherweise nicht über die erforderlichen Registrierungsinformationen oder Meldungs-DLL-Dateien, um Meldungen von einem Remotecomputer anzuzeigen. Möglicherweise können Sie das Flag /AUXSOURCE= verwenden, um diese Beschreibung abzurufen. Weitere Informationen finden Sie unter Hilfe und Support. Die folgenden Informationen sind Teil des Ereignisses: 80004005, , CAddin::HrActivateAddin, 472.

Fehlermeldung 3

Die Beschreibung für ereignis-ID ( 5944 ) in Source ( MSCRMAddin ) wurde nicht gefunden. Der lokale Computer verfügt möglicherweise nicht über die erforderlichen Registrierungsinformationen oder Meldungs-DLL-Dateien, um Meldungen von einem Remotecomputer anzuzeigen. Möglicherweise können Sie das Flag /AUXSOURCE= verwenden, um diese Beschreibung abzurufen. Weitere Informationen finden Sie unter Hilfe und Support. Die folgenden Informationen sind Teil des Ereignisses: 80004005, , CAddin::HrInitializeUI, 137.

Symptome 2

Wenn Sie Windows Vista mit dem Microsoft Dynamics CRM für Outlook verwenden und die Plattformablaufverfolgung aktivieren, erhalten Sie eine Fehlermeldung, die der folgenden ähnelt:

Clientkonfiguration: [Fehler] COM-Registrierungsschlüssel scheinen beschädigt zu sein. Führen Sie den CRM-Konfigurations-Assistenten erneut aus, oder wenden Sie sich an Ihren Microsoft Dynamics CRM-Administrator. >--- System.TypeLoadException: Fehler beim Abrufen der COM-Klassenfactory für die Komponente mit CLSID {<ID>} aufgrund des folgenden Fehlers: 80131522. unter
System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) at
System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) at
System.Activator.CreateInstance(Type type, Boolean nonPublic) at
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) --- Ende der ablaufverfolgung des inneren Ausnahmestapels --- at
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) at Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheck.DeepExecute(BackgroundWorker backgroundWorker)

Symptome 3

Wenn Sie versuchen, den Microsoft Dynamics CRM-Client für Outlook auszuführen, können Sie die Microsoft Dynamics CRM Ordnerstruktur nicht anzeigen. Außerdem wird die folgende Fehlermeldung angezeigt:

Fehler beim Laden Microsoft CRM Funktionalität. Versuchen Sie, Outlook neu zu starten.

Die folgenden Fehlermeldungen werden im Ereignisprotokoll protokolliert:

Ereignistyp: Fehler Ereignisquelle: MSCRMAddin Ereigniskategorie: Keine Ereignis-ID: 16930 Datum: Datum Uhrzeit: Uhrzeit Benutzer: N/A Computer: ComputerName Beschreibung: Fehler bei der Initialisierung der Microsoft CRM Ui. Versuchen Sie, Microsoft Outlook neu zu starten. HR=0x80004005. Context=. Function=CAddin::HrActivateAddin. Zeile=521. Darüber hinaus erhalten Sie die folgende Fehlermeldung in der OUTLOOK-YYDDMM.log Ablaufverfolgungsprotokolldatei: [Datum und Uhrzeit] Prozess: OUTLOOK |Thread:0832 |Kategorie: Unmanaged.Platform |Benutzer: PlatformUser |Ebene: Fehler | HrGetXmlDOM-Datei: c:\bt\643\src\application\outlook\v3caddin\xmlutil.cpp Zeile: 179 >hr = 0x80004005

Hinweis

In dieser Fehlermeldung stellt der Platzhalter Datum und Uhrzeit das tatsächliche Datum und die tatsächliche Uhrzeit dar. Das tatsächliche Datum und die tatsächliche Uhrzeit könnten beispielsweise "2007-10-19 17:53:26.138" sein.

Symptome 4

Wenn Sie den Microsoft Dynamics CRM-Client für Outlook starten, wird die folgende Fehlermeldung angezeigt:

Fehler beim Laden Microsoft CRM Funktionalität. Versuchen Sie, Outlook neu zu starten. Darüber hinaus wird im Anwendungsprotokoll auf das Fehlerereignis 80072f19 verwiesen: Ereignis: 16941 Beim Initialisieren der Symbolleiste für den Initialisierungsfortschritt ist ein Problem aufgetreten. Starten Sie Microsoft CRM neu, und versuchen Sie es erneut. HR=0x80072f19. Context=. Function=CAddin::HrActivateAddin. Zeile=322.

Symptome 5

Wenn Sie versuchen, Microsoft Office Outlook auf einem Computer zu starten, auf dem der Microsoft Dynamics CRM Client für Outlook installiert ist, wird die folgende Fehlermeldung angezeigt:

Fehler beim Laden Microsoft Dynamics CRM Funktionalität.

Versuchen Sie, Microsoft Outlook neu zu starten.

Wenden Sie sich an Ihren Systemadministrator, wenn Weiterhin Fehler auftreten.

Darüber hinaus wird die folgende Fehlermeldung im Anwendungsereignisprotokoll protokolliert:

Ereignistyp: Fehler
Ereignisquelle: MSCRMAddin
Ereigniskategorie: Keine
Ereignis-ID: 16931
Beschreibung:

Beim Initialisieren Microsoft CRM COM-Interop ist ein Problem aufgetreten. Starten Sie Microsoft CRM neu, und versuchen Sie es erneut. HR=0x80131700. Context=. Function=CAddin::HrActivateAddin. Zeile=274.

Ereignistyp: Fehler
Ereignisquelle: MSCRMAddin
Ereigniskategorie: Keine
Ereignis-ID: 5903
Beschreibung:

Das Microsoft CRM Outlook-Add-In konnte nicht ordnungsgemäß initialisiert werden. Starten Sie Microsoft Outlook neu, und versuchen Sie es erneut. HR=0x80070057. Context=. Function=CAddin::OnConnection. Zeile=196.

Ursache

Ursache 1

Dieses Problem tritt auf, weil die dem Benutzerkonto zugewiesene Rolle keinen Lesezugriff auf die Entität Gespeicherte Ansicht in Microsoft Dynamics CRM hat. Siehe Auflösung 1.

Ursache 2

Die Konfiguration "Ordnerstartseite deaktivieren" wird über Gruppenrichtlinie aktiviert. Die Konfiguration "Ordnerstartseite deaktivieren" ist eine Microsoft Office 2003-Konfiguration mit administrativer Vorlage (OUTLK11.adm). Wenn diese Einstellung aktiviert ist, kann Office 2003 die Microsoft Dynamics CRM Ordnerstruktur nicht laden. Siehe Auflösung 2.

Ursache 3

Dieses Problem tritt auf, wenn IIS die Zuordnungen für die SRF-Erweiterungen fehlen, die auf die CRMisapi.dll-Datei verweisen. Siehe Auflösung 3.

Ursache 4

Dieses Problem tritt auf, weil die Überprüfung auf Die Sperrung von Serverzertifikaten aktiviert ist. Siehe Auflösung 4.

Ursache 5

Dieses Problem tritt auf, weil die Outlook.exe.config-Datei im Microsoft Office-Installationsordner vorhanden ist. Diese Datei wird in Instanzen zur Problembehandlung für den Microsoft Outlook CRM-Client für Outlook verwendet, damit Outlook eine bestimmte Version des Microsoft .NET Framework verwenden kann. Siehe Auflösung 5.

Lösung

Lösung 1

Um den Microsoft Dynamics CRM Client für Outlook ordnungsgemäß starten zu können, muss die dem Benutzerkonto zugewiesene Rolle über Lesezugriff auf die Entität Gespeicherte Ansicht verfügen. Führen Sie die folgenden Schritte aus, um den Zugriff des Benutzers zu ändern:

  1. Öffnen Sie Microsoft Dynamics CRM.
  2. Wählen Sie Einstellungen aus, wählen Sie Einstellungen aus, wählen Sie Geschäftseinheitseinstellungen und Benutzer aus, und doppelklicken Sie dann auf den Benutzer, um den Benutzer zu öffnen.
  3. Wählen Sie Rollen aus, doppelklicken Sie auf die Rolle, um die Rolle zu öffnen, wählen Sie die Registerkarte Kerndatensätze aus, und wählen Sie dann Lesezugriff für die Entität Gespeicherte Ansicht aus.

Lösung 2

Um dieses Problem zu beheben, ändern Sie die Einstellung der Konfiguration Ordnerstartseite deaktivieren in deaktiviert status. Führen Sie dazu die folgenden Schritte für Outlook 2003 aus:

  1. Um die Gruppenrichtlinie zu bearbeiten, die die administrative Office 2003-Vorlage enthält, öffnen Sie Gruppenrichtlinie Objekt-Editor.
  2. Erweitern Sie Benutzerkonfiguration, Richtlinien, Administrative Vorlagen und dann Microsoft Office Outlook 2003.
  3. Wählen Sie Ordnerstartseiten für spezielle Outlook-Ordner aus, und doppelklicken Sie dann auf Ordnerstartseiten deaktivieren.
  4. Aktivieren Sie auf der Seite Eigenschaften von Ordnerstartseiten deaktivieren das Kontrollkästchen Deaktiviert , und klicken Sie dann auf OK.
  5. Beenden Sie Gruppenrichtlinie Objekt-Editor.
  6. Starten Sie den betroffenen Clientcomputer neu.

Führen Sie die folgenden Schritte für Outlook 2007 aus:

  1. Um die Gruppenrichtlinie zu bearbeiten, die die administrative Office 2007-Vorlage enthält, öffnen Sie Gruppenrichtlinie Objekt-Editor.
  2. Erweitern Sie Benutzerkonfiguration, Richtlinien, Administrative Vorlagen und dann Microsoft Office Outlook 2007.

    [HINWEIS] Der Ordner Microsoft Office Outlook 2007 kann sich unter Klassische administrative Vorlagen (ADM) befinden.

  3. Wählen Sie Ordner-Startseiten für Outlook-Sonderordner aus, und doppelklicken Sie dann auf Die Url der Startseite darf nicht in den Ordnereigenschaften festgelegt werden.
  4. Aktivieren Sie auf der Seite Startseiten-URL im Ordner Eigenschaften nicht festlegen das Kontrollkästchen Deaktiviert , und wählen Sie dann OK aus.
  5. Beenden Sie Gruppenrichtlinie Objekt-Editor.
  6. Starten Sie den betroffenen Clientcomputer neu.

Lösung 3

Um dieses Problem zu beheben, fügen Sie der website Microsoft Dynamics CRM die SRF-Zuordnung hinzu. Gehen Sie dazu wie folgt vor:

  1. Erweitern Sie die Microsoft Dynamics CRM-Website in IIS.
  2. Klicken Sie mit der rechten Maustaste auf das virtuelle Anwendungsverzeichnis MSCRMServices , und wählen Sie dann Eigenschaften aus.
  3. Wählen Sie auf der Registerkarte Virtuelles Verzeichnisdie Option Konfiguration aus.
  4. Wählen Sie im Abschnitt Anwendungserweiterungen die Option Hinzufügen aus.
  5. Suchen Sie die CRMIsapi.dll-Datei , und setzen Sie den Pfad wie folgt in Anführungszeichen:
    C:\Programme\Microsoft CRM\Server\bin\CrmIsapi.dll
  6. Geben Sie im Feld Erweiterungden Namen .srf ein.
  7. Geben Sie im Feld Limit to (Limit to) GET, POST, HEAD ein.
  8. Aktivieren Sie das Kontrollkästchen Skript-Engine und das Kontrollkästchen Überprüfen, ob die Datei vorhanden ist , und wählen Sie dann OK aus.
  9. Setzen Sie IIS zurück. Wählen Sie hierzu Start aus, wählen Sie Ausführen aus, geben Sie iisreset in das Feld Öffnen ein, und wählen Sie dann OK aus.

Lösung 4

Gehen Sie wie folgt vor, um das Problem zu beheben:

  1. Wählen Sie in Internet Explorer das Menü Extras und dann Internetoptionen aus.
  2. Aktivieren Sie die Registerkarte Erweitert , und deaktivieren Sie dann das Kontrollkästchen Auf Serverzertifikatsperrung überprüfen (Neustart erforderlich).
  3. Starten Sie Outlook neu.

Lösung 5

Um dieses Problem zu beheben, entfernen Oder benennen Sie die Outlook.exe.config-Datei um, und starten Sie Dann Outlook neu.