Ett fel uppstod när Microsoft Dynamics CRM funktionsfel skulle läsas in när Outlook startades

Den här artikeln innehåller lösningar på de problem som kan uppstå när du startar Microsoft Dynamics CRM-klienten för Outlook.

Gäller för: Microsoft CRM-klient för Microsoft Office Outlook
Ursprungligt KB-nummer: 911384

Symptom

Symptom 1

När du öppnar Microsoft Dynamics CRM-klienten för Microsoft Office Outlook får du följande felmeddelande:

Ett fel uppstod när Microsoft CRM funktioner skulle läsas in. Prova att starta om Outlook.

I händelseloggen loggas felmeddelanden som liknar följande.

Felmeddelande 1

Det går inte att hitta beskrivningen för händelse-ID ( 2 ) i Källan ( Microsoft CRM ). Den lokala datorn kanske inte har nödvändig registerinformation eller DLL-meddelandefiler för att visa meddelanden från en fjärrdator. Du kanske kan använda flaggan /AUXSOURCE= för att hämta den här beskrivningen. Mer information finns i Hjälp och support.

Följande information är en del av händelsen. MSCRM-plattformsfelrapport:

Fel: Undantag från HRESULT: 0x80040220. Felmeddelande: Undantag från HRESULT: 0x80040220. Felinformation: Information om det här felet har inte angetts av plattformen. Källfil: Inte tillgängligt radnummer: Inte tillgänglig stackspårningsinformation: på System.Web.UI.Page.HandleError(Undantag e) på System.Web.UI.Page.ProcessRequestMain() på System.Web.UI.Page.ProcessRequest() på System.Web .UI.Page.ProcessRequest(HttpContext context) at System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolesk& slutfördSynkront).

Felmeddelande 2

Det går inte att hitta beskrivningen för händelse-ID (16930) i Källa (MSCRMAddin). Den lokala datorn kanske inte har nödvändig registerinformation eller DLL-meddelandefiler för att visa meddelanden från en fjärrdator. Du kanske kan använda flaggan /AUXSOURCE= för att hämta den här beskrivningen. Mer information finns i Hjälp och support. Följande information är en del av händelsen: 80004005, , CAddin::HrActivateAddin, 472.

Felmeddelande 3

Det går inte att hitta beskrivningen för händelse-ID (5944) i Källa (MSCRMAddin). Den lokala datorn kanske inte har nödvändig registerinformation eller DLL-meddelandefiler för att visa meddelanden från en fjärrdator. Du kanske kan använda flaggan /AUXSOURCE= för att hämta den här beskrivningen. Mer information finns i Hjälp och support. Följande information är en del av händelsen: 80004005, , CAddin::HrInitializeUI, 137.

Symptom 2

När du använder Windows Vista med Microsoft Dynamics CRM för Outlook och när du aktiverar plattformsspårning får du ett felmeddelande som liknar följande:

Klientkonfiguration: [Fel] COM-registernycklar verkar vara skadade. Kör crm-konfigurationsguiden igen eller kontakta Microsoft Dynamics CRM-administratören. >--- System.TypeLoadException: Det gick inte att hämta COM-klassfabriken för komponenten med CLSID {<ID>} på grund av följande fel: 80131522. På
System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) at
System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) at
System.Activator.CreateInstance(Type type, Boolean nonPublic) at
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) --- Slut på spårning av inre undantagsstack --- på
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) på Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheck.DeepExecute(BackgroundWorker backgroundWorker)

Symptom 3

När du försöker köra Microsoft Dynamics CRM-klienten för Outlook kan du inte visa Microsoft Dynamics CRM mappstruktur. Dessutom visas följande felmeddelande:

Ett fel uppstod när Microsoft CRM funktioner skulle läsas in. Prova att starta om Outlook.

Följande felmeddelanden loggas i händelseloggen:

Händelsetyp: Felhändelsekälla: MSCRMAddin Händelsekategori: Inget händelse-ID: 16930 Datum: Datum: Tidsanvändare: N/A-dator: Datornamn Beskrivning: Initieringen av Microsoft CRM användargränssnittet misslyckades. Prova att starta om Microsoft Outlook. HR=0x80004005. Context=. Function=CAddin::HrActivateAddin. Rad=521. Dessutom får du följande felmeddelande i OUTLOOK-YYDDMM.log spårningsloggfil: [Datum och tid] Process: OUTLOOK |Tråd:0832 |Kategori: Ohanterad.Plattform |Användare: PlatformUser |Nivå: Fel | HrGetXmlDOM-fil: c:\bt\643\src\application\outlook\v3caddin\xmlutil.cpp Rad: 179 >h = 0x80004005

Obs!

I det här felmeddelandet representerar platshållaren Datum och tid det faktiska datumet och den faktiska tiden. Det faktiska datumet och den faktiska tiden kan till exempel vara "2007-10-19 17:53:26.138".

Symptom 4

När du startar Microsoft Dynamics CRM-klienten för Outlook får du följande felmeddelande:

Ett fel uppstod när Microsoft CRM funktioner skulle läsas in. Prova att starta om Outlook. Dessutom refereras felhändelse 80072f19 i programloggen: Händelse: 16941 Ett problem uppstod när verktygsfältet för initieringsframställning skulle initieras. Starta om Microsoft CRM och försök igen. HR=0x80072f19. Context=. Function=CAddin::HrActivateAddin. Rad=322.

Symptom 5

När du försöker starta Microsoft Office Outlook på en dator där Microsoft Dynamics CRM-klienten för Outlook är installerad visas följande felmeddelande:

Ett fel uppstod när Microsoft Dynamics CRM funktioner skulle läsas in.

Prova att starta om Microsoft Outlook.

Kontakta systemadministratören om felen kvarstår.

Dessutom loggas följande felmeddelande i programhändelseloggen:

Händelsetyp: Fel
Händelsekälla: MSCRMAddin
Händelsekategori: Ingen
Händelse-ID: 16931
Beskrivning:

Ett problem uppstod när Microsoft CRM COM-interop skulle initieras. Starta om Microsoft CRM och försök igen. HR=0x80131700. Context=. Function=CAddin::HrActivateAddin. Rad=274.

Händelsetyp: Fel
Händelsekälla: MSCRMAddin
Händelsekategori: Ingen
Händelse-ID: 5903
Beskrivning:

Det gick inte att initiera Microsoft CRM Outlook-tillägget korrekt. Starta om Microsoft Outlook och försök igen. HR=0x80070057. Context=. Function=CAddin::OnConnection. Rad=196.

Orsak

Orsak 1

Det här problemet beror på att rollen som har tilldelats användarkontot inte har läsbehörighet till entiteten Sparad vy i Microsoft Dynamics CRM. Se Lösning 1.

Orsak 2

Konfigurationen Inaktivera startsida för mapp är aktiverad via grupprincip. Konfigurationen inaktivera mappstartsida är en administrationsmall för Microsoft Office 2003 (OUTLK11.adm). Om den här inställningen är aktiverad kan office 2003 inte läsa in Microsoft Dynamics CRM mappstruktur. Se Lösning 2.

Orsak 3

Det här problemet uppstår om IIS saknar mappningarna för .srf-tilläggen som pekar på den CRMisapi.dll filen. Se Lösning 3.

Orsak 4

Det här problemet beror på att kontrollen av återkallning av servercertifikat är aktiverad. Se Lösning 4.

Orsak 5

Det här problemet beror på att den Outlook.exe.config filen finns i installationsmappen för Microsoft Office. Den här filen används i felsökningsinstanser för Microsoft Outlook CRM-klienten för Outlook så att Outlook kan använda en specifik version av Microsoft .NET Framework. Se Lösning 5.

Åtgärd

Lösning 1

Om du vill starta Microsoft Dynamics CRM klient för Outlook korrekt måste rollen som har tilldelats användarkontot ha läsbehörighet till entiteten Sparad vy. Följ dessa steg om du vill ändra användarens åtkomst:

  1. Öppna Microsoft Dynamics CRM.
  2. Välj Inställningar, välj Inställningar, välj Inställningar för affärsenhet, välj Användare och dubbelklicka sedan på användaren för att öppna användaren.
  3. Välj Roller, dubbelklicka på rollen för att öppna rollen, välj fliken Kärnposter och välj sedan Läs-åtkomst för entiteten Sparad vy .

Lösning 2

Lös problemet genom att ändra inställningen för konfigurationen Inaktivera startsida för mapp till inaktiverad status. Gör detta genom att följa dessa steg för Outlook 2003:

  1. Om du vill redigera grupprincip som innehåller office 2003 administrationsmallen öppnar du grupprincip-objektredigeraren.
  2. Expandera Användarkonfiguration, expandera Principer, expandera Administrativa mallar och expandera sedan Microsoft Office Outlook 2003.
  3. Välj Mappstartsidor för Särskilda Outlook-mappar och dubbelklicka sedan på Inaktivera startsidor för mapp.
  4. På sidan Inaktivera egenskaper för startsidor för mapp markerar du kryssrutan Inaktiverad och väljer sedan OK.
  5. Avsluta grupprincip objektredigeraren.
  6. Starta om den berörda klientdatorn.

Följ dessa steg för Outlook 2007:

  1. Om du vill redigera grupprincip som innehåller administrationsmallen för Office 2007 öppnar du grupprincip-objektredigeraren.
  2. Expandera Användarkonfiguration, expandera Principer, expandera Administrativa mallar och expandera sedan Microsoft Office Outlook 2007.

    [OBS] Mappen Microsoft Office Outlook 2007 kan finnas under Klassiska administrativa mallar (ADM).

  3. Välj Mappstartsidor för Särskilda Outlook-mappar och dubbelklicka sedan på Tillåt inte att webbadressen till startsidan anges i mappen Egenskaper.
  4. På sidan Tillåt inte att webbadressen till startsidan anges på sidan Egenskaper för mappen markerar du kryssrutan Inaktiverad och väljer sedan OK.
  5. Avsluta grupprincip objektredigeraren.
  6. Starta om den berörda klientdatorn.

Lösning 3

Lös problemet genom att lägga till .srf-mappningen på Microsoft Dynamics CRM webbplats. Gör så här:

  1. Expandera Microsoft Dynamics CRM webbplats i IIS.
  2. Högerklicka på den virtuella katalogen för MSCRMServices-programmet och välj sedan Egenskaper.
  3. På fliken Virtuell katalog väljer du Konfiguration.
  4. I avsnittet Programtillägg väljer du Lägg till.
  5. Leta upp filenCRMIsapi.dll och placera sedan sökvägen inom citattecken enligt följande:
    C:\Program Files\Microsoft CRM\Server\bin\CrmIsapi.dll
  6. I rutan Tillägg anger du .srf.
  7. I rutan Begränsa till anger du GET, POST, HEAD.
  8. Markera kryssrutan Skriptmotor och kryssrutan Kontrollera att filen finns och välj sedan OK.
  9. Återställ IIS. Det gör du genom att välja Start, välja Kör, skriva iisreset i rutan Öppna och sedan välja OK.

Lösning 4

Följ de här stegen för att lösa problemet:

  1. I Internet Explorer väljer du menyn Verktyg och sedan Internetalternativ.
  2. Välj fliken Avancerat och avmarkera sedan kryssrutan Sök efter servercertifikatåterkallelse (omstart krävs).
  3. Starta om Outlook.

Lösning 5

Lös problemet genom att ta bort eller byta namn på Outlook.exe.config-filen och sedan starta om Outlook.