You experience unexpected results when you try to process inventory transfers in Headquarters or in Store Operations

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SUMMARY

This article lists methods to resolve problems that may occur when you try to process inventory transfers in Microsoft Retail Management System Headquarters or in Microsoft Retail Management System Store Operations.

SYMPTOMS

When you try to process inventory transfers in Headquarters or in Store Operations, you may experience one or more of the following symptoms:
  • Interstore inventory transfers are uploaded to Headquarters from the issuing store but are not downloaded to the receiving store.
  • Miscellaneous items are added to or removed from the interstore inventory transfer after the transfer has been downloaded to the receiving store.

CAUSE

Several situations may cause inventory transfers not to work as expected. These situations are as follows:
  • You have not upgraded Microsoft Retail Management System to the most recent version.
  • The Headquarters Manager Configuration options for interstore inventory transfers have not been enabled.
  • You have created items in the store database instead of in the headquarters database. Therefore, the Store Operations database contains invalid HQID values.
  • One or more items on the inventory transfer do not exist at the receiving store.
  • The transfer order number contains fewer than six digits.
  • Some IDs in the Headquarters purchase order table and in the Headquarters inventory transfer log table are larger than the IDs at the store level.

RESOLUTION

Note Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.

For more information about how to make a backup of a Store Operations or Headquarters database, click the following article number to view the article in the Microsoft Knowledge Base:
859729 How to back up a database in Store Operations or Headquarters
To resolve these problems, use one of the following methods.

Method 1

Microsoft has released several hotfixes for problems regarding interstore inventory transfers. Therefore, we strongly recommend that you upgrade to the most recent version of Microsoft Retail Management System and then apply the most recent hotfix.

Notes
  • To receive upgrades and hotfixes, you must be enrolled in a Microsoft Retail Management System maintenance plan. For more information about how to enroll in a maintenance plan, telephone (800) 456-0025 and request a quote from the Microsoft Dynamics Sales Operations team.
  • After you upgrade Microsoft Retail Management System software, previous inventory transfers that were not processed as expected will not be fixed. However, after you upgrade the software, future transfers may be prevented from not working as expected.
For more information about updates, service packs, and hotfixes for Microsoft Retail Management System, click the following article numbers to view the articles in the Microsoft Knowledge Base:
887221 Microsoft Business Solutions Retail Management System 1.2 service packs and hotfixes
912636 Microsoft Retail Management System 1.3 refreshes, service packs, and hotfixes

Method 2

Verify that the following check boxes are selected in the Headquarters Manager Configuration window:
  • Automatically create inter-store receive inventory order
  • Automatically create inter-store issue inventory order
To verify that these check boxes are selected, follow these steps:
  1. On the File menu in Headquarters Manager, click Configuration.
  2. Verify that the previously listed check boxes are selected.
  3. Click OK.

Method 3

At each store, every item is assigned an HQID. This is how Store Operations tracks the items that pass between stores. If the HQIDs at a store do not match the ID for that item at Headquarters, or if any item on the inventory transfer has an HQID of zero (0), the inventory transfer will not be downloaded at the receiving store. Additionally, if even one item on the inventory transfer does not have an HQID, the inventory transfer will not be downloaded at the receiving store.

Note If you create an item at a store instead of at Headquarters, the item's HQID will be zero. Therefore, the item will not upload to Headquarters. If the item is included on an inventory transfer, the item's HQID of zero will prevent the inventory transfer from being downloaded at the receiving store.

To run an SQL statement on the store databases to verify that all items have a nonzero HQID, follow these steps:
  1. On the File menu in Store Operations Administrator, click Connect, type the Microsoft SQL Server password, and then click OK to connect to the Store Operations database.
  2. On the Query menu, click New.
  3. Copy the following SQL statement, and then paste it into the New Query window.

    Note You must press CTRL+V to paste the SQL statement into the New Query window.
    SELECT * FROM Item WHERE HQID = 0
  4. Press F5 to run the statement.
If this query returns any results, follow these steps:
  1. Delete the identified items in the store database.
  2. Re-create those items in the headquarters database.
  3. Download those items to the store databases.
Note You must run this statement at all stores. You must take this action to verify that you have not created any items at the store level at any of the stores.

Method 4

Make sure that any item that is added to an inventory transfer also exists at a receiving store. If an item that is added to an inventory transfer does not exist at a receiving store, the inventory transfer will not be downloaded at the receiving store.

Method 5

Make sure that you use a number of at least six digits for all inventory transfer numbers. All inventory transfers that have an inventory transfer number of fewer than six digits will fail.

Method 6

The IDs in the Headquarters purchase order table and in the Headquarters inventory transfer log table must not be larger than the IDs at the store level. Therefore, determine whether you have IDs in the headquarters database that are larger than the IDs in the store databases. If you have IDs in the headquarters database that are larger than the IDs in the store databases, unnecessary records exist at headquarters. You must delete these records from the headquarters database.

To do this, follow these steps:
  1. On the File menu in Store Operations Administrator, click Connect, type the SQL Server password, and then click OK to connect to the Store Operations database.
  2. On the Query menu, click New.
  3. Copy the following SQL statements, paste them in the New Query window, and then press F5 to run the statements.

    Note You must run these SQL statements separately. For each statement, you must note the MAX(ID) value that is returned. You will use the MAX(ID) values in step 6. Additionally, you may use the MAX(ID) values in step 7.
    SELECT MAX(ID) FROM PurchaseOrder

    SELECT MAX(ID) FROM PurchaseOrderEntry

    SELECT MAX(ID) FROM PurchaseOrderEntryDetail

    SELECT MAX(ID) FROM InventoryTransferLog
  4. On the File menu in Headquarters Administrator, click Connect, type the SQL Server password, and then click OK to connect to the headquarters database.
  5. On the Query menu, click New
  6. Copy the following SQL statements, paste them in the New Query window, and then press F5 to run the statements.

    Note Replace the Y variable in the following SQL statements with the store ID for the store with which you are working.

    Note You must run the following SQL statements separately.
    SELECT MAX(ID) FROM PurchaseOrder WHERE  StoreID = Y

    SELECT MAX(ID) FROM PurchaseOrderEntry WHERE StoreID = Y

    SELECT MAX(ID) FROM PurchaseOrderEntryDetail WHERE StoreID = Y

    SELECT MAX(ID) FROM InventoryTransferLog WHERE StoreID = Y
    Note the MAX(ID) values that these statements return, and then compare those values to the MAX(ID) values that you received when you ran the corresponding SQL statements at the store level in step 3. The MAX(ID) values that are returned in this step (step 6) should be equal to or less than the store MAX(ID) values that were returned in step 3.
  7. If the MAX(ID) values that were returned in step 6 (the values in the tables at headquarters) are greater than the MAX(ID) values that were returned in step 3 (the values at the store), unnecessary records exist at headquarters. You must delete these records from the headquarters database.

    To delete these records, you must run an appropriate query. This query is reproduced in this step. The query is based on a table that has too many records in the headquarters database.

    Notes
    • Replace the Y variable in the following SQL statements with the store ID.
    • Replace the X variable in the following SQL statements with the MAX(ID) value that was calculated for that table in step 3.
    • If the MAX(ID) value that was returned in step 6 was equal to or less than the MAX(ID) value that was returned in step 3, you do not have to run a delete statement for that table.
    DELETE PurchaseOrder WHERE StoreID = Y AND ID > X

    DELETE PurchaseOrderEntry WHERE StoreID = Y AND ID > X

    DELETE PurchaseOrderEntryDetail WHERE StoreID = Y AND ID > X

    DELETE InventoryTransferLog WHERE StoreID = Y AND ID > X
  8. Verify that the MAX(ID) values in the tables at headquarters are not larger than the MAX(ID) values at the store. To do this, complete steps 1 through 7 for each store.

MORE INFORMATION

The following steps will help you avoid experiencing the symptoms that are mentioned in the "Symptoms" section.
  1. Make sure that you select Inter-store in the inventory transfer window. Additionally, make sure that the correct receiving store is selected on each inventory transfer that is created at the issuing store.
  2. Make sure that items are not created at the store level. By using Store Operations security, you can disable the New button that allows cashiers to create new items at the store. For more information about Store Operations security, press F1 to display the Help file.
  3. Process all Headquarters and Store Operations updates, service packs, and hotfixes as soon as they are released.

    Note For more information about the updates, service packs, and hotfixes that have been released for Headquarters and for Store Operations, see the Microsoft Knowledge Base articles that are listed in method 1 of the "Resolution" section.

Properties

Article ID: 911389 - Last Review: July 26, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Retail Management System Headquarters 1.3
  • Microsoft Retail Management System Store Operations 1.3
Keywords: 
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