Non è possibile connettersi a Internet e non è possibile aggiungere o accedere al dominio se Windows Server 2003 SP1 è installato nel controller di dominio di autenticazione

Questo articolo fornisce una soluzione a un problema a cui i client non possono accedere o partecipare al dominio.

Si applica a: Windows Server 2003
Numero KB originale: 912023

Sintomi

Considerate il seguente scenario: Un computer client basato su Microsoft Windows XP viene aggiunto a un dominio di Microsoft Windows Server 2003. Inoltre, Windows Server 2003 Service Pack 1 (SP1) viene installato nel controller di dominio di autenticazione. In questo scenario si riscontrano i sintomi seguenti:

  • Non è possibile connettersi a Internet.
  • Non è possibile aggiungere o accedere al dominio. Pertanto, il controller di dominio è in modalità IPsec Block.

Quando si avvia il componente servizi IPSEC nel controller di dominio, è possibile che venga visualizzato un messaggio di errore simile al seguente:

Impossibile trovare il file specificato.

Inoltre, è possibile che nel log di sistema del server vengano registrati gli eventi seguenti:

Tipo evento: Errore
Origine evento: IPSEC
Categoria di eventi: Nessuna
ID evento: 4292
Date: <DateTime>
Ora: <DateTime>
Utente: N/D
Computer: <ComputerName>
Descrizione:
Il driver IPSec è entrato in modalità blocco. IPSec eliminerà tutto il traffico di rete TCP/IP in ingresso e in uscita che non è consentito dalle esenzioni dei criteri IPSec in fase di avvio.

Tipo evento: Errore
Origine evento: Service Control Manager
Categoria di eventi: Nessuna
ID evento: 7023
Date: <DateTime>
Ora: <DateTime>
Utente: N/D
Computer: <ComputerName>
Descrizione:
Il servizio Servizi IPSEC è terminato con l'errore seguente: Il sistema non riesce a trovare il file specificato

Causa

Questo problema può verificarsi se la chiave del Registro di sistema IPSec\Policy\Local viene eliminata o se nell'archivio criteri è presente un file danneggiato. Il file potrebbe essere danneggiato se si verifica un'interruzione durante la scrittura dei criteri sul disco.

Risoluzione

Importante

In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire backup e ripristino del Registro di sistema, vedere Backup e ripristino del Registro di sistema in Windows.

Per risolvere questo problema, attenersi alla seguente procedura:

  1. Eliminare la sottochiave del Registro di sistema dei criteri locali. A tal fine, attenersi alla seguente procedura:

    1. Fare clic su Start, Esegui, digitare regedit nella casella Apri, quindi fare clic su OK.

    2. In Registro di sistema Editor individuare e quindi fare clic sulla sottochiave seguente:

      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\IPSec\Policy\Local

    3. Scegliere Elimina dal menu Modifica .

    4. Fare clic su per confermare che si vuole eliminare la sottochiave.

    5. Chiudere l'editor del Registro di sistema.

  2. Ricompilare un nuovo archivio criteri locale. A tale scopo, fare clic su Start, fare clic su Esegui, digitare regsvr32 polstore.dll nella casella Apri e quindi fare clic su OK.

  3. Verificare che il componente Servizi IPSEC sia impostato su automatico e quindi riavviare il controller di dominio.

Soluzione alternativa

Per risolvere temporaneamente questo problema, disabilitare il componente Servizi IPSEC e quindi riavviare il controller di dominio.