当您在运行 Windows Server 2003 Service Pack 1 (SP1) 或 x64 版本 Windows 的计算机上使用 HP SecurePath 时,记录事件 ID 50、26 或 57

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您在运行 Microsoft Windows Server 2003 Service Pack 1 (SP1) 或 x64 版本 Windows 的计算机上使用 Hewlett-Packard (HP) SecurePath。在这种情况下,系统日志中记录一个或多个以下事件 ID:
事件类型:警告
事件来源:Ntfs
事件类别:无
事件 ID: 50
时间:日期
时间:时间
用户:N/A
计算机:Computer_Name
描述:
{延迟写入失败} Windows 无法保存该文件的所有数据。数据可能已丢失。这个错误可能是由计算机硬件或网络连接故障所致。请将这个文件存到别的地方。

有关更多信息,请参见位于 http://www.microsoft.com/contentredirect.asp 的帮助和支持中心。
数据:
0000: 00040004 00520002 00000000 80040032
0010: 00000000 c000003c 00000000 00000000
0020: 00000000 00000000 c000003c
有关事件 ID 50 的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
816004 事件 ID 50 错误消息描述
事件类型:信息
事件来源:弹出应用程序
事件类别:无
事件 ID: 26
时间:日期
时间:时间
用户:N/A
计算机:Computer_Name
描述:
弹出应用程序:Windows - 延迟写入失败:Windows 无法保存文件 DRIVE:\FILE 的所有数据。数据可能已丢失。这个错误可能是由计算机硬件或网络连接故障所致。请将这个文件存到别的地方。

有关更多信息,请参见位于 http://www.microsoft.com/contentredirect.asp 的帮助和支持中心。
事件类型:警告
事件来源:Ftdisk
事件类别:磁盘
事件 ID: 57
时间:日期
时间:时间
用户:N/A
计算机:Computer_Name
描述:
系统未能将数据刷新到事务日志中。可能出现损坏现象。

有关更多信息,请参见位于 http://www.microsoft.com/contentredirect.asp 的帮助和支持中心。
数据:
0000: 00000000 00be0001 00000002 80040039
0010: 00000000 c000003c 00000000 00000000
0020: 00000000 00000000
与该问题相关的错误在记录的事件中包含状态代码 c000003c。该状态代码也称为 STATUS_DATA_OVERRUN。不包含状态代码 c000003c 的记录事件有不同的原因,与该问题无关。

在 Microsoft 服务器群集 (MSCS) 中,您可能看到群集节点间歇性地无法保留共享磁盘。在事件查看器中,您可以看到以下条目:
事件类型:错误
事件来源:ClusSvc
事件类别:物理磁盘资源
事件 ID: 1038
日期: 27.04.2006
时间: 05:44:22
用户:N/A
计算机:Computer_Name
描述:
保留的群集磁盘“Cluster_disk_name:”丢失。请检查您的系统和磁盘配置。有关更多信息,请参见位于 http://www.microsoft.com/contentredirect.asp 的帮助和支持中心。
在 clusdisk 驱动器的软件跟踪日志和群集日志中,您还将看到以下日志:

04\27\2006-05:44:19:752 ReserveScsiDevice(8A622408):Exit => STATUS_SUCCESS :
04\27\2006-05:44:20:361 GetDriveLayoutEx failed for DO 8A6154E0, 0xc00000a3 (STATUS_DEVICE_NOT_READY)
04\27\2006-05:44:20:408 GetDriveLayoutEx failed for DO 8A620528, 0xc00000a3 (STATUS_DEVICE_NOT_READY)
04\27\2006-05:44:20:424 GetDriveLayoutEx failed for DO 8A61DBA0, 0xc00000a3 (STATUS_DEVICE_NOT_READY):
04\27\2006-05:44:22:752 ClusDiskReservationWorker:LostReserve DO 8A622408 DiskNo 3 status 0xc000003c (STATUS_DATA_OVERRUN) (operation 0)

群集日志将同时报告以下事件:

2006/04/27-03:44:22.752 INFO Physical Disk <Disk_Name:>:[DiskArb] CompletionRoutine, status 1117.
2006/04/27-03:44:22.752 ERR Physical Disk <Disk_Name:>:[DiskArb] CompletionRoutine:reservation lost!Status 1117
2006/04/27-03:44:25.533 ERR Physical Disk <Disk_Name:>:LooksAlive, error checking device, error 1117.
2006/04/27-03:44:25.533 ERR Physical Disk <Disk_Name:>:IsAlive, error checking device, error 1117. This is seen sporadically and does not show up in the boot phase of the cluster nodes.

原因

该问题是由于对 Windows Server 2003 SP1 中的 Classpnp.sys 文件所做的更改导致的。这些更改同时合并到 x64 版本的 Windows 中。它们导致与 HP SecurePath 中的 Raiddisk.sys 驱动程序的兼容性问题。

解决方案

修补程序信息

Microsoft 现在提供了一个受支持的修补程序,但该程序只用于解决本文中描述的问题。只有系统遇到本文提到的特定问题时才可应用此修补程序。此修补程序可能还会接受进一步的测试。因此,如果这个问题没有对您造成严重的影响,我们建议您等待包含此修补程序的下一个 Service Pack。

要立即解决此问题,请与 Microsoft 产品支持服务联系,以获取此修补程序。要获取 Microsoft 产品支持服务电话号码和支持费用信息的完整列表,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support
注意:特殊情况下,如果 Microsoft 支持专业人员确定某个特定的更新能够解决您的问题,可免收通常情况下收取的电话支持服务费用。对于所述的特定更新无法解决的其他支持问题和事项,将照常收取支持费用。

先决条件

必须运行 Windows Server 2003 SP1,才能安装此修补程序。

注意:基于 x64 版本的 Windows 不需要 Windows Server 2003 SP1 便可安装该修补程序。

重新启动要求

应用此修补程序后,必须重新启动计算机。在安装该修补程序的过程中,下列服务会自动停止然后重新启动。
HTTP SSL
IIS Admin 服务
HTTP SSL
Microsoft Exchange 路由引擎
简单邮件传输协议 (SMTP)
万维网发布服务

修补程序替代信息

此修补程序不替代任何其他修补程序。

文件信息

此修补程序的英文版具有下表中列出的文件属性(或更新的文件属性)。这些文件的日期和时间按协调世界时 (UTC) 列出。当您查看文件信息时,此时间将转换为当地时间。要了解 UTC 与本地时间之间的时差,请使用“控制面板”中“日期和时间”项的“时区”选项卡。
Windows Server 2003(基于 x86 的版本)
收起该表格展开该表格
文件名文件版本文件大小日期时间平台
Classpnp.sys5.2.3790.260054,78422-Dec-200523:58x86
Windows Server 2003(基于 x64 的版本)
收起该表格展开该表格
文件名文件版本文件大小日期时间平台
Classpnp.sys5.2.3790.260098,30423-Dec-200501:19x64
Windows Server 2003(基于 Itanium 的版本)
收起该表格展开该表格
文件名文件版本文件大小日期时间平台
Classpnp.sys5.2.3790.2600161,28023-Dec-200501:19IA-64

状态

Microsoft 已经确认这是在“适用于”一节中列出的 Microsoft 产品中存在的问题。

更多信息

有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684 有关用于描述 Microsoft 软件更新标准术语的介绍

对基于 x64 的 Microsoft Windows 版本的技术支持

硬件制造商为基于 x64 的 Windows 版本提供了技术支持和帮助。硬件制造商提供支持是因为基于 x64 的 Windows 版本是随硬件提供的。您的硬件制造商可能自定义了使用独特组件的 Windows 安装。这些独特组件可能包括特定设备驱动程序,或者可能包括实现硬件性能最大化所用的可选设置。如果您需要基于 x64 的 Windows 版本的技术帮助,Microsoft 将尽可能提供合理的帮助。但是,您可能必须与制造商直接联系。您的制造商最有资格为安装在您的硬件上的软件提供支持。

有关 Microsoft Windows XP Professional x64 Edition 的产品信息,请访问下面的 Microsoft 网站:
http://www.microsoft.com/china/windowsxp/64bit/default.mspx
有关基于 x64 的 Microsoft Windows Server 2003 版本的产品信息,请访问下面的 Microsoft 网站:
http://www.microsoft.com/china/windowsserver2003/64bit/x64/default.mspx
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。对于这些产品的性能或可靠性,Microsoft 不作任何暗示保证或其他形式的保证。

属性

文章编号: 912593 - 最后修改: 2006年11月3日 - 修订: 3.1
这篇文章中的信息适用于:
  • Microsoft Windows Server 2003 Service Pack 1?当用于
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Professional x64 Edition
关键字:?
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