ID do artigo: 912949 - Última revisão: quinta-feira, 11 de outubro de 2007 - Revisão: 2.6

Alguns aplicativos de terceiros que usam arquivos de manifesto externos parem de funcionar após a instalação do Windows server 2003 Service Pack 1

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Depois de instalar o Microsoft Windows Server 2003 Service Pack 1 (SP1) em um computador, alguns aplicativos de terceiros parar de funcionar. Esse problema ocorre se os aplicativos dependem dos componentes em arquivos de manifesto externos.

Causa

Esse problema ocorre porque a prioridade de pesquisa do arquivo de manifesto lado a lado (SxS) é alterada quando você instalar o Windows Server 2003 SP1.

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Windows Server 2003 SP1 deve ser instalado no computador.
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003 com Service Pack 1, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Kernel32.dll5.2.3790.26071,038,84804 De janeiro de 200603: 51x 86
Updspapi.dll6.2.29.0371,42412 De outubro de 200523: 13x 86
Windows Server 2003, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Kernel32.dll5.2.3790.26071,501,69603 De janeiro de 200612: 31x 64SP1SP1QFE
Wkernel32.dll5.2.3790.26071,008,64003 De janeiro de 200612: 31x 86SP1UAU
Updspapi.dll6.2.29.0462,04803 De janeiro de 200612: 34x 64NenhumNão aplicável
Windows Server 2003 com Service Pack 1, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Kernel32.dll5.2.3790.26071,967,10403 De janeiro de 200612: 33IA-64SP1SP1QFE
Wkernel32.dll5.2.3790.26071,008,64003 De janeiro de 200612: 33x 86SP1UAU
Updspapi.dll6.2.29.0638,68803 De janeiro de 200612: 34IA-64NenhumNão aplicável

Depois de instalar o hotfix

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Depois de instalar o hotfix, você deve criar a entrada de registro PreferExternalManifest. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide
  3. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  4. Digite PreferExternalManifest e, em seguida, pressione ENTER.
  5. Clique com o botão direito do mouse PreferExternalManifest e, em seguida, clique em Modificar .
  6. Na caixa de diálogo Editar valor DWORD , clique em decimal em base .
  7. Na caixa dados do valor , digite 1 e, em seguida, clique em OK .
  8. No menu arquivo , clique em Sair para fechar o Editor do Registro.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Server 2003 Service Pack 2.

Mais Informações

Conjuntos de módulos lado--permitir que aplicativos especificar qual versão de um componente da DLL de sistema ou de um COM (clássico Component Object Model) componente usar. Por exemplo, se um aplicativo de serviços corporativos depende de uma versão específica de um assembly dependente, o aplicativo poderá usar essa versão do assembly mesmo depois que as versões mais recentes tiverem sido instaladas.

O manifesto de aplicativo é um arquivo XML que tem informações sobre onde um componente da DLL está instalado. O arquivo de manifesto é usado para criar um contexto de ativação para o aplicativo. Um contexto de ativação permite que um aplicativo carregar uma determinada versão DLL ou instância do objeto COM.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Service Pack 1 nas seguintes plataformas
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbexpertisebeginner kbhotfixserver kbqfe KB912949 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 912949  (http://support.microsoft.com/kb/912949/en-us/ )