SQL Server 2005 Reporting Services ne pas enregistrer les fichiers de vidage à l'emplacement que vous spécifiez dans Dr. Watson pour Windows outil

Traductions disponibles Traductions disponibles
Numéro d'article: 913046 - Voir les produits auxquels s'applique cet article
Bogue #: 20011181 (SQLBUDT)
Agrandir tout | Réduire tout

Symptômes

Envisagez le scénario suivant. Vous souhaitez définir un emplacement de fichier image pour Microsoft SQL Server 2005 Reporting Services. Pour ce faire, vous indiquer un emplacement pour le vidage des incidents option de Dr. Watson pour Windows programme erreur débogueur outil. Dans ce scénario, SQL Server 2005 Reporting Services continue enregistrer le fichier de vidage à son emplacement de fichiers journaux. SQL Server 2005 Reporting Services n'enregistre pas les fichiers d'images à l'emplacement que vous spécifiez dans Dr. Watson pour Windows outil.

note Dr. Watson pour Windows outil est fourni avec Microsoft Windows.

Cause

Ce problème se produit car SQL Server 2005 rapport services génère un fichier de vidage à l'emplacement suivant par défaut :
Drive: \Program Files\Microsoft SQL Server\MSSQL.x\Reporting Services\LogFiles
notes
  • Drive représente le lecteur sur lequel SQL Server 2005 Reporting Services est installé.
  • MSSQL.x représente l'ID instance correspondante pour le système. Pour déterminer l'ID d'instance pour le système, procédez comme suit :
    1. Se connecter à l'instance de le Server SQL Reporting Services service en utilisant l'outil de configuration de Reporting Services.
    2. Cliquez sur l' état du serveur pour ouvrir la page Rapport sur état du serveur .
    3. Sur la page Rapport sur état du serveur , notez les informations de code instance.

Contournement

Avertissement Des problèmes graves peuvent se produire si vous modifier les fichiers de configuration incorrecte. Assurez-vous que vous disposez d'une copie des fichiers configuration avant de les modifier.

Pour contourner ce problème, spécifiez le nouvel emplacement pour le fichier de vidage dans les fichiers de configuration pour SQL Server 2005 Reporting Services. Pour ce faire, procédez comme suit :
  1. Dans le bloc-notes, ouvrez le fichier ReportingServicesService.exe.config qui se trouve dans le dossier suivant :
    Drive: \Program Files\Microsoft SQL Server\ MSSQL.x \Reporting Services\ReportServer\Bin
  2. Ajoutez le code suivant à la section <rstrace> :
    <add name="FileName" value="ReportServer_" />
    <add name="Directory" value="YourPath" />
    Remarque YourPath représente le dossier dans lequel vous voulez que SQL Server 2005 Reporting Services pour enregistrer les fichiers image.
  3. Dans le bloc-notes, ouvrez le fichier Web.config qui se trouve dans le dossier suivant :
    Drive: \Program Files\Microsoft SQL Server\ MSSQL.x \Reporting Services\ReportServer
  4. Ajoutez le code qui est répertorié dans l'étape 2 dans le fichier Web.config.
  5. Dans le bloc-notes, ouvrez le fichier Web.config qui se trouve dans le dossier suivant :
    Drive: \Program Files\Microsoft SQL Server\ MSSQL.x \Reporting Services\ReportManager
  6. Ajoutez le code qui est répertorié dans l'étape 2 dans le fichier Web.config.
note La modification de l'emplacement de répertoire pour les fichiers image modifie également l'emplacement pour les fichiers journaux SQL Server Reporting Services. Vous devez définir des autorisations dans le dossier nouveau faire correspondre les autorisations sur le dossier de fichiers journaux.

Plus d'informations

Pour afficher les fichiers d'aide pour Dr. Watson pour Windows outil, procédez comme suit :
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez drwtsn32.exe et puis cliquez sur OK . L'outil de Dr.Watson pour Windows s'ouvre.
  2. Cliquez sur Aide .

Propriétés

Numéro d'article: 913046 - Dernière mise à jour: mardi 14 février 2006 - Version: 3.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft SQL Server 2005 Reporting Services
Mots-clés : 
kbmt kbsql2005rs kbprb KB913046 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 913046
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com