Chybová zpráva při pokusu o instalaci ovládacího prvku ActiveX nebo při pokusu o proces ověření WGA v systému Windows XP s aktualizací Service Pack 2: "8024402c"

Překlady článku Překlady článku
ID článku: 913460 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem obnovení registru v případě, že nastane problém. Další informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Po upgradu počítače na systém Windows XP Service Pack 2 (SP2) pokusíte nainstalovat ovládací prvek ActiveX. Nebo dokončit proces ověření Microsoft Windows Genuine Advantage (WGA). Však zobrazí následující chybová zpráva:
8024402C

Příčina

K tomuto problému dochází, protože pozadí inteligentního Transfer (BITS) 2.0 klient odešle implicitní pověření serveru proxy. To způsobí, že server proxy vrátit kód náhodné stavu. Klientský počítač tedy nelze stáhnout aktualizace z webu Windows Update.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li použít tuto opravu hotfix, musí mít Windows XP Service Pack 2.

Požadavek na restartování

Po instalaci této opravy hotfix není třeba počítač restartovat.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce datum a čas v ovládacím.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Qmgr.dll6.6.2600.2848381,95216. Února 200605: 29X86

Informace o instalaci opravy hotfix

Po použití této opravy hotfix, musíte odstranit složku softwaredistribution povolit opravu hotfix. Odstranit složku softwaredistribution, zadejte následující příkazy příkazového řádku. Každý příkaz potvrďte stisknutím klávesy ENTER.
  • %windir%\system32\net.exe stop wuauserv
  • CD /d % windir %
  • RD /s softwaredistribution
  • CD system32
  • regsvr32 wuapi.dll
  • REGSVR32 WUAUENG1.DLL
  • regsvr32 wuaueng.dll
  • REGSVR32 WUCLTUI.DLL
  • REGSVR32 WUPS.DLL
  • NET.exe start wuauserv

Jak potíže obejít

Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Chcete-li tento problém vyřešit, změnit hodnotu položky registru lmcompatibilitylevel 0 nebo 1. Postupujte takto.

Poznámka: Výchozí hodnota této položky registru je 2 nebo vyšší hodnotu.
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte Regedit a klepněte na tlačítko OK.
  2. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. V podokně podrobností poklepejte na položku registru lmcompatibilitylevel.
  4. V poli Údaj, typ 1 nebo 0 v závislosti na prostředí. Poté klepněte na tlačítko OK.
  5. Ukončete program Editor registru a restartujte počítač.
Další informace o nastavení možnosti zabezpečení LMCompatibility viz tabulka 4.6 v následující web společnosti Microsoft:
http://technet.microsoft.com/en-us/library/dd277307.aspx

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Další informace o termínech používaných k popisu aktualizací softwaru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 913460 - Poslední aktualizace: 29. srpna 2007 - Revize: 2.3
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Service Pack 2 na těchto platformách
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
  • Microsoft Windows Genuine Advantage
Klíčová slova: 
kbmt kbautohotfix kbexpertiseinter kbfix kbhotfixserver kbqfe kbpubtypekc KB913460 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:913460

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com