Winshow explorador hijacker provoca errores y los sitios Web no deseados a abrir en Internet Explorer

Seleccione idioma Seleccione idioma
Id. de artículo: 913505 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando inicia Microsoft Internet Explorer 6, puede experimentar uno o varios de los síntomas siguientes:
  • Puede recibir un mensaje de error similar al siguiente. A continuación, Internet Explorer puede cerrarse inesperadamente.
    Internet Explorer ha detectado un problema y debe cerrarse
    nombre de la aplicación: iexplorer.exe
    nombre mod: winshow.dll
  • Puede recibir un mensaje de error similar al siguiente. A continuación, Internet Explorer puede cerrarse inesperadamente.
    Infracción de acceso: Internet Explorer ha detectado un problema y tiene que cerrar.
  • Puede cambiar su página principal a la página Searchv.com Web.
  • En ocasiones, Internet Explorer aleatoriamente pueden abrir sitios Web no deseados.

Causa

Este problema puede producirse si hijacker de explorador Winshow se ha instalado en el equipo. Winshow puede cambiar la página principal de Internet Explorer y la configuración de búsqueda sin su permiso. Winshow está instalado como un objeto del Ayudante del Internet Explorer explorador (BHO).

Solución

Para resolver este problema, debe quitar los archivos Winshow y las entradas del registro que instala Winshow. Además, debe restablecer Internet Explorer en su configuración predeterminada.


Para resolver este problema, siga estos pasos en orden.

Paso 1: Quitar los archivos Winshow

Nota como hay varias versiones de Microsoft Windows, los pasos siguientes pueden ser diferentes en su equipo. En tal caso, consulte la documentación del producto para realizar estos pasos.

Nota Algunos de los archivos que aparecen en los pasos siguientes no pueden instalarse en el equipo. En este caso, puede recibir un mensaje de error que indica que no se pudo encontrar el módulo especificado. Cuando esto ocurre, haga clic en Aceptar y continúe con el paso siguiente.
Microsoft Windows XP, Microsoft Windows Server 2003, Microsoft Windows 2000 y Microsoft Windows NT
Para anular el registro los archivos Winshow en un equipo que está ejecutando uno de estos sistemas operativos, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba cmd y, a continuación, haga clic en Aceptar .
  2. Escriba los comandos siguientes. Presione ENTRAR después de cada comando.
    • CD %WinDir%\
    • regsvr32/u "..\winshow.dll"
    • regsvr32/u "..\ mshp.dll"
    • CD "% WinDir%\System"
    • regsvr32/u "..\winshow.dll"
    • regsvr32/u "% AppData%\winshow\winshow.dll"
    • Salir
  3. Cierre todos los programas y, a continuación, reinicie el equipo.
Microsoft Windows Millennium Edition
Para anular el registro los archivos Winshow en un equipo que está ejecutando Windows Millennium Edition, siga estos pasos:
  1. Haga clic en Inicio , seleccione Todos los programas , Accesorios y, a continuación, haga clic en MS-DOS .
  2. Escriba los comandos siguientes. Presione ENTRAR después de cada comando.
    • CD %WinDir%\
    • regsvr32/u "..\winshow.dll"
    • regsvr32/u "..\ mshp.dll"
    • CD "% WinDir%\System"
    • regsvr32/u "..\winshow.dll"
    • regsvr32/u "..\Application Data\winshow\winshow.dll"
    • Exit
  3. Cierre todos los programas y, a continuación, reinicie el equipo.
Microsoft Windows 98
Para anular el registro los archivos Winshow en un equipo que ejecuta Windows 98, siga estos pasos:
  1. Haga clic en Inicio , seleccione Todos los programas y, a continuación, haga clic en MS-DOS .
  2. Escriba los comandos siguientes. Presione ENTRAR después de cada comando.
    • CD %WinDir%\
    • regsvr32/u "..\winshow.dll"
    • regsvr32/u "..\ mshp.dll"
    • CD "% WinDir%\System"
    • regsvr32/u "..\winshow.dll"
    • regsvr32/u "..\Application Data\winshow\winshow.dll"
    • Salir
  3. Cierre todos los programas y, a continuación, reinicie el equipo.

Paso 2: Quitar los archivos Winshow y las entradas de registro Winshow

Para quitar los archivos y las entradas del registro, o bien puede utilizar la detección de terceros y eliminación software, o bien puede quitar manualmente los archivos y las entradas del registro.

Análisis en línea

Software de seguridad: descargas y ensayos

http://www.windowsmarketplace.com
Microsoft proporciona información de contacto con otros proveedores para ayudarle a encontrar soporte técnico. Esta información de contacto puede cambiar sin previo aviso. Microsoft no ofrece ninguna garantía con respecto a la exactitud de esta información de contacto con otros proveedores.

La información y la solución en este documento representa la visión actual de Microsoft Corporation sobre estos problemas la fecha de publicación. Esta solución está disponible a través de Microsoft o a través un proveedor de terceros. Microsoft no recomienda específicamente cualquier proveedor de terceros o una solución de terceros que describa este artículo. Puede haber otros proveedores de terceros o soluciones de terceros que no se describe en este artículo. Dado que Microsoft debe responder a las condiciones cambiantes del mercado, esta información no debe interpretarse como un compromiso por Microsoft. Microsoft no puede garantizar ni respalda la precisión de ninguna información o de cualquier solución que se presenta por Microsoft o por cualquier proveedor de terceros mencionado.

Microsoft no otorga ninguna garantía y excluye todo representaciones, garantías y condiciones ya expresa, implícita o legal. Estos incluyen pero no limitados a las representaciones, garantías o condiciones de título, no infracción, condición satisfactoria, comerciabilidad e idoneidad para un fin determinado, con respecto a cualquier servicio, solución, producto, o cualquier otro material o información. En ningún caso será Microsoft responsable de cualquier solución de terceros que mencione en este artículo.

Quitar manualmente los archivos Winshow y las entradas de registro Winshow

Nota Algunos de los archivos o las entradas del registro que aparecen en los pasos siguientes no pueden instalarse en el equipo. En este caso, vaya al paso siguiente.

Quitar manualmente los archivos de Winshow. Para ello, siga estos pasos:
  1. Cerrar todos los programas, ventanas del explorador y Explorador de Windows.
  2. Haga clic en Inicio y, a continuación, haga clic en Buscar .
  3. Haga clic en todos los archivos y carpetas y, a continuación, escriba Winshow en el cuadro todo o parte del nombre de archivo .
  4. Haga clic en Más opciones avanzadas y, a continuación, active la casilla de verificación Buscar todos los archivos y carpetas ocultos .
  5. Haga clic en Buscar .
  6. Haga clic con el botón secundario en cada archivo Winshow o la carpeta que encuentre y, a continuación, haga clic en Eliminar .
  7. Haga clic en Atrás .
  8. Escriba msupdater.exe en el cuadro todo o parte del nombre de archivo y, a continuación, haga clic en Buscar . Elimine el archivo Msupdater.exe si se encuentra.
  9. Haga clic en Inicio , haga clic en Ejecutar , escriba cmd y, a continuación, haga clic en Aceptar .
  10. Escriba los comandos siguientes. Presione ENTRAR después de cada comando.
    • CD %WinDir%\
    • winlink.dll del
    • dict.dat del
    • dllreg.exe del
    • sys.reg del
    • Salir
importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
Quitar manualmente las entradas de registro Winshow. Para ello, siga estos pasos:
  1. Cerrar todos los programas, ventanas del explorador y Explorador de Windows.
  2. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  3. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_CURRENT_USER\SOFTWARE\Winshow
    Haga clic en para confirmar.
  4. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    {6cc1c918-ae8b-4373-a5b4-28ba1851e39a} HKEY_CLASSES_ROOT\CLSID\
    Haga clic en para confirmar.
  5. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_CLASSES_ROOT\TypeLib\{354a1552-9a59-417e-87cb-0d040a85b4d6}\c:\windows\winshow.dll
    Haga clic en para confirmar.
  6. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_CLASSES_ROOT\TypeLib\ {6cc1c918-ae8b-4373-a5b4-28ba1851e39a}
    Haga clic en para confirmar.
  7. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_CLASSES_ROOT\Winlink.viewsource
    Haga clic en para confirmar.
  8. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_CLASSES_ROOT\Winlink.viewsource.1
    Haga clic en para confirmar.
  9. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_CLASSES_ROOT\Winshow.viewsource
    Haga clic en para confirmar.
  10. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_CLASSES_ROOT\Winshow.viewsource.1
    Haga clic en para confirmar.
  11. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_CURRENT_USER\SOFTWARE\Winshow
    Haga clic en para confirmar.
  12. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_LOCAL_MACHINE\CLSID\ {6cc1c918-ae8b-4373-a5b4-28ba1851e39a}
    Haga clic en para confirmar.
  13. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\ {6cc1c918-ae8b-4373-a5b4-28ba1851e39a}
    Haga clic en para confirmar.
  14. Haga clic con el botón secundario en la siguiente subclave del registro y, a continuación, haga clic en Eliminar :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser ayuda Objects\ {6cc1c918-ae8b-4373-a5b4-28ba1851e39a}
    Haga clic en para confirmar.
  15. Cierre el Editor del registro.

Paso 3: Restablecer Internet Explorer para la configuración predeterminada

Nota No debe realizar la siguiente función si utiliza un servidor proxy. Quizás tenga que póngase en contacto con un administrador del sistema o proveedor de servicios antes de continuar. Para obtener más información acerca de cómo configurar un servidor proxy en Internet Explorer, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
135982 Cómo configurar Internet Explorer para utilizar un servidor proxy
  1. Restablecer la página principal de Internet Explorer y la página de búsqueda. Para ello, siga estos pasos.

    Nota Este procedimiento restaura la página de principal de Internet Explorer y la página de búsqueda a la configuración predeterminada.
    1. Inicie Internet Explorer y, a continuación, haga clic en Opciones de Internet en el menú Herramientas .
    2. En la ficha programas , haga clic en Restablecer configuración Web .
    3. En el cuadro de diálogo Restablecer configuración Web , haga clic en casilla de verificación Restablecer también la página principal y, a continuación, haga clic en .
    4. Haga clic en Aceptar dos veces.
  2. Desactivar extensiones de explorador de terceros. Para ello, siga estos pasos:
    1. Inicie Internet Explorer y, a continuación, haga clic en Opciones de Internet en el menú Herramientas .
    2. En la ficha Avanzadas , desplácese a la sección de exploración y, después, haga clic para desactivar la Habilitar extensiones de explorador de terceros (requiere reinicio) casilla de verificación.
    3. Haga clic en Aceptar para cerrar el cuadro de diálogo Opciones de Internet .
  3. Eliminar archivos temporales de Internet de Internet y cookies. Para ello, siga estos pasos:
    1. Inicie Internet Explorer y, a continuación, haga clic en Opciones de Internet en el menú Herramientas .
    2. En la ficha General , haga clic en Eliminar Cookies y, a continuación, haga clic en Aceptar .
    3. Haga clic en Eliminar archivos .
    4. En el cuadro de diálogo Eliminar archivos , haga clic en casilla de verificación Eliminar todo el contenido sin conexión y, a continuación, haga clic en Aceptar .
    5. Haga clic en Borrar historial y, a continuación, haga clic en .
    6. Haga clic en configuración y, a continuación, haga clic en Ver objetos .
    7. En el menú Edición , haga clic en Seleccionar todo y, a continuación, presione SUPR.
    8. Haga clic en para comprobar que desea eliminar los archivos y, a continuación, cierre el cuadro de diálogo Archivos de programa descargados .
    9. En el cuadro de diálogo configuración , haga clic en Aceptar .
    10. En el cuadro de diálogo Opciones de Internet , haga clic en la ficha seguridad .
    11. Haga clic en Internet , mueva el control deslizante de Nivel de seguridad a medio y, a continuación, haga clic en Aplicar .
    12. Haga clic en la ficha privacidad , mueva el control deslizante de Nivel de seguridad a medio y, a continuación, haga clic en Aplicar .
    13. Haga clic en la ficha conexiones y, a continuación, haga clic en Configuración LAN .
    14. En el cuadro de diálogo configuración de red de área Local (LAN) , haga clic para desactive las casillas de verificación y, a continuación, haga clic en Aplicar .

Paso 4: Cambiar el nombre del archivo hosts

Windows XP, Windows Server 2003, Windows 2000 y Windows NT

Cambiar el nombre del archivo hosts en un equipo que está ejecutando uno de estos sistemas operativos, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba cmd y, a continuación, haga clic en Aceptar .
  2. Escriba los comandos siguientes. Presione ENTRAR después de cada comando.
    • ren %windir%\SYSTEM32\DRIVERS\ETC\hosts hosts.old
    • Salir
  3. Cierre todos los programas y, a continuación, reinicie el equipo.

Microsoft Windows Millennium Edition

Cambiar el nombre del archivo hosts en un equipo que está ejecutando uno de estos sistemas operativos, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba cmd y, a continuación, haga clic en Aceptar .
  2. Escriba los comandos siguientes. Presione ENTRAR después de cada comando.
    • ren %windir%\SYSTEM32\DRIVERS\ETC\hosts hosts.old
    • Salir

Windows 98

Cambiar el nombre del archivo hosts en un equipo que ejecuta Windows 98, siga estos pasos:
  1. Haga clic en Inicio , seleccione Todos los programas , Accesorios y, a continuación, haga clic en .
  2. Escriba los comandos siguientes. Presione ENTRAR después de cada comando.
    • ren C:\WINDOWS\hosts hosts.old
    • Salir

Paso 5: Limpieza de equipo

Los siguientes pasos de limpieza le ayudará a asegurarse de que se han quitado todos los archivos de Winshow. Estos pasos le ayudarán también Asegúrese de que tiene una punto en el equipo de restauración nueva.

Nota Asegúrese de que reinicie el equipo antes de continuar con los pasos siguientes.
  1. Vaciar la Papelera de reciclaje. Para ello, siga estos pasos:
    1. En el escritorio, haga doble clic en el icono de Papelera de reciclaje .
    2. En el panel de tareas en el lado izquierdo de la ventana de la Papelera de reciclaje, haga clic en Vaciar la Papelera de reciclaje .
    3. Haga clic en para confirmar.
    4. Cierre la ventana de la Papelera de reciclaje.
  2. Ejecute la utilidad Liberador de espacio de disco. Para ello, siga estos pasos:
    1. Haga clic en Inicio , seleccione Todos los programas , Accesorios , Herramientas del sistema y, a continuación, haga clic en Liberador de espacio en disco .

      Nota Si el equipo tiene más de una partición, se le pedirá para seleccionar la letra que desea limpiar. Seleccione la unidad que contiene el sistema operativo y los perfiles de usuario y, a continuación, haga clic en Aceptar . Normalmente, es la unidad C.
    2. En el cuadro de diálogo Limpieza de disco , haga clic para seleccionar las casillas de verificación siguientes:
      • archivos temporales de Internet
      • Papelera de reciclaje
      • archivos temporales
    3. Haga clic en Aceptar y, a continuación, haga clic en .
  3. Crear un punto de restauración nueva. Para ello, siga estos pasos:
    1. Haga clic en Inicio , seleccione Todos los programas , Accesorios , Herramientas del sistema y, a continuación, haga clic en Restaurar sistema .
    2. Haga clic en Crear punto de restauración y, a continuación, haga clic en siguiente .
    3. En el cuadro de Descripción de punto de restauración , escriba una descripción adecuada. Por ejemplo, escriba Después Winshow eliminación .

      Nota Esta descripción se supone que le recuerde cuándo y por qué creó este punto de restauración.
    4. Haga clic en crear .
    5. Haga clic en Cerrar para cerrar la ventana Restaurar sistema.
Los productos de terceros mencionados en este artículo son fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.

Propiedades

Id. de artículo: 913505 - Última revisión: martes, 30 de octubre de 2007 - Versión: 1.10
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows Millennium Edition
Palabras clave: 
kbmt kbtshoot kbexpertisebeginner kberrmsg KB913505 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 913505

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com