Stellen Sie eine benutzerdefinierte Symbolleiste/Multifunktionsleiste für alle Benutzer in Project-Clients zur Verfügung

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 913678 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

EINFÜHRUNG

Dieser Artikel beschreibt, wie ein benutzerdefiniertes Makro und Symbolleiste/Multifunktionsleiste mit Schaltflächen zum Ausführen von Makros erstellen). Dieser Artikel beschreibt darüber hinaus die benutzerdefinierten Objekten an die lokalen-global-Projektvorlage (Global.mpt) oder der Enterprise-global-Projektvorlage bereitstellen, wenn Sie Project Server verwenden. Dadurch wird die benutzerdefinierte Symbolleiste/Multifunktionsleiste für alle Benutzer von Microsoft Office Project-Clients verfügbar sein, ob Benutzer in Microsoft Office Project Server eine Verbindung herstellen oder eigenständiges Projekt-Clients verwenden.

Weitere Informationen

Beim Öffnen eines Projekts verwendet Informationen in der lokalen Datei als auch die globale Vorlagendatei zum Festlegen von Standardeinstellungen für den Plan. Die globale Vorlagendatei
enthält, Ansichten, Berichte, Module (Makros), Tabellen, Filter, Kalender, Karten, Felder und Gruppen (Symbolleisten werden in Project 2007 oder früher globale Vorlagendateien jedoch nicht 2010, die Multifunktionsleiste im Jahr 2010 eingeführt wurde). Der Projektplan werden die Standardeinstellungen aus der globalen Vorlage verwendet, es sei denn, Sie neuer erstellen oder Ändern vorhandener Objekte. Benutzerdefinierte Objekte werden an das lokale Projekt gespeichert, wenn Sie die Schritte, die Informationen in die Globaldatei kopieren. Die globale Vorlage kann mit anderen Project-Benutzern Client, entweder durch Senden der Datei global.mpt lokal speichern oder Teilen es über einem Speicherort im Netzwerk freigegeben werden.

Beim Öffnen eines Enterprise-Projekts aus Project Server sind die Einstellungen der Enterprise-global-Projektvorlage auf das Projekt angewendet. Nachdem die Enterprise-global-Projektvorlage auf das Projekt angewendet wurde, werden alle Elemente in der lokalen Globaldatei, die nicht denselben Namen wie die Elemente in der Enterprise-global-Projektvorlage verfügen auch auf die Projektdatei angewendet. Wenn Sie erstellt eine benutzerdefinierte Ansicht, eine Tabelle oder ein Filter, der den gleichen Namen wie ein Element in der Enterprise-global-Projektvorlage hat, müssen Sie umbenennen oder das benutzerdefinierte Element überschrieben wird.Die Fehlermeldung, die Sie erhalten ähnelt der folgenden Fehler:

"Enterprise-Global enthält bereits ein (ein Objekt wie z. B. eine Ansicht, Tabelle, Kalender usw.) mit dem Namen"<ObjectName>". Umbenennen oder ersetzen."

Benennen Sie das Objekt wird, beheben Sie das Problem und ermöglichen es Ihnen, auch weiterhin den Plan öffnen. Eine zweite Version des Objekts wird auch beibehalten, falls erforderlich.

Die Enterprise-global-Projektvorlage hat in der Regel Vorrang vor anderen Vorlagen. Jedoch ist die Rangfolge der Bänder, Symbolleisten und Menüs von anderen Elementen in der Enterprise-global-Projektvorlage anders behandelt. Bänder, Symbolleisten und Menüs in der Globaldatei lokalen Vorrang gegenüber Bändern, Symbolleisten und Menüs, die den gleichen Namen in der Enterprise-global-Projektvorlage haben. Darüber hinaus Vorrang unterschiedlichen Sprachversionen von Bändern, Symbolleisten und Menüs in der Globaldatei lokaler Bänder, Symbolleisten und Menüelementen in der Enterprise-global-Projektvorlage. Eine benutzerdefinierte Multifunktionsleiste oder Symbolleiste, das einen eindeutigen Namen, in die Datei der Enterprise-global-Projektvorlage in Project Server hat werden jedoch für alle Benutzer des Projekts verfügbar.

Die allgemeinen Schritte zum Tomove angepasst Objekte aus einem lokalen Plan in lokalen Globaldatei sind Recht direkt:</ObjectName>
  1. Erstellen Sie das benutzerdefinierte Objekt in Ihrem lokalen Plan.
  2. Öffnen Sie den Organizer zeigt die Objekte in die lokale globale Vorlage und den Plan nebeneinander.
  3. Verschieben Sie das benutzerdefinierte Objekt mit Vorlage aus dem Plan, und Sie sind fertig.

Diese Schritte funktionieren für alle Versionen des Projekts bis 2010.

Allerdings möchten Sie benutzerdefinierte Objekte der Enterprise-Global-Projektvorlage hinzufügen (da Sie Project Server verwenden) kann die Enterprise-Global nur von einem Benutzer mit Berechtigungen zum Öffnen der Enterprise-Global-Projektvorlage aus Project Server-Einstellungen zugegriffen werden. Diese Aktion startet PRoject Professional mit globalen Enterprise-Vorlage im Arbeitsspeicher geöffnet.Sie Canmove Objectsfrom vorführen Global oder einen Projektplan, um die geöffneten Enterprise-Global-Projektvorlage öffnen

Wenn Sie eine benutzerdefinierte Multifunktionsleisten-Registerkarte enthalten, das eine Befehlsschaltfläche zum Ausführen eines Makros in der Datei der Enterprise-global-Projektvorlage in Project 2010 hat, gehen Sie folgendermaßen vor:

Schritte zum benutzerdefinierten Makros erstellt

  1. Projekt-Client zu starten.
  2. Starten Sie ein neues Projekt. Es handelt sich um Name istProject1.
  3. Klicken Sie auf der Registerkarte Ansicht auf die Dropdownliste für Makros , und klicken Sie dann auf Makros.
  4. Geben Sie im Feld Makroname einen Namen ein. Makro1 ist z. B. die Standardeinstellung.
  5. Klicken Sie in der Liste Speichern in auf Globaldatei. Bei Auswahl Dieses Projekts ist das Makro nur in Project 1verfügbar.
  6. Klicken Sie auf die anderen gewünschten Optionen, und klicken Sie dann auf OK.

Schritte, um das Modul zu kopieren, das das Makro hinzu-global-Projektvorlage enthält ggf.

  1. Auf der Seite Informationen über die Registerkarte Schaltfläche klicken Sie aufdie OrgaNizer ot links vom Organisieren-Global-Projektvorlage.

    Hinweis: der Name der aktuell geöffneten Dateien erscheinen am oberen Rand jedes Fensters. Sie können die Datei in einer anderen geöffneten Datei mithilfe den Dropdownlisten am unteren Rand jedes Fensters ändern.
  2. Klicken Sie auf der Registerkarte Module
  3. In dem das Modul, das in den oben aufgeführten Schritten erstellte Makro enthält, markieren Sie es.
  4. Zwischen den Bereichen klicken Sie auf Kopieren, und klicken Sie dann auf Schließen.

Die globale wird wird automatisch gespeichert. Das Moduel und das Makro wird sind jetzt alle Pläne, mit denen diese lokale globale Vorlage verfügbar sein.

Schritte, um das Modul in 2007 oder 2010 in der Enterprise-global-Projektvorlage kopieren.

  1. Starten Sie Project Web Access als ein Benutzer mit Berechtigungen ot der Enterprise-Global-Artikelvorlage ändern...
  2. Klicken Sie auf Servereinstellungen > Enterprise-Global und Clikc die Schaltfläche Konfigurieren Sie Project Professional. Project Professional wird mit der Enterprise-Global-Projektvorlage im Arbeitsspeicher gestartet.
  3. Klicken Sie auf die Registerkarte Datei , wählen Sie Info und Globale Vorlage verwalten.
  4. Öffnen Sie den Plan, auf dem das Makro gespeichert wird wenn nicht bereits in der Global (+ nicht zwischengespeicherte Enterprise).
  5. Klicken Sie auf der Registerkarte ' Modul ', und wählen Sie dann das Modul, das Sie in der globalen Enterprise-Vorlage kopieren wollen.
  6. Zwischen den Bereichen klicken Sie auf Kopieren, und klicken Sie dann auf Schließen.
  7. Klicken Sie auf der Registerkarte Task, und klicken Sie dann auf Speichern, um die Enterprise-global-Projektvorlage zu speichern.
  8. Beenden Sie Project Professional.

Das nächste Mal, das ein Benutzer alle Enterprise support-Plan öffnen, wird das Makro verfügbar sein.

Schritte zum Erstellen einer benutzerdefinierten Symbolleiste, und fügen Sie das Makro einer Schaltfläche in 2007 und früheren Versionen.

  1. Starten Sie th Project-Clients.
  2. Klicken Sie im Menü Extras auf Anpassen, und klicken Sie dann auf Symbolleisten.
  3. Klicken Sie auf der Registerkarte Symbolleisten klicken Sie auf neu, und geben Sie einen Namen im Feld Name der Symbolleiste . Geben Sie zum Beispiel CustToolbar1, und klicken Sie dann auf OK.
  4. Klicken Sie auf die Registerkarte Befehle .
  5. Klicken Sie in der Liste Kategorien auf Alle Makros.
  6. Ziehen Sie dieMakro1Befehl aus der Liste Befehle auf die Symbolleiste.
  7. Klicken Sie auf der Symbolleiste auf neu hinzugefügte Makros.
  8. Klicken Sie im Dialogfeld Anpassen auf Auswahl ändern.
  9. Klicken Sie auf Schaltflächensymbol bearbeiten oder Schaltflächensymbol ändern, und dann nehmen Sie die erforderlichen Änderungen vor.
  10. Klicken Sie auf Schließen.
  11. Öffnen Sie die Enterprise-global-Projektvorlage oder die Symbolleiste in die lokale globale Vorlagendatei gespeichert wird.
  12. Die neu hinzugefügten Button-Steuerelement klicken Sie auf Auswahl ändern, und klicken Sie dann auf Makro zuweisen.
  13. Stellen Sie sicher, dass das Makro, das Sie erstellt im Feld Befehl angezeigt wird. Dieses Makro muss ein Makro dateispezifische nicht.
  14. Klicken Sie auf Schließen.
  15. Projekt-Client beenden.

Eigenschaften

Artikel-ID: 913678 - Geändert am: Freitag, 27. Dezember 2013 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Project Server 2013
  • Microsoft Project 2013 Professional
  • Microsoft Project Server 2010
  • Microsoft Project Professional 2010
  • Microsoft Office Project Server 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Server 2003
  • Microsoft Office Project Professional 2003
  • Microsoft Project Server 2002
  • Microsoft Project 2002 Professional Edition
Keywords: 
kbhowto kbmt KB913678 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell übersetzt und wird dann möglicherweise mithilfe des Community Translation Framework (CTF) von Mitgliedern unserer Microsoft Community nachbearbeitet. Weitere Informationen zu CTF finden Sie unter http://support.microsoft.com/gp/machine-translation-corrections/de.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 913678
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com