Article ID: 913957 - Last Review: October 11, 2007 - Revision: 2.6

FIX: A 0x6be exception may occur when you quickly make multiple remote procedure calls to a server that is running Windows Server 2003

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

Consider the following scenario. You quickly make multiple remote procedure calls (RPCs) to a server that is running Microsoft Windows Server 2003. The multiple RPCs are on the same endpoint. In this scenario, a 0x6be exception may occur.

CAUSE

This problem occurs because an RPC can reuse a TCP connection that the server has already asked to close. When the RPC does this, the server responds by using an ACK/RST packet. Additionally, the server causes the 0x6be exception to occur on the client computer.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 32-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.2.3790.2684645,63218-Apr-200603:19x86
W03a2409.dll5.2.3790.268424,57618-Apr-200601:38x86
Windows Server 2003 64-bit version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.2.3790.26841,720,83218-Apr-200603:12x64
W03a2409.dll5.2.3790.268425,08818-Apr-200603:12x64
Windows Server 2003 Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.2.3790.26842,470,91218-Apr-200603:12IA-64
W03a2409.dll5.2.3790.268423,55218-Apr-200603:12IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbwinserv2003presp2fix kbfix kbbug kbhotfixserver kbqfe kbpubtypekc KB913957
 

Article Translations

 

Related Support Centers