Article ID: 913964 - Last Review: November 24, 2010 - Revision: 4.0

Windows Live OneCare Firewall does not prompt you to keep blocking programs or to allow programs

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Windows Live OneCare is no longer available for sale

Existing subscribers will continue to be supported throughout the term of their subscriptions. Existing subscribers can reinstall by following the steps to download a trial (http://onecare.live.com/standard/en-us/install/install.htm) , and can still add a PC to their existing OneCare circle (http://onecare.live.com/standard/en-us/install/addcomputerinstall.htm) .

Learn more about end of sale for OneCare (http://onecare.live.com/standard/en-us/activation/oc_eol_guidance.htm) .

On September 29th 2009, Microsoft introduced Microsoft Security Essentials, a FREE consumer anti-malware solution for Genuine Windows based PCs.

Learn more about Microsoft Security Essentials (http://onecare.live.com/standard/en-us/default.htm) or download from Microsoft directly at: http://www.microsoft.com/security_essentials/default.aspx (http://onecare.live.com/standard/en-us/default.htm) .



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SYMPTOMS

You may notice that programs are blocked automatically by the Windows Live OneCare Firewall. You do not receive any prompts to keep blocking programs or to allow programs through the Windows Live OneCare Firewall.

CAUSE

This problem may occur if you install the programs on dynamic disks.

RESOLUTION

To resolve this problem, add the programs to the list of allowed programs in the Windows Live OneCare Firewall
  1. Start Windows Live OneCare Live.
  2. On the left side of the display, click View or change settings.
  3. Click the Firewall tab, and then click Advanced Settings.
  4. Click the Programs List tab.
  5. Click Add.
  6. Find to the .exe file for the program that you want to allow through the firewall, and then click Open.
  7. Repeat steps 5 through 6 for each program that you want to allow through the firewall.

WORKAROUND

Alternatively, you can resolve the problem by converting the dynamic disk back to a basic disk. To convert the disk, use the Dskprob.exe tool.

Important If you do not use the Dskprob.exe tool correctly, this process may cause you to lose of all data the on the disk. This process works only if you have not used any one of the new features of dynamic disks. These features include extending a partition or using software redundant array of independent disks (RAID).
  1. Download and install the Windows Support Tools for Microsoft Windows XP. To do this, visit the following Web site:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=49AE8576-9BB9-4126-9761-BA8011FABF38&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyId=49AE8576-9BB9-4126-9761-BA8011FABF38&displaylang=en)
    Note When you install these tools, click Complete when you are prompted to click Typical or Complete. If you click Typical, you will have to reinstall the tools. When you reinstall the tools, click Optional when you are prompted.
  2. Click Start, click Run, type Dskprobe.exe, and then click OK.
  3. On the Drives menu, click Physical Drive.
  4. In the Available Physical Drives box, double-click the drive you want to change.
  5. Click Set Active, and then click OK.
  6. On the Sectors menu, click Read.
  7. Click Read to accept the default settings.
  8. In the editor, find the 01C0 line. In this line, the third pair of numbers on the right is 42. Change 42 to 07.

    Note On some computers, 42 may appear on the 01D0 line.
  9. On the Sectors menu, click Write.
  10. When you receive a message that is similar to the following, click Yes:
    The current handle is in Read Only mode. Do you wish to change the current mode to allow writing the selected buffer to disk?
  11. Click Write it.
  12. When you receive a message that is similar to the following, click Yes:
    Are you sure you want to permanently overwrite the data in sector 0 on the device PhysicalDrive 0
  13. Exit the Disk Prob program, and then restart the computer.
  14. After the computer restarts, click Start, click Run, type cmd, and then click OK.
  15. On the command line, type chkdsk to scan for errors.
  16. If any errors are found, type chkdsk /f on the command line to fix these errors.

MORE INFORMATION

Currently, the Windows Live OneCare Firewall is incompatible with dynamic disks. If you install programs on dynamic disks, the Windows Live OneCare Firewall will not allow these programs to access the network.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.
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Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.