Vous pouvez recevoir des messages d'erreur si vous désactiver NetBIOS sur un cluster Windows Server 2003

Traductions disponibles Traductions disponibles
Numéro d'article: 914056 - Voir les produits auxquels s'applique cet article
important Cet article contient des informations sur la modification du Registre. Veillez à sauvegarder le Registre avant de le modifier. Vérifiez que vous connaissez comment restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Description du Registre Microsoft Windows
Agrandir tout | Réduire tout

Sommaire

Symptômes

Vous désactiver NetBIOS et continuer à utiliser Microsoft Cluster Service (MSCS) sur un cluster de Windows Server 2003. Vous trouverez que la configuration permet les adresses IP et les ressources de nom de réseau à accéder à chaque n?ud. Cependant, la configuration ne permet pas pour les connexions aux noms de domaine complets (FQDN). En outre, vous pouvez rencontrer un ou les deux symptômes suivants :
  • Vous recevez un message d'erreur pop-up semblable à celui-ci :
    \\ <fqdn>
    Vous n'étaient pas connecté car un nom en double existe sur le réseau. Accédez au système du Panneau de configuration pour modifiez la nom de l'ordinateur et réessayez.
  • Vous trouverez qu'une trace du Moniteur réseau capture une erreur « STATUS_DUPLICATE_NAME » qui est cohérente avec la message d'erreur pop-up. Toutefois, aucun message d'erreur n'est enregistré dans le journal des événements système pour indiquer qu'il existe un nom en double sur le réseau.

Cause

Ce problème se produit parce que l'emplacement de service (SRV) service sur le serveur conserve une liste ServerEndPoint. Toutefois, le NetBIOS nom figure dans la liste. Par conséquent, le service SRV ne peut pas trouver le NetBIOS nom et envoie un message d'erreur à l'ordinateur client.

Résolution

Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.

Pour résoudre ce problème, vous devez modifier le Registre, assurez-vous que les paramètres de la carte réseau public sont corrects, s'assurer que les connexions utilisent des adresses IP ou FQDN.

Modifier le Registre

Ajoutez l'entrée de Registre DisableStrictNameChecking à chaque noeud du cluster si il n'existe pas. Pour ce faire, procédez comme suit :
  1. Démarrez l'Éditeur du Registre.
  2. Recherchez la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\lanmanserver\parameters
  3. Dans le menu Edition , cliquez sur Ajouter valeur , puis ajoutez les opérations suivantes :
    Réduire ce tableauAgrandir ce tableau
    Nom de valeurType de donnéesValeur
    DisableStrictNameCheckingREG_DWORD1
  4. Quittez l'Éditeur du Registre et redémarrez l'ordinateur.

Examinez les paramètres de la carte réseau public

  • N'oubliez pas cliquer sur Activez la case à cocher Enregistrer les adresses de cette connexion dans DNS pour la carte réseau public.
  • Assurez-vous que les adresses des serveurs DNS apparaissent sur la page Propriétés du protocole Internet (TCP/IP) de la carte réseau public. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
    825036 Meilleures pratiques pour DNS client paramètres dans Windows 2000 Server et Windows Server 2003

Vérifiez les connexions pour les adresses IP ou complets

S'assurer que les connexions de carte réseau public utilisent des adresses IP ou FQDN.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations, reportez-vous au site Web de Microsoft TechNet suivant :
http://technet2.microsoft.com/WindowsServer/en/Library/7b1c90d1-877e-4c55-ab8c-9c65101a503d1033.mspx

Propriétés

Numéro d'article: 914056 - Dernière mise à jour: mardi 27 novembre 2007 - Version: 1.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Mots-clés : 
kbmt kbtshoot kbprb KB914056 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 914056
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com