Error message when you try to install Windows Media Player 10 on a Windows XP Service Pack 2-based computer: "This version of Windows Media Technologies is incompatible with this version of Windows"

Article translations Article translations
Article ID: 914223
Expand all | Collapse all

Symptoms

When you try to install Microsoft Windows Media Player 10 on a Microsoft Windows XP Service Pack 2-based computer, you may receive an error message that is similar to the following:
This version of Windows Media Technologies is incompatible with this version of Windows. For more information, view the information at the Microsoft web site.

Cause

This error occurs because the Windows Media Player 10 installer may cause data loss if it is installed to that system.

Resolution

If the Windows Media Format 11 runtime is listed in Add or Remove Programs in Control Panel, this behavior is by design. You must first uninstall the Windows Media Format 11 runtime before you can install Windows Media Player 10. If you do not have the Windows Media Format 11 runtime present on the system, follow these steps to resolve this issue:
  1. Click Start, click Run, type explorer, and then click OK.
  2. Locate the Wmploc.dll file in the %systemroot%\ServicePackFiles\i386 folder, and then copy it to the %systemroot%\System32 folder.

    Note The %systemroot% folder is the folder where you installed Microsoft Windows. Also, the %systemroot%\ServicePackFiles folder may not be present on the computer. In this case, you must manually search for the Wmploc.dll file on the computer, and then copy it to the %systemroot%\System32 folder. To do this, follow these steps:
    1. Click Start, and then click Search.
    2. Click All files and folders, and then type Wmploc.dll in the All or part of the file name box.
    3. In the Look in list, click My Computer, and then click Search.
    4. Locate the Wmploc.dll file in the list of files that are found, and then copy it to the %systemroot%\System32 folder.
  3. Install Windows Media Player 10.

Properties

Article ID: 914223 - Last Review: June 20, 2014 - Revision: 4.0
Keywords: 
kbtshoot KB914223

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com