Die CoCreateInstance-Funktion kann auf einem Computer mit Windows XP Professional Service Pack 2 oder Windows Server 2003 einen HRESULT-Fehler zurückgeben.

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Problembeschreibung

Die CoCreateInstance -Funktion kann einen HRESULT-Fehler zurückgeben, auf einem Microsoft Windows XP Professional Service Pack 2 (SP2)-basierten oder Microsoft Windows Server 2003-Computer. CoCreateInstance -Funktion kann einen der folgende HRESULT-Werte zurückgeben:
  • E_HANDLE
  • E_NOINTERFACE
  • E_ACCESSDENIED

Ursache

Dieses Problem kann auftreten, wenn remote Procedure (RPC) Kommunikation Thread, die Aufrufen für verwendet DCOM prozessübergreifende Kommunikation auf dem Computer vorzeitig beendet wird.

Dieses Problem kann z. B. im folgenden Szenario auftreten:
  • Ein DCOM-Client-Thread hat einen ausstehenden Aufruf von DCOM-Server.
  • Der Clientprozess wird geschlossen, bevor die Threads ordnungsgemäß bereinigen und CoUninitialize -Funktion aufrufen können.
In diesem Szenario unabhängige anderen DCOM-Prozess vorzeitig beendet und nicht ordnungsgemäß durch den RPC-Dienst bereinigt werden kann. Daher auftreten E_HANDLE, E_NOINTERFACE oder E_ACCESSDENIED Fehler, in die Aufrufe, die dann versuchen, den DCOM-Prozess verwenden. Wenn diese Fehler auftreten, kann der DCOM-Server weiterhin ausgeführt, auf dem Computer. Allerdings ist der DCOM-Server von anderen Prozessen DCOM nicht zugegriffen werden.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Windows XP Professional SP2-Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Keine.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen früheren Hotfix nicht.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Rpcrt4.dll5.1.2600.2859582,14402-Mär-200603: 55X 86

Windows Server 2003 Hotfix-Informationen

Voraussetzungen

Keine.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen früheren Hotfix nicht.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.

Windows Server 2003, 32-Bit-Versionen

Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Ole32.dll5.2.3790.3741,193,98421-Jul-200503: 12X 86KeinerRTMQFE
Rpcproxy.dll5.2.3790.14126,11216-Mär-200403: 17X 86KeinerRTMQFE
Rpcrt4.dll5.2.3790.521589,82419-Apr-200609: 48X 86KeinerRTMQFE
RPCSS.dll5.2.3790.374296,96021-Jul-200503: 12X 86KeinerRTMQFE
Rpcrt4.dll5.2.3790.2685645,63219-Apr-200610: 22X 86SP1SP1QFE

Windows Server 2003, Itanium-basierte Versionen

Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Ole32.dll5.2.3790.3743,582,97619-Apr-200610: 58IA-64KeinerRTMQFE
Rpcproxy.dll5.2.3790.14173.21619-Apr-200610: 58IA-64KeinerRTMQFE
Rpcrt4.dll5.2.3790.5212,151,42419-Apr-200610: 58IA-64KeinerRTMQFE
RPCSS.dll5.2.3790.374694,27219-Apr-200610: 58IA-64KeinerRTMQFE
Wole32.dll5.2.3790.3741,193,98419-Apr-200610: 58X 86KeinerWOW
Wrpcproxy.dll5.2.3790.14126,11219-Apr-200610: 58X 86KeinerWOW
Wrpcrt4.dll5.2.3790.521544,76819-Apr-200610: 58X 86KeinerWOW
Rpcrt4.dll5.2.3790.26852,470,91219-Apr-200611: 06IA-64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2685628,73619-Apr-200611: 06X 86SP1WOW

Windows Server 2003 x 64-basierte Versionen

Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Rpcrt4.dll5.2.3790.26851,720,83219-Apr-200611: 09X 64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2685628,73619-Apr-200611: 09X 86SP1WOW

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Dieses Problem wurde erstmals in Windows Server 2003 Service Pack 2.

Weitere Informationen

Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 914301 - Geändert am: Mittwoch, 29. August 2007 - Version: 3.3
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Service Pack 2, wenn verwendet mit:
    • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbmt kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbwinserv2003presp2fix kbwinxppresp3fix kbfix kbbug kbpubtypekc KB914301 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 914301
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