La función CoCreateInstance puede devolver un error HRESULT en un equipo Windows XP Professional Service Pack 2 o Windows Server 2003

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Síntomas

La función CoCreateInstance puede devolver un error HRESULT en un Microsoft Windows XP Professional Service Pack 2 (SP2)-equipo basado en Microsoft Windows Server 2003 o en función. La función CoCreateInstance puede devolver uno de los valores HRESULT siguientes:
  • E_HANDLE
  • E_NOINTERFACE
  • E_ACCESSDENIED

Causa

Este problema puede producirse si el subproceso de comunicación (RPC) que se utiliza para la llamada a un procedimiento remoto comunicación entre procesos DCOM finaliza prematuramente en el equipo.

Por ejemplo, este problema puede producirse en el siguiente escenario:
  • Un subproceso de cliente DCOM tiene una llamada pendiente a un servidor DCOM.
  • El proceso de cliente se cierra antes los subprocesos pueden limpiar y llamar a la función CoUninitialize correctamente.
En este escenario, otro no relacionados de proceso DCOM puede prematuramente y incorrectamente limpiarse por el servicio llamada a procedimiento remoto. Por lo tanto, se producen errores E_HANDLE, E_NOINTERFACE o E_ACCESSDENIED en las llamadas que intente utilizar ese proceso DCOM. Cuando se producen estos errores, el servidor DCOM puede continuar ejecutándose en el equipo. Sin embargo, el servidor DCOM es ahora accesible por otros procesos DCOM.

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Server 2003. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información de la revisión Service Pack 2 de Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No hay ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye cualquier revisión anterior.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Rpcrt4.dll5.1.2600.2859582,14402-Mar-200603: 55x 86

Información sobre hotfix de Windows Server 2003

Requisitos previos

No hay ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye cualquier revisión anterior.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.

Versiones de 32 bits de Windows Server 2003

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ole32.dll5.2.3790.3741,193,98421-Jul-200512: 03x 86NingunoRTMQFE
Rpcproxy.dll5.2.3790.14126,11216-Mar-200403: 17x 86NingunoRTMQFE
Rpcrt4.dll5.2.3790.521589,82419 De abril de 200609: 48x 86NingunoRTMQFE
Rpcss.dll5.2.3790.374296,96021-Jul-200512: 03x 86NingunoRTMQFE
Rpcrt4.dll5.2.3790.2685645,63219 De abril de 200610: 22x 86SP1SP1QFE

Windows Server 2003, versiones basadas en Itanium

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ole32.dll5.2.3790.3743,582,97619 De abril de 200610: 58IA-64NingunoRTMQFE
Rpcproxy.dll5.2.3790.14173.21619 De abril de 200610: 58IA-64NingunoRTMQFE
Rpcrt4.dll5.2.3790.5212,151,42419 De abril de 200610: 58IA-64NingunoRTMQFE
Rpcss.dll5.2.3790.374694,27219 De abril de 200610: 58IA-64NingunoRTMQFE
Wole32.dll5.2.3790.3741,193,98419 De abril de 200610: 58x 86NingunoGUAU
Wrpcproxy.dll5.2.3790.14126,11219 De abril de 200610: 58x 86NingunoGUAU
Wrpcrt4.dll5.2.3790.521544,76819 De abril de 200610: 58x 86NingunoGUAU
Rpcrt4.dll5.2.3790.26852,470,91219 De abril de 200611: 06IA-64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2685628,73619 De abril de 200611: 06x 86SP1GUAU

Windows Server 2003, versiones basadas en 64 x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Rpcrt4.dll5.2.3790.26851,720,83219 De abril de 200609: 11x 64SP1SP1QFE
Wrpcrt4.dll5.2.3790.2685628,73619 De abril de 200609: 11x 86SP1GUAU

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Este problema se corrigió por primera vez en Windows Server 2003 Service Pack 2.

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 914301 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 3.3
La información de este artículo se refiere a:
  • Microsoft Windows XP Service Pack 2 sobre las siguientes plataformas
    • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Palabras clave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbwinserv2003presp2fix kbwinxppresp3fix kbfix kbbug kbpubtypekc KB914301 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 914301

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