FIX: The database status changes to Suspect when you perform a bulk copy in a transaction and then roll back the transaction in SQL Server 2000

Article translations Article translations
Article ID: 914384 - View products that this article applies to.
Microsoft distributes Microsoft SQL Server 2000 fixes as one downloadable file. Because the fixes are cumulative, each new release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2000 fix release.
Expand all | Collapse all

On This Page

SUMMARY

This article describes the following about this hotfix release:
  • The issues that are fixed by this hotfix package
  • The prerequisites for installing the hotfix package
  • Whether you must restart the computer after you install the hotfix package
  • Whether you must make any registry changes
  • The files that are contained in the hotfix package

SYMPTOMS

Consider the following scenario. You perform a bulk copy in a transaction in SQL Server 2000. In the same transaction, you insert data in the same table. When you try to roll back the transaction, you may receive the following error message:
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionCheckForData (CheckforData()).
Server: Msg 11, Level 16, State 1, Line 0
General network error. Check your network documentation. Connection Broken
Additionally, the status of the database is set to Suspect. Error messages that resemble the following are logged in the SQL Server ErrorLog file:
2006-02-02 11:08:19.71 spid14 Stack Signature for the dump is 0xFCDEDADE
2006-02-02 11:08:19.74 spid14 SQL Server Assertion: File: <logscan.cpp>, line=3399 Failed Assertion = 'm_lastLSN == NullLSN || startLSN < m_lastLSN'.
2006-02-02 11:08:19.74 spid14 Location: logscan.cpp:3399 Expression: m_lastLSN == NullLSN || startLSN < m_lastLSN SPID: 14 Process ID: 7252
2006-02-02 11:08:19.74 spid14 Error: 9004, Severity: 23, State: 7
2006-02-02 11:08:19.74 spid14 An error occurred while processing the log for database 'testdb'..
2006-02-02 11:08:19.76 spid14 Error: 3414, Severity: 21, State: 1
2006-02-02 11:08:19.76 spid14 Database 'testdb' (database ID 17) could not recover. Contact Technical Support..
For a list of all publicly released SQL Server 2000 Service Pack 4 hotfixes, see the following article in the Microsoft Knowledge Base:
894905 Cumulative list of the hotfixes that are available for SQL Server 2000 SP4

CAUSE

This problem occurs because SQL Server 2000 cannot roll back a transaction when both logged changes and non-logged changes have been made on the splitting pages.

RESOLUTION

The installer does not install this hotfix correctly on x64-based systems. This installation issue occurs when the following conditions are true:
  • The system uses the Advanced Micro Devices (AMD) AMD64 processor architecture or the Intel Extended Memory 64 Technology (EM64T) processor architecture.

    Note This issue does not occur on systems that use the Intel Itanium processor architecture.
  • The system is running a 64-bit version of the Microsoft Windows Server operating system.
  • The system is running a 32-bit version of SQL Server 2000.
We have corrected this installation issue in later builds of SQL Server 2000, starting with version 8.00.2244. When a customer who is running SQL Server 2000 on an x64-based system requests this hotfix, we will provide a build that includes this hotfix and that can be installed correctly on an x64-based system. The build that we provide will be version 8.00.2244 or a later version.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft SQL Server 2000 Service Pack 4 (SP4) installed before you can install this hotfix.

For more information about how to obtain SQL Server 2000 Service Pack 4, click the following article number to view the article in the Microsoft Knowledge Base:
290211 How to obtain the latest SQL Server 2000 service pack

Restart requirement

You do not have to restart the computer.

Registry information

You do not have to change the registry.

Hotfix file information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain of all the files that you must have to fully update a product to the latest build.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dtsui.dll2000.80.2187.01,593,34409-Mar-200604:47x86
Impprov.dll2000.80.2187.0102,40009-Mar-200604:47x86
Msgprox.dll2000.80.2187.094,20809-Mar-200604:47x86
Msrpjt40.dll4.10.9424.0188,47323-Jan-200616:13x86
Mssdi98.dll8.11.50523.0239,10406-Jun-200506:46x86
Ntwdblib.dll2000.80.2187.0290,81609-Mar-200604:47x86
Odsole70.dll2000.80.2187.069,63209-Mar-200604:47x86
Osql.exe2000.80.2187.057,34409-Mar-200602:37x86
Pfclnt80.dll2000.80.2187.0430,08009-Mar-200604:47x86
Replmerg.exe2000.80.2187.0163,84009-Mar-200602:46x86
Replprov.dll2000.80.2187.0237,56809-Mar-200604:47x86
Replrec.dll2000.80.2187.0315,39209-Mar-200604:47x86
Replsub.dll2000.80.2187.0270,33609-Mar-200604:47x86
Semexec.dll2000.80.2187.0856,06409-Mar-200604:47x86
Sqlagent.exe2000.80.2187.0323,58409-Mar-200602:26x86
Sqldiag.exe2000.80.2187.0118,78409-Mar-200603:22x86
Sqldmo.dll2000.80.2187.04,362,24009-Mar-200604:47x86
Sqlevn70.rll2000.80.2187.045,05609-Mar-200604:47Not Applicable
Sqlfth75.dll2000.80.2187.0102,40009-Mar-200602:35x86
Sqlservr.exe2000.80.2187.09,162,75209-Mar-200604:45x86
Sqlsort.dll2000.80.2187.0589,82409-Mar-200604:47x86
Stardds.dll2000.80.2187.0176,12809-Mar-200604:47x86
Svrnetcn.dll2000.80.2187.0110,59209-Mar-200604:47x86
Ums.dll2000.80.2187.035,32809-Mar-200604:47x86

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 914384 - Last Review: October 9, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft SQL Server 2000 Standard Edition
  • Microsoft SQL Server 2000 Developer Edition
  • Microsoft SQL Server 2000 Enterprise Edition
  • Microsoft SQL Server 2000 Personal Edition
  • Microsoft SQL Server 2000 Workgroup Edition
Keywords: 
kbautohotfix kbfix kbexpertiseadvanced kbHotfixServer kbqfe KB914384

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com