Webanwendungen, die aufgeteilte Codierung reagieren Stop, wenn Sie diese von Windows Server 2003 oder von einem Windows XP-basierten Computer zugreifen

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wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Sollten Sie die Registrierung sichern, bevor Sie Sie ändern. Stellen Sie sicher, dass Sie die Registrierung wiederherstellen kennen, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986Beschreibung der Microsoft Windows-Registrierung
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Problembeschreibung

Sie Webanwendungen zugreifen oder Websites aus einer Server, verwendet aufgeteilter, Internet übertragen Codierung auf Microsoft Windows Server 2003 oder auf einem Windows XP-Computer. Anschließend reagiert der Browser oder die Webanwendungen.

Ursache

Dieses Problem tritt auf, wenn die Datei "Wininet.dll" eine unvollständige Chunk erhält Daten empfangen von Daten während der anfänglichen Winsock-Vorgang. Wenn dieses Verhalten auftritt, erhalten die zweiten Winsock-Daten Vorgang liest nur ein Fragment-Token. Beispielsweise erhalten die zweiten Winsock-Daten Vorgang kann nur gelesen Wagenrücklauf Zeilenvorschub (CRLF) vom Socket. Datei "Wininet.dll" führt dann fortlaufend Aufrufe an die Funktion Winsock: Auswahl für 30 Sekunden. Die Datei wartet weitere Daten zu empfangen. Wenn keine Daten ankommen, reagiert jedoch Browser oder in der Webanwendung.

Lösung

Windows Server 2003

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Es gelten keine Voraussetzungen.
Neustartanforderung
Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformService Pack-AnforderungServicebereich
Wininet.dll6.0.3790.495628,73602-Mär-200619: 15X 86KeinerRTMQFE
Wininet.dll6.0.3790.2651665,08802-Mär-200619: 24X 86SP1SP1QFE
Nachdem Sie den Hotfix installiert haben, müssen Sie die Registrierung, um den Hotfix zu aktivieren, ändern. Gehen Sie hierzu folgendermaßen vor: Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine Ihr Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. So aktivieren diesen Hotfix pro Benutzer, suchen, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    So aktivieren diesen Hotfix pro Computer, suchen, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Klicken Sie auf den Registrierungsunterschlüssel, den Sie in Schritt 2 gefunden.
  4. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  5. Geben Sie FEATURE_CHUNK_TIMEOUT_KB914453 , und drücken Sie anschließend die [EINGABETASTE].
  6. Klicken Sie auf den Registrierungsschlüssel, den Sie in Schritt 5 erstellt haben.
  7. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  8. Geben Sie Einstellungen , und drücken Sie anschließend die [EINGABETASTE].
  9. Klicken Sie auf FEATURE_CHUNK_TIMEOUT_KB914453 .
  10. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  11. Geben Sie Iexplore.exe , und drücken Sie anschließend die [EINGABETASTE].
  12. Klicken Sie im Menü Bearbeiten auf Ändern .
  13. Geben Sie in das Feld Wertdaten 1 ein, und klicken Sie dann auf OK .

    Hinweis: Die gültigen Werte für den Unterschlüssel sind 0 und 1. Der Wert 1 aktiviert den Hotfix und der Wert 0 deaktiviert den Hotfix.
  14. Klicken Sie auf FEATURE_CHUNK_TIMEOUT_KB914453 .
  15. Klicken Sie auf Einstellungen .
  16. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  17. Geben Sie ChunkSelectTimeout , und drücken Sie anschließend die [EINGABETASTE].
  18. Klicken Sie im Menü Bearbeiten auf Ändern .
  19. Geben Sie in das Feld Wert FFFFFFFF und klicken Sie dann auf OK .

    Hinweis: Die gültigen Werte für den Unterschlüssel basieren auf einer Verzögerung. Der Wert FFFFFFFF aktiviert den Hotfix, und jeder andere Wert zeigt den Timeoutwert.
  20. Beenden Sie den Registrierungs-Editor.
Hinweis: Wenn Sie die Teilstruktur
HKEY_LOCAL_MACHINE
Registrierung aktualisieren, müssen Sie den Computer neu starten. Dann ab-Sie und Anmelden des Computers die Verhaltensänderungen anzuzeigen.

Windows XP

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Es gelten keine Voraussetzungen.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Wininet.dll6.0.2900.2859663,55201-Mär-200621: 16X 86
Nachdem Sie den Hotfix installiert haben, müssen Sie die Registrierung, um den Hotfix zu aktivieren, ändern. Gehen Sie hierzu folgendermaßen vor: Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine Ihr Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. So aktivieren diesen Hotfix pro Benutzer, suchen, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    So aktivieren diesen Hotfix pro Computer, suchen, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Klicken Sie auf den Registrierungsschlüssel in Schritt 2.
  4. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  5. Geben Sie FEATURE_CHUNK_TIMEOUT_KB914453 , und drücken Sie anschließend die [EINGABETASTE].
  6. Klicken Sie auf den Registrierungsschlüssel, den Sie in Schritt 5 erstellt haben.
  7. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  8. Geben Sie Einstellungen , und drücken Sie anschließend die [EINGABETASTE].
  9. Klicken Sie auf FEATURE_CHUNK_TIMEOUT_KB914453 .
  10. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  11. Geben Sie Iexplore.exe , und drücken Sie anschließend die [EINGABETASTE].
  12. Klicken Sie im Menü Bearbeiten auf Ändern .
  13. Geben Sie in das Feld Wertdaten 1 ein, und klicken Sie dann auf OK .

    Hinweis: Die gültigen Werte für den Unterschlüssel sind 0 und 1. Der Wert 1 aktiviert den Hotfix und der Wert 0 deaktiviert den Hotfix.
  14. Klicken Sie auf FEATURE_CHUNK_TIMEOUT_KB914453 .
  15. Klicken Sie auf Einstellungen .
  16. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  17. Geben Sie ChunkSelectTimeout , und drücken Sie anschließend die [EINGABETASTE].
  18. Klicken Sie im Menü Bearbeiten auf Ändern .
  19. Geben Sie in das Feld Wert FFFFFFFF und klicken Sie dann auf OK .

    Hinweis: Die gültigen Werte für den Unterschlüssel basieren auf einer Verzögerung. Der Wert FFFFFFFF aktiviert den Hotfix, und jeder andere Wert zeigt den Timeoutwert.
  20. Beenden Sie den Registrierungs-Editor.
Hinweis: Wenn Sie die Teilstruktur
HKEY_LOCAL_MACHINE
Registrierung aktualisieren, müssen Sie den Computer neu starten. Dann ab-Sie und Anmelden des Computers die Verhaltensänderungen anzuzeigen.

Abhilfe

Verwenden Sie eine der folgenden Optionen, um dieses Problem zu umgehen:
  • Deaktivieren Sie die aufgeteilte Codierung vom Server. Weitere Informationen, ob der Server aufgeteilte Codierung deaktivieren kann, und Weitere Informationen zum Deaktivieren der aufgeteilte Codierung finden Sie die Web-Server-Produktdokumentation.
  • Deaktivieren Sie die HTTP 1.1-Einstellungen in Microsoft Internet Explorer. Gehen Sie hierzu folgendermaßen vor:
    1. Schließen Sie alle aktiven Internet Explorer-Fenster.
    2. Starten Sie Internet Explorer.
    3. Klicken Sie im Menü Extras auf Internetoptionen .
    4. Klicken Sie im Dialogfeld Internetoptionen auf die Registerkarte Erweitert .
    5. Klicken Sie unter Einstellungen für HTTP 1.1 in der Liste Einstellungen auf das Kontrollkästchen HTTP 1.1 verwenden.
    6. Deaktivieren Sie unter Einstellungen für HTTP 1.1 das Kontrollkästchen HTTP 1.1 über Proxyverbindungen verwenden , und klicken Sie dann auf OK .

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Server 2003 Service Pack 2.

Weitere Informationen

Weitere Informationen zu Standardterminologie, die zur Beschreibung der Microsoft-Softwareupdates verwendet wird, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 914453 - Geändert am: Freitag, 1. Juni 2007 - Version: 3.4
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional
Keywords: 
kbmt kbautohotfix kbwinserv2003sp2fix kbwinserv2003presp2fix kbwinxppresp3fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB914453 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 914453
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