Applications Web qui utilisent chunked codage stop a répondre lorsque vous accéder dans un Windows Server 2003 ou d'un ordinateur Windows XP

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Numéro d'article: 914453 - Voir les produits auxquels s'applique cet article
important Cet article contient des informations sur la modification du Registre. Veillez à sauvegarder le Registre avant de le modifier. Vérifiez que vous connaissez comment restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Description du Registre Microsoft Windows
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Sommaire

Symptômes

Vous accéder aux applications Web ou sites Web à partir d'un site Web serveur qui utilise chunked transférer codage sur un Microsoft Windows Server 2003-basé ou sur un ordinateur Windows XP. Puis, le navigateur ou les applications Web cesser de répondre.

Cause

Ce problème se produit lorsque le fichier Wininet.dll reçoit un bloc incomplète de données au cours de Winsock initiale données recevoir opération. Lorsque ce problème se produit, les données de Winsock deuxième recevez opération lit uniquement un jeton de bloc. Par exemple, les données de Winsock deuxième recevoir opération peut uniquement lecture retour de chariot ligne-flux (CRLF) à partir du socket. Ensuite, le fichier Wininet.dll effectue des appels continus à la fonction Winsock Select pendant 30 secondes. Le fichier attend de recevoir plus de données. Toutefois, si aucune donnée n'arrive, le navigateur ou l'application Web cesse de répondre.

Résolution

Windows Server 2003

Informations sur le service pack

Pour résoudre ce problème, procurez-vous le dernier service pack pour Windows Server 2003. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
889100 Comment obtenir le dernier pack service pour Windows Server 2003

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.
Conditions préalables
Aucune condition préalable à l'installation ne sont nécessaires.
Demande de redémarrage
Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.
Informations sur le remplacement de correctif
Ce correctif ne remplace aucun autre correctif.
Informations de fichier
La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeService pack demandeSuccursale de service
Wininet.dll6.0.3790.495628,73602-Mar-200619:15x 86AucunRTMQFE
Wininet.dll6.0.3790.2651665,08802-Mar-200619:24x 86SERVICE PACK 1SP1QFE
Après avoir installé le correctif, vous devez modifier le Registre pour activer le correctif logiciel. Pour ce faire, procédez comme suit : Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
  2. Pour activer ce correctif logiciel par utilisateur, repérez et puis cliquez sur la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
    Pour activer ce correctif logiciel par ordinateur, repérez et puis cliquez sur la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Cliquez sur la sous-clé de Registre que vous avez localisée dans l'étape 2.
  4. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  5. Tapez FEATURE_CHUNK_TIMEOUT_KB914453 et puis appuyez sur ENTRÉE.
  6. Cliquez sur la clé de Registre que vous avez créé à l'étape 5.
  7. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  8. Tapez les paramètres et puis appuyez sur ENTRÉE.
  9. Cliquez sur FEATURE_CHUNK_TIMEOUT_KB914453 .
  10. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  11. Tapez iexplore.exe , puis appuyez sur ENTRÉE.
  12. Dans le menu Edition , cliquez sur Modifier .
  13. Dans la zone données de la valeur , tapez 1 et puis cliquez sur OK .

    note Les valeurs valides pour la sous-clé sont 0 et 1. La valeur 1 active le correctif et une valeur de 0 désactive le correctif.
  14. Cliquez sur FEATURE_CHUNK_TIMEOUT_KB914453 .
  15. Cliquez sur Paramètres .
  16. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  17. Tapez ChunkSelectTimeout et puis appuyez sur ENTRÉE.
  18. Dans le menu Edition , cliquez sur Modifier .
  19. Dans la zone données de la valeur , tapez FFFFFFFF et puis cliquez sur OK .

    note Les valeurs valides pour la sous-clé reposent sur un délai. Une valeur de FFFFFFFF permet le correctif et toute autre valeur indique la valeur du délai d'attente.
  20. Quittez l'Éditeur du Registre.
note Si vous mettez à jour la sous-arborescence de Registre
HKEY_LOCAL_MACHINE
, vous devez redémarrer l'ordinateur. Ensuite, vous devez déconnecter et ouvrir une session sur l'ordinateur pour voir les modifications de comportement.

Windows XP

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Aucune condition préalable à l'installation ne sont nécessaires.

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace aucun autre correctif.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Wininet.dll6.0.2900.2859663,55201-Mar-200621:16x 86
Après avoir installé le correctif, vous devez modifier le Registre pour activer le correctif logiciel. Pour ce faire, procédez comme suit : Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
  2. Pour activer ce correctif logiciel par utilisateur, repérez et puis cliquez sur la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
    Pour activer ce correctif logiciel par ordinateur, repérez et puis cliquez sur la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Cliquez sur la clé de Registre que vous avez localisée à l'étape 2.
  4. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  5. Tapez FEATURE_CHUNK_TIMEOUT_KB914453 et puis appuyez sur ENTRÉE.
  6. Cliquez sur la clé de Registre que vous avez créé à l'étape 5.
  7. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  8. Tapez les paramètres et puis appuyez sur ENTRÉE.
  9. Cliquez sur FEATURE_CHUNK_TIMEOUT_KB914453 .
  10. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  11. Tapez iexplore.exe , puis appuyez sur ENTRÉE.
  12. Dans le menu Edition , cliquez sur Modifier .
  13. Dans la zone données de la valeur , tapez 1 et puis cliquez sur OK .

    note Les valeurs valides pour la sous-clé sont 0 et 1. La valeur 1 active le correctif et une valeur de 0 désactive le correctif.
  14. Cliquez sur FEATURE_CHUNK_TIMEOUT_KB914453 .
  15. Cliquez sur Paramètres .
  16. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  17. Tapez ChunkSelectTimeout et puis appuyez sur ENTRÉE.
  18. Dans le menu Edition , cliquez sur Modifier .
  19. Dans la zone données de la valeur , tapez FFFFFFFF et puis cliquez sur OK .

    note Les valeurs valides pour la sous-clé reposent sur un délai. Une valeur de FFFFFFFF permet le correctif et toute autre valeur indique la valeur du délai d'attente.
  20. Quittez l'Éditeur du Registre.
note Si vous mettez à jour la sous-arborescence de Registre
HKEY_LOCAL_MACHINE
, vous devez redémarrer l'ordinateur. Ensuite, vous devez déconnecter et ouvrir une session sur l'ordinateur pour voir les modifications de comportement.

Contournement

Pour contourner ce problème, appliquez l'une des options suivantes :
  • Désactiver le codage mémorisé en bloc à partir du serveur Web. Pour plus d'informations si le serveur Web vous permet de désactiver le codage mémorisé en bloc et pour savoir comment désactiver le codage mémorisé en bloc, consultez la documentation du produit serveur Web.
  • Désactivez les paramètres HTTP 1.1 dans Microsoft Internet Explorer. Pour ce faire, procédez comme suit :
    1. Fermez toutes les fenêtres Internet Explorer actuellement actifs.
    2. Démarrez Internet Explorer.
    3. Dans le menu Outils , cliquez sur Options Internet .
    4. Dans la boîte de dialogue Options Internet , cliquez sur l'onglet Avancé .
    5. Sous Paramètres HTTP 1.1 dans la liste Paramètres , cliquez pour désactiver la case à cocher Utiliser HTTP 1.1.
    6. Sous Paramètres HTTP 1.1 , désactivez la case à cocher Utiliser HTTP 1.1 via des connexions de proxy , puis cliquez sur OK .

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ». Ce problème a été corrigé dans Windows Server 2003 Service Pack 2.

Plus d'informations

Pour plus d'informations sur la terminologie utilisée pour décrire les mises à jour logicielles Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 914453 - Dernière mise à jour: vendredi 1 juin 2007 - Version: 3.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional
Mots-clés : 
kbmt kbautohotfix kbwinserv2003sp2fix kbwinserv2003presp2fix kbwinxppresp3fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB914453 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 914453
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