Při pokusu o spuštění vlastní aplikace nebo při pokusu o otevření webu pomocí aplikace Internet Explorer 6 SP1 aplikace nebo Internet Explorer může přestat reagovat

Překlady článku Překlady článku
ID článku: 915355 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem obnovení registru v případě, že nastane problém. Další informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Pokuste se spustit vlastní aplikace nebo při pokusu o otevření webu pomocí aplikace Internet Explorer 6 Service Pack 1 (SP1). Pokud aplikace nebo webový server používá soubor Mshtml.dll a JScript, aplikace nebo Internet Explorer může přestat reagovat.

Příčina

K tomuto problému dochází při knihovny Mshtml.dll při aplikace se pokusí ukončit uchovává zámek zavaděče. Zámek zavaděče může zabránit ukončení jiných podprocesů. Toto chování způsobuje zablokování v aplikaci nebo v aplikaci Internet Explorer. Proto aplikace nebo Internet Explorer může přestat reagovat.

Řešení

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Instalací této opravy hotfix neexistují žádné požadavky.

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o registru

Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Chcete-li povolit tuto opravu hotfix, je nutné přidat následující klíče registru:
FEATURE_JSCRIPT_EXHAUSTIVE_COLLECT_AND_100MS_DOWNLOAD_THREAD_TIMEOUT_KB915355
FEATURE_ENABLE_DXTRANS_SHUTDOWN_TIMEOUT_KB905297
Postupujte takto:
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a klepněte na tlačítko OK.
  2. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE \Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. V nabídce Úpravy přejděte na příkaz Nový a klepněte na příkaz klíč.
  4. Zadejte FEATURE_JSCRIPT_EXHAUSTIVE_COLLECT_AND_100MS_DOWNLOAD_THREAD_TIMEOUT_KB915355 a stiskněte klávesu ENTER.
  5. V nabídce Úpravy klepněte na příkaz Nový a klepněte na položku DWORD.
  6. Zadejte iexplore.exe, nebo zadejte název vlastní aplikace a potom klepněte na tlačítko OK.
  7. V nabídce Úpravy klepněte na tlačítko změnit.
  8. Zadejte 1 a potom klepněte na tlačítko OK.
  9. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE \Software\Microsoft\Internet Explorer\Main\FeatureControl
  10. V nabídce Úpravy přejděte na příkaz Nový a klepněte na příkaz klíč.
  11. Zadejte FEATURE_ENABLE_DXTRANS_SHUTDOWN_TIMEOUT_KB905297 a stiskněte klávesu ENTER.
  12. V nabídce Úpravy klepněte na příkaz Nový a klepněte na položku DWORD.
  13. Zadejte iexplore.exe, nebo zadejte název vlastní aplikace a potom klepněte na tlačítko OK.
  14. V nabídce Úpravy klepněte na tlačítko změnit.
  15. Zadejte 1 a potom klepněte na tlačítko OK.
  16. Ukončete program Editor registru.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce Datum a čas v ovládacím.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Dxtrans.dll6.3.2800.1535192,51224. 2. 200621: 26X86
Iecustom.dll6.0.2800.150236,86419. 4. 200520: 56X86
Mshtml.dll6.0.2800.15362,708,99228. 2. 200622: 38X86

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 915355 - Poslední aktualizace: 15. listopadu 2007 - Revize: 1.7
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Explorer 6.0 SP1
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbpubtypekc KB915355 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:915355

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com