Al intentar ejecutar una aplicación personalizada o abrir un sitio Web con Internet Explorer 6 con SP1, la aplicación o Internet Explorer puede dejar de responder

Seleccione idioma Seleccione idioma
Id. de artículo: 915355 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Compruebe que ha hecho una copia de seguridad del Registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

Síntomas

Intente ejecutar una aplicación personalizada o abrir un sitio Web utilizando Microsoft Internet Explorer 6 con Service Pack 1 (SP1). Si la aplicación o el sitio Web utiliza el archivo Mshtml.dll y JScript, la aplicación o Internet Explorer deje de responder.

Causa

Este problema se produce cuando la biblioteca MSHTML.dll mantiene un bloqueo del cargador cuando la aplicación intenta salir. El bloqueo del cargador puede impedir que otros subprocesos salir. Este comportamiento hace que un interbloqueo en la aplicación o en Internet Explorer. Por lo tanto, la aplicación o Internet Explorer deje de responder.

Solución

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No hay requisitos previos para instalar este hotfix.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información del registro

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para habilitar esta revisión, debe agregar las siguientes claves del registro:
FEATURE_JSCRIPT_EXHAUSTIVE_COLLECT_AND_100MS_DOWNLOAD_THREAD_TIMEOUT_KB915355
FEATURE_ENABLE_DXTRANS_SHUTDOWN_TIMEOUT_KB905297
Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE \Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_JSCRIPT_EXHAUSTIVE_COLLECT_AND_100MS_DOWNLOAD_THREAD_TIMEOUT_KB915355 y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en nuevo y, a continuación, haga clic en DWORD .
  6. Escriba iexplore.exe , o escriba el nombre de la aplicación personalizada y, a continuación, haga clic en Aceptar .
  7. En el menú Edición , haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE \Software\Microsoft\Internet Explorer\Main\FeatureControl
  10. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  11. Escriba FEATURE_ENABLE_DXTRANS_SHUTDOWN_TIMEOUT_KB905297 y, a continuación, presione ENTRAR.
  12. En el menú Edición , haga clic en nuevo y, a continuación, haga clic en DWORD .
  13. Escriba iexplore.exe , o escriba el nombre de la aplicación personalizada y, a continuación, haga clic en Aceptar .
  14. En el menú Edición , haga clic en Modificar .
  15. Escriba 1 y, a continuación, haga clic en Aceptar .
  16. Editor de registro de salida.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Dxtrans.dll6.3.2800.1535192,51224-Feb-200621: 26x 86
Iecustom.dll6.0.2800.150236.86419-Abr-200520: 56x 86
Mshtml.dll6.0.2800.15362,708,99228-Feb-200622: 38x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 915355 - Última revisión: jueves, 15 de noviembre de 2007 - Versión: 1.7
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0 SP1
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbpubtypekc KB915355 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 915355

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com