Article ID: 915458 - Last Review: October 9, 2011 - Revision: 3.0

A client computer that is connected to a Windows Server 2003-based DHCP server loses network connectivity when the client computer tries to renew its IP address

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You change an exclusion range on a Microsoft Windows Server 2003-based Dynamic Host Configuration Protocol (DHCP) server. Or, you disable a scope in the Microsoft Management Console (MMC) of the DHCP server.
  • A client computer that is connected to the DHCP server tries to renew its IP address by sending a DHCP request packet to the DHCP server.
In this scenario, the client computer loses network connectivity.

CAUSE

The DHCP server replies to the DHCP request packet by sending a broadcast DHCP negative acknowledgement (NAK) packet instead of by sending a unicast DHCP NAK packet. If the client computer and the DHCP server are located on different IP subnets, the broadcast DHCP NAK packet does not reach the client computer. Therefore, the client computer loses network connectivity.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on your computer.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpssvc.dll5.2.3790.2645733,69622-Feb-200622:40IA-64SP1SP1QFE
Wdhcpssvc.dll5.2.3790.2645270,84822-Feb-200622:40x86SP1WOW
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpssvc.dll5.2.3790.2645432,64022-Feb-200622:40x64SP1SP1QFE
Wdhcpssvc.dll5.2.3790.2645270,84822-Feb-200622:40x86SP1WOW
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dhcpssvc.dll5.2.3790.2645270,84823-Feb-200611:07x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbwinserv2003presp2fix kbbug kbfix KB915458