Experimenta rendimiento más lento que habitual en Microsoft Dynamics CRM 3.0 cuando se ejecuta el trabajo MSCRM Stored Procedure Priming

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La revisión que se describe en este artículo no está disponible para la versión china de Microsoft Dynamics CRM o para la versión japonesa de Microsoft Dynamics CRM.
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Síntomas

En Microsoft Dynamics CRM 3.0, experimenta rendimiento más lento que típico cuando se ejecuta el trabajo MSCRM Stored Procedure Priming. Observe uno o varios de los síntomas siguientes:
  • Registros de la base de datos son más lentos que típica.
  • Uso de CPU es más habitual.
  • Hay aumentos inesperados en los siguientes contadores de rendimiento:
    • SQLServer: Estadísticas de SQL: solicitudes de lotes/seg.
    • SQLServer: Estadísticas de SQL: compilaciones SQL/seg.
    • SQLServer: Estadísticas de SQL: recompilaciones SQL/seg.
    • Disco físico: Longitud de cola de disco de Media

Causa

Este problema se produce porque el trabajo MSCRM Stored Procedure Priming existe para mantener los procedimientos almacenados en cascada de Microsoft Dynamics CRM en la caché de procedimientos de Microsoft SQL Server. De forma predeterminada, el trabajo MSCRM Stored Procedure Priming está programado para ejecutarse cada 10 minutos. La frecuencia de ejecutar el trabajo puede provocar el uso de la CPU llegue en SQL Server que contiene las bases de datos de Microsoft Dynamics CRM.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoTamaño del archivoFechaTiempo
Detail.rdl de estado de factura63,43612 De septiembre de 200623: 19
Factura status.rdl31,78812 De septiembre de 200623: 19
Pipeline.rdl ventas108,50712 De septiembre de 200623: 19
Detail.rdl de volumen de actividad de servicio100,12412 De septiembre de 200623: 19
Volume.rdl de actividad de servicio65,20012 De septiembre de 200623: 19

Información de instalación

Instalar esta revisión en equipos que ejecutan el servidor de Microsoft Dynamics CRM 3.0.

Requisitos previos

No hay ningún requisito previo para aplicar este hotfix.

Requisito de reinicio

Si se le pide, reinicie el equipo después de instalar la revisión.

Información acerca de cómo quitar

Para quitar esta revisión de un equipo que ejecuta servidor de Microsoft Dynamics CRM 3.0, utilice Agregar o quitar programas en el panel de control.Los administradores del sistema pueden utilizar la utilidad Spuninst.exe para quitar esta revisión de un equipo que ejecuta servidor de Microsoft Dynamics CRM 3.0.

La herramienta Spuninst.exe se encuentra en la carpeta %Windir%\$NTUninstallKB915722$\Spuninst.

Más información acerca de la revisión

Esta revisión resuelve este problema sólo cuando esté en el modo en línea en el cliente de Microsoft Dynamics CRM para Outlook. Esta revisión no resuelve el problema si está en modo sin conexión en el cliente para equipo portátil Microsoft Dynamics CRM para Outlook.

Solución

Para evitar este problema, cambie la programación para el trabajo MSCRM Stored Procedure Priming. Para ello, siga estos pasos dependiendo de la versión de SQL Server que está utilizando.

SQL Server 2005

  1. Haga clic en Inicio , seleccione Todos los programas , seleccione Microsoft SQL Server 2005 y, a continuación, haga clic en SQL Server Management Studio .
  2. Conectar con el SQL Server que contiene las bases de datos de Microsoft Dynamics CRM.
  3. Haga clic en Agente SQL Server .
  4. Haga clic en trabajos y haga doble clic en MSCRM almacenados procedimiento desbloquear trabajo .
  5. Haga clic en la ficha programaciones y haga doble clic en la programación Desbloquear de procedimiento almacenado .
  6. En el cuadro frecuencia Diariamente , seleccione el intervalo de tiempo que desee. Por ejemplo, seleccione 4 horas .
  7. Haga clic en Aceptar para cerrar los cuadros de diálogo.

SQL Server 2000

  1. Haga clic en Inicio , seleccione Todos los programas , seleccione Microsoft SQL Server y, a continuación, haga clic en Administrador corporativo .
  2. Expanda Servidores Microsoft SQL Server , expanda Grupo de SQL Server y, a continuación, expanda el servidor local.
  3. Expanda Administración y, a continuación, expanda Agente SQL Server .
  4. Haga clic en trabajos y haga doble clic en MSCRM almacenados procedimiento desbloquear trabajo .
  5. Haga clic en la ficha programaciones y haga doble clic en la lista programación. Debe establecer la programación en Periódico .
  6. Haga clic en cambiar .
  7. En el cuadro frecuencia Diariamente , seleccione el intervalo de tiempo que desee. Por ejemplo, seleccione 4 horas .
  8. Haga clic en Aceptar para cerrar los cuadros de diálogo.

Más información

Para obtener información acerca de la optimización del rendimiento para CRM 3.0, consulte el siguiente documento:
http://www.microsoft.com/downloads/details.aspx?FamilyID=6b32e0b3-5520-48a7-b3cd-d8477d084821&DisplayLang=en
Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
887283Los estándares de nomenclatura de paquete de actualización y revisiones de software de Microsoft Business Solutions CRM

Propiedades

Id. de artículo: 915722 - Última revisión: jueves, 10 de mayo de 2007 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft CRM 3.0
Palabras clave: 
kbmt kbautohotfix kbmbsadministration kbhotfixserver kbqfe kbmbsmigrate KB915722 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 915722

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