Si verificano prestazioni pi¨ lente in Microsoft Dynamics CRM 3.0 quando Ŕ in esecuzione il processo di MSCRM Stored Procedure priming

Traduzione articoli Traduzione articoli
Identificativo articolo: 915722 - Visualizza i prodotti a cui si riferisce l?articolo.
L'hotfix descritto in questo articolo non Ŕ disponibile per la versione cinese di Microsoft Dynamics CRM o per la versione giapponese di Microsoft Dynamics CRM.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

In Microsoft Dynamics CRM 3.0, si verificano di prestazioni pi¨ lente, quando il processo di MSCRM Stored Procedure priming Ŕ in esecuzione. Si si verifichi uno o pi¨ dei seguenti sintomi:
  • I record del database sono pi¨ lente rispetto tipica.
  • Utilizzo della CPU Ŕ pi¨ tipico.
  • Sono disponibili i seguenti contatori delle prestazioni aumento imprevisto:
    • SQLServer: Statistiche SQL: richieste batch/sec
    • SQLServer: Statistiche SQL: SQL Compilations/sec
    • SQLServer: Statistiche SQL: ricompilazioni SQL/sec
    • Disco fisico: Lunghezza coda disco Media

Cause

Questo problema si verifica perchÚ il processo di MSCRM Stored Procedure priming esiste per mantenere le stored procedure CSS di Microsoft Dynamics CRM nella cache delle procedure di Microsoft SQL Server. Per impostazione predefinita, il processo di MSCRM Stored Procedure priming Ŕ esecuzione pianificata ogni 10 minuti. La frequenza di esecuzione il processo pu˛ causare l'utilizzo della CPU picco in SQL Server contenente i database di Microsoft Dynamics CRM.

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome del fileDimensione del fileDataOra
Detail.rdl stato fattura63,43612-09-200623: 19
Fattura status.rdl31,78812-09-200623: 19
Vendita pipeline.rdl108,50712-09-200623: 19
Servizio detail.rdl del volume di attivitÓ100,12412-09-200623: 19
Servizio volume.rdl attivitÓ65,20012-09-200623: 19

Informazioni sull'installazione

Installare questo aggiornamento rapido (hotfix) nei computer che eseguono server Microsoft Dynamics CRM 3.0.

Prerequisiti

Non esistono prerequisiti per applicare questo aggiornamento rapido (hotfix).

NecessitÓ di riavvio

Se richiesto, riavviare il computer dopo avere installato l'hotfix.

Informazioni sulla rimozione

Per rimuovere questo aggiornamento rapido (hotfix) da un computer che esegue Microsoft Dynamics CRM 3.0 server, utilizzare lo strumento Installazione applicazioni nel Pannello di controllo.Gli amministratori di sistema consente l'utilitÓ Spuninst.exe di rimuovere questo aggiornamento rapido (hotfix) da un computer che esegue Microsoft Dynamics CRM 3.0 server.

Lo strumento di Spuninst.exe si trova nella cartella %Windir%\$NTUninstallKB915722$\Spuninst.

Ulteriori informazioni sull'hotfix

Questo hotfix risolve questo problema solo se si Ŕ in modalitÓ in linea nel client Microsoft Dynamics CRM per Outlook. Questo aggiornamento rapido (hotfix) non risolve il problema se la modalitÓ non in linea nel client laptop di Microsoft Dynamics CRM per Outlook.

Workaround

Per risolvere questo problema, modificare la pianificazione per il processo di MSCRM Stored Procedure priming. Per effettuare questa operazione, attenersi alla seguente procedura in base alla versione di SQL Server che si sta utilizzando.

SQL Server 2005

  1. Fare clic su Start , scegliere tutti i programmi , scegliere Microsoft SQL Server 2005 e quindi fare clic su SQL Server Management Studio .
  2. Connettersi al server SQL che contiene i database di Microsoft Dynamics CRM.
  3. Fare clic su Agente SQL Server .
  4. Fare clic su processi e quindi fare doppio clic su MSCRM stored procedure priming processo .
  5. Selezionare la scheda pianificazioni e quindi fare doppio clic sulla pianificazione di Stored Procedure Priming .
  6. Nella casella frequenza giornaliera , selezionare l'intervallo di tempo che si desidera. Ad esempio, selezionare 4 ore .
  7. Fare clic su OK per chiudere la finestra di dialogo.

SQL Server 2000

  1. Fare clic su Start , scegliere tutti i programmi , quindi Microsoft SQL Server e quindi Enterprise Manager .
  2. Espandere Microsoft SQL Server , espandere Gruppo SQL Server e quindi espandere il server locale.
  3. Espandere Gestione e quindi espandere Agente SQL Server .
  4. Fare clic su processi e quindi fare doppio clic su MSCRM stored procedure priming processo .
  5. Selezionare la scheda pianificazioni e quindi fare doppio clic sulla pianificazione elencata. La pianificazione deve essere impostata su periodica .
  6. Fare clic su Cambia .
  7. Nella casella frequenza giornaliera , selezionare l'intervallo di tempo che si desidera. Ad esempio, selezionare 4 ore .
  8. Fare clic su OK per chiudere la finestra di dialogo.

Informazioni

Per informazioni sull'ottimizzazione delle prestazioni per CRM 3.0, vedere il white paper seguenti:
http://www.microsoft.com/downloads/details.aspx?FamilyID=6b32e0b3-5520-48a7-b3cd-d8477d084821&DisplayLang=en
Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
887283Aggiornamenti e hotfix software Microsoft Business Solutions CRM standard di denominazione dei pacchetti

ProprietÓ

Identificativo articolo: 915722 - Ultima modifica: giovedý 10 maggio 2007 - Revisione: 3.2
Le informazioni in questo articolo si applicano a:
  • Microsoft CRM 3.0
Chiavi:á
kbmt kbautohotfix kbmbsadministration kbhotfixserver kbqfe kbmbsmigrate KB915722 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 915722
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com