Detecta desempenho lento do que o normal no Microsoft Dynamics CRM 3.0 quando a tarefa MSCRM procedimento armazenado desobstrução está em execução

Traduções de Artigos Traduções de Artigos
Artigo: 915722 - Ver produtos para os quais este artigo se aplica.
A correcção descrita neste artigo não está disponível para a versão em chinês do Microsoft Dynamics CRM ou para a versão japonesa do Microsoft Dynamics CRM.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

No Microsoft Dynamics CRM 3.0, detecta desempenho mais lento do que o normal quando o trabalho MSCRM procedimento armazenado desobstrução é executado. Detectar um ou mais dos seguintes sintomas:
  • Registos da base de dados são mais lentos do que o normal.
  • Utilização da CPU é mais do que normal.
  • Existem aumentos inesperados os seguintes contadores de desempenho:
    • Estatísticas do SQL Server: SQL: ' Pedidos batch/seg '
    • Estatísticas do SQL Server: SQL: SQL compilações/seg
    • Estatísticas do SQL Server: SQL: SQL recompilações/seg
    • Disco físico: Comprimento da fila disco média

Causa

Este problema ocorre porque a tarefa MSCRM procedimento armazenado desobstrução existe para manter os procedimentos armazenados em cascata do Microsoft Dynamics CRM na cache de procedimento do Microsoft SQL Server. Por predefinição, a tarefa MSCRM procedimento armazenado desobstrução está programada para ser executado a cada 10 minutos. A frequência de executar a tarefa pode causar a utilização da CPU picos no SQL Server que contém as bases de dados do Microsoft Dynamics CRM.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroTamanho do ficheiroDataTempo
Detail.rdl de estado da factura63,43612-Set-200623: 19
Factura status.rdl31,78812-Set-200623: 19
Pipeline.rdl vendas108,50712-Set-200623: 19
Detail.rdl de volume de actividade de serviço100,12412-Set-200623: 19
Volume.rdl de actividade de serviço65,20012-Set-200623: 19

Informações de instalação

Instale esta correcção nos computadores que executem o servidor do Microsoft Dynamics CRM 3.0.

Pré-requisitos

Existem não pré-requisitos para aplicar esta correcção.

Requisito de reinício

Se lhe for pedido, reinicie o computador depois de instalar a correcção.

Informações de remoção

Para remover esta correcção de um computador que está a executar o Microsoft Dynamics CRM 3.0 server, utilize Adicionar ou remover programas no painel de controlo.Os administradores de sistema podem usar o utilitário Spunist.exe para remover esta correcção de um computador que está a executar o Microsoft Dynamics CRM 3.0 server.

A ferramenta Spuninst.exe está localizada na pasta %Windir%\$NTUninstallKB915722$\Spuninst.

Obter mais informações sobre a correcção

Esta correcção resolve este problema apenas quando estiver no modo online no cliente do Microsoft Dynamics CRM para Outlook. Esta correcção não resolve o problema se estiver no modo offline no cliente de laptop do Microsoft Dynamics CRM para Outlook.

Como contornar

Para contornar este problema, altere a agenda para a tarefa MSCRM procedimento armazenado desobstrução. Para o fazer, siga estes passos dependendo da versão do SQL Server que está a utilizar.

SQL Server 2005

  1. Clique em Iniciar , aponte para Todos os programas , aponte para Microsoft SQL Server 2005 e, em seguida, clique em SQL Server Management Studio .
  2. Estabelecer ligação com o SQL Server que contém as bases de dados do Microsoft Dynamics CRM.
  3. Clique em SQL Server Agent .
  4. Clique em tarefas e, em seguida, faça duplo clique MSCRM armazenadas procedimento desobstrução tarefa .
  5. Clique no separador programas e, em seguida, faça duplo clique agenda Armazenadas desobstrução do procedimento .
  6. Na caixa de frequência diária , seleccione o intervalo de tempo que pretende. Por exemplo, seleccione 4 horas .
  7. Clique em OK para fechar as caixas de diálogo.

SQL Server 2000

  1. Clique em Iniciar , aponte para Todos os programas , aponte para Microsoft SQL Server e, em seguida, clique em Enterprise Manager .
  2. Expanda Servidores Microsoft SQL Server , expanda SQL Server Group e, em seguida, expanda o servidor local.
  3. Expanda Gestão e, em seguida, expanda SQL Server Agent .
  4. Clique em tarefas e, em seguida, faça duplo clique MSCRM armazenadas procedimento desobstrução tarefa .
  5. Clique no separador programas e, em seguida, faça duplo clique a agenda listada. A agenda deve ser definida como periódico .
  6. Clique em alterar .
  7. Na caixa de frequência diária , seleccione o intervalo de tempo que pretende. Por exemplo, seleccione 4 horas .
  8. Clique em OK para fechar as caixas de diálogo.

Mais Informação

Para obter informações sobre optimização do desempenho para o CRM 3.0, consulte a seguinte documentação técnica:
http://www.microsoft.com/downloads/details.aspx?FamilyID=6b32e0b3-5520-48a7-b3cd-d8477d084821&DisplayLang=en
Para obter mais informações sobre a terminologia de actualização de software, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft
887283Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

Propriedades

Artigo: 915722 - Última revisão: 10 de maio de 2007 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft CRM 3.0
Palavras-chave: 
kbmt kbautohotfix kbmbsadministration kbhotfixserver kbqfe kbmbsmigrate KB915722 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 915722

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com