Message d'erreur lorsque vous utilisez l'Assistant Copie de base de données dans SQL Server 2005 pour migrer la base de données Microsoft Dynamics CRM 3.0 MSCRM à partir de SQL Server 2000: "paramètre Source de connexion (Erreur)"

Traductions disponibles Traductions disponibles
Numéro d'article: 915799 - Voir les produits auxquels s'applique cet article
Le correctif décrits dans cet article n'est pas disponible pour la version chinoise de Microsoft Dynamics CRM ou pour la version japonaise de Microsoft Dynamics CRM.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous utilisez l'Assistant Copie de base de données dans Microsoft SQL Server 2005 pour migrer la base de données Microsoft Dynamics CRM 3.0 MSCRM à partir de Microsoft SQL Server 2000, vous recevez le message d'erreur suivantes dans l'Assistant Copie de base de données :
Paramètre de connexion de source (erreur)
Messages
? Erreur 0xc0202009 : activité [1] de la source : un OLE DB erreur s'est produite. Code d'erreur : 0x80040E37. (SQL Server Assistant d'importation et exportation)
? Erreur 0xc02020e8 : activité [1] de la source : ouverture d'un ensemble de lignes pour " [Database Name _MSCRM]. [dbo]. [activité] " a échoué. Vérifiez que l'objet existe dans la base de données. (SQL Server Assistant d'importation et exportation)
? Exception de HRESULT : 0xC02020E8 (Microsoft.SqlServer.DTSPipelineWrap)
note L'espace réservé au Database Name est un espace réservé pour le nom de base de données MSCRM réel.

Lorsque vous puis exécutez le sélectionnez * d'activité commande SQL dans la base de données MSCRM dans SQL Query Analyzer pour déterminer si l'objet existe dans la base de données, vous recevez le message d'erreur suivantes :
Serveur: Msg 208, Niveau 16, État 1, procédure activité, ligne 75
Nom d'objet non valide « ActivityBase ».
Serveur: Msg 4413, Niveau 16, État 1, ligne 1
Pourrait pas utiliser vue ou fonction « activité » raison d'erreurs de liaison. »

Cause

Ce problème se produit car une vue fait référence à une table qui n'existe pas. La table n'existe pas, car la base de données ne migre pas correctement.

Contournement

Pour contourner ce problème, appliquez l'une des méthodes suivantes.

Méthode 1

La commande détacher la base de données permet de supprimer la base de données de l'instance de Microsoft SQL Server 2000. Ensuite, utilisez la commande Insérer une base de données pour attacher la base de données à l'instance de Microsoft SQL 2005.

Méthode 2

  1. Sauvegardez la base de données dans Microsoft SQL Server 2000.
  2. Installer Microsoft SQL Server 2005.
  3. Restaurez la base de données dans Microsoft SQL Server 2005.

Résolution

Ce problème est résolu dans Microsoft Dynamics CRM 3.0 mise à jour le correctif cumulatif 1. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
922815 Le correctif cumulatif 1 est disponible pour Microsoft Dynamics CRM 3.0

Plus d'informations

Pour plus d'informations sur l'Assistant Base de données de copie dans Microsoft SQL Server 2005, reportez-vous à la rubrique suivante dans la documentation en ligne de SQL Server 2005 :
mise à niveau vers SQL Server 2005 avec l'Assistant Copie de base de données
Pour plus d'informations sur la terminologie utilisée pour décrire les mises à jour logicielles Microsoft, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft
887283 Package correctif de logiciel Microsoft Business Solutions CRM et mise à jour de normes d'affectation de noms

Propriétés

Numéro d'article: 915799 - Dernière mise à jour: jeudi 7 décembre 2006 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft CRM 3.0
Mots-clés : 
kbmt kbmbsupgrade kberrmsg kbbug kbhotfixserver kbqfe kbmbsmigrate KB915799 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 915799
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com