SQL Server 2000 から Microsoft Dynamics CRM 3.0 MSCRM データベースを移行するのには SQL Server 2005 では、データベース コピー ウィザードを使用すると、エラー メッセージ: 設定ソース接続」(エラー)

文書翻訳 文書翻訳
文書番号: 915799
この資料で説明されている修正プログラムの体字中国語バージョンの Microsoft Dynamics CRM または Microsoft Dynamics CRM の日本語版ではありません。
すべて展開する | すべて折りたたむ

目次

現象

Microsoft SQL Server 2005 年に Microsoft SQL Server 2000 から Microsoft Dynamics CRM 3.0 MSCRM データベースを移行するのには、データベース コピー ウィザードを使用すると、データベース コピー ウィザードでは、次のエラー メッセージが表示されます。
ソース接続 (エラー) を設定します。
メッセージ
? エラー 0xc0202009: ソース ・活動 [1]: に OLE DB エラーが発生しました。エラー コード: 0x80040E37。(SQL Server のインポートとエクスポート ウィザード)
? エラー 0xc02020e8: ソース ・活動 [1]:"[は行セットを開くデータベース名_MSCRM]。[dbo].[活動]「に失敗しました。オブジェクトがデータベースに存在することを確認してください。(SQL Server のインポートとエクスポート ウィザード)
? HRESULT からの例外: 0xC02020E8 (Microsoft.SqlServer.DTSPipelineWrap)
メモ は、 データベース名 プレース ホルダーは、MSCRM データベースの実際の名前のプレース ホルダーです。

実行すると、 選択 * アクティビティから SQL のコマンド オブジェクトがデータベースに存在するかどうかを確認するのには、SQL クエリ アナライザーで、MSCRM データベースに対して、次のエラー メッセージが表示されます。
サーバー: メッセージ 208、レベル 16、状態 1、プロシージャの処理、行 75
無効なオブジェクト名 'ActivityBase'。
サーバー: メッセージ 4413、レベル 16、状態 1、行 1
ビューまたは関数 'アクティビティ' バインド エラーにより使用できませんでした。"

原因

ビューが存在しないテーブルを参照するために発生します。データベースが正しく移行されなかったため、テーブルは存在しません。

回避策

この問題を回避するには、次の方法のいずれかを使用します。

方法 1

使用して、 データベースをデタッチします。 Microsoft SQL Server 2000年のインスタンスからデータベースを削除するコマンドです。次に、 データベースをアタッチします。 Microsoft SQL 2005 のインスタンスにデータベースをアタッチするコマンドです。

方法 2

  1. Microsoft SQL Server 2000年にデータベースをバックアップします。
  2. Microsoft SQL Server 2005年をインストールします。
  3. Microsoft SQL Server 2005年にデータベースを復元します。

解決方法

Microsoft Dynamics CRM 3.0 の更新プログラム ロールアップ 1 にはこの問題を解決します。 詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
922815 Microsoft Dynamics CRM 3.0 の更新プログラム ロールアップ 1 があります。

詳細

Microsoft SQL Server 2005 年のデータベース コピー ウィザードの詳細については、次のトピックでは、SQL Server 2005 Books Online を参照してください。
データベース コピー ウィザードを使用して SQL Server 2005 へのアップグレード
マイクロソフトのソフトウェア更新プログラムの説明に使用される用語の詳細については、マイクロソフト サポート技術記事を表示するのには、次の資料番号をクリックしてください。
824684 マイクロソフトのソフトウェア更新プログラムの説明に使用される一般的な用語の説明
887283 Microsoft ビジネス ソリューションの CRM のソフトウェア修正プログラムおよび更新プログラム パッケージの命名規則

プロパティ

文書番号: 915799 - 最終更新日: 2011年8月4日 - リビジョン: 4.0
キーワード:?
kberrmsg kbbug kbqfe kbmbsmigrate kbhotfixserver kbmbsupgrade kbmt KB915799 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:915799
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com