Mensagem de erro ao usar o Assistente de cópia de banco de dados no SQL Server 2005 para migrar o banco de dados MSCRM do Microsoft Dynamics CRM 3.0 do SQL Server 2000: "Configuração conexão de origem (erro)"

Traduções deste artigo Traduções deste artigo
ID do artigo: 915799 - Exibir os produtos aos quais esse artigo se aplica.
O hotfix discutido neste artigo não está disponível para a versão em chinês do Microsoft Dynamics CRM ou para a versão em japonês do Microsoft Dynamics CRM.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você usa o Assistente de cópia de banco de dados no Microsoft SQL Server 2005 para migrar o banco de dados MSCRM do Microsoft Dynamics CRM 3.0 do Microsoft SQL Server 2000, você receber a seguinte mensagem de erro do Assistente de cópia de banco de dados:
Configuração de conexão de origem (erro)
Mensagens
? Erro 0xc0202009: Source - atividade [1]: erro de um OLE. Código de erro: 0x80040E37. Assistente (SQL Server para importação e exportação)
? Erro 0xc02020e8: Source - atividade [1]: abrir um conjunto de linhas para "[Database Name _MSCRM]. [dbo]. [Atividade]" falhou. Verifique se o objeto existe no banco de dados. Assistente (SQL Server para importação e exportação)
? Exceção de HRESULT: 0xC02020E8 (Microsoft.SqlServer.DTSPipelineWrap)
Observação O espaço reservado para Database Name é um espaço reservado para o nome de banco de dados MSCRM real.

Quando você, então, executar o Selecione * de Activity comando SQL no banco de dados do Microsoft CRM no SQL Query Analyzer para determinar se o objeto existe no banco de dados, você receber a seguinte mensagem de erro:
Servidor: Mensagem 208, nível 16, estado 1, atividade de procedimento, linha 75
Nome de objeto inválido 'ActivityBase'.
Servidor: Mensagem 4413, nível 16, estado 1, linha 1
Não foi possível usar modo de exibição ou função 'Atividade' devido a erros de ligação."

Causa

Esse problema ocorre porque um modo de exibição faz referência a uma tabela que não existe. A tabela não existe porque o banco de dados não corretamente a migração.

Como Contornar

Para contornar este problema, use um dos seguintes métodos.

Método 1

Use o comando Desanexar banco de dados para remover o banco de dados da instância do Microsoft SQL Server 2000. Em seguida, use o comando Anexar banco de dados para anexar o banco de dados para a instância do Microsoft SQL 2005.

Método 2

  1. Fazer backup do banco de dados no Microsoft SQL Server 2000.
  2. Instale o Microsoft SQL Server 2005.
  3. Restaure o banco de dados no Microsoft SQL Server 2005.

Resolução

Esse problema é corrigido no Update Rollup 1 do Microsoft Dynamics CRM 3.0. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
922815O pacote cumulativo de atualizações 1 está disponível para o Microsoft Dynamics CRM 3.0

Mais Informações

Para obter mais informações sobre o Assistente de cópia de banco de dados no Microsoft SQL Server 2005, consulte o tópico a seguir nos manuais online do SQL Server 2005:
atualização para o SQL Server 2005 com o Assistente de cópia de banco de dados
Para obter mais informações sobre a terminologia que é usada para descrever as atualizações de software da Microsoft, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
887283Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

Propriedades

ID do artigo: 915799 - Última revisão: quinta-feira, 7 de dezembro de 2006 - Revisão: 2.2
A informação contida neste artigo aplica-se a:
  • Microsoft CRM 3.0
Palavras-chave: 
kbmt kbmbsupgrade kberrmsg kbbug kbhotfixserver kbqfe kbmbsmigrate KB915799 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 915799

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com