Help and Support

Id. de artículo: 916089 - Última revisión: lunes, 10 de diciembre de 2007 - Versión: 10.4

REVISIÓN: Cuando se ejecuta Windows Update para buscar actualizaciones que utilizan a Windows Installer, incluidas las actualizaciones de Office, puede experimentar una pérdida de memoria o que reciba un mensaje de error para el proceso Svchost

AVISO
El problema que describe la sección "Síntomas" se corrigió en Windows Update Agent 3.0 y en actualización 927891. Estas actualizaciones se distribuyeron a través de Microsoft Update en junio y julio de 2007. Si todavía experimenta un problema que se asemeje al que se describe en este artículo, puede ser un problema diferente. Para solucionar problemas similares, vea la sección "Similar problems and resolutions" más adelante en este artículo.

Información acerca de la sustitución de la revisión

Se ha reemplazado la revisión que describe este artículo (916089) mediante una revisión más reciente (927891). La revisión 927891 también corrige el problema que se describe en la sección "Síntomas".

En esta página

Expandir todo | Contraer todo

Síntomas

Cuando ejecuta Microsoft Windows Update para buscar actualizaciones o para aplicar actualizaciones a aplicaciones que utilizan Microsoft Windows Installer (MSI) 3.1 junto con Windows Update, puede recibir el siguiente mensaje de error en el Visor de sucesos en un equipo:
Aplicación emergente: svchost.exe - Error de aplicación: la instrucción en "0x745f2780" hace referencia a memoria en "0x00000070". La memoria no se pudo "leer".
Además, puede producirse una pérdida de memoria cuando Windows Update busca actualizaciones que usan a Windows Installer.

Estos problemas pueden producirse cuando intenta buscar actualizaciones de Microsoft Office. También puede experimentar estos problemas cuando utilizas alguno de los mecanismos de actualización siguiente:
  • El sitio Web de Microsoft Update.
  • Actualizaciones automáticas a través de Internet o a través de Windows Server Update Services (WSUS).
  • Microsoft Systems Management Server Inventory Tool for Microsoft Updates (SMS ITMU).
  • Microsoft Baseline Security Analyzer (MBSA).
  • Explora cualquier aplicación que realiza la actualización mediante el archivo CAB de análisis sin conexión (Wsusscan.cab) que utiliza Windows Update Agent (WUA).
Por ejemplo, puede experimentar este problema cuando intenta digitalizar para actualizaciones de Microsoft Office o cuando aplique una actualización a cualquier aplicación en un equipo que utiliza Microsoft Windows Installer 3.1 (también conocido como MSI) junto con el agente de actualización de Windows.

Causa

Este problema puede producirse cuando el agente de Windows Update intenta buscar actualizaciones de Windows Installer.

Solución

Información de revisiones

Para resolver este problema, aplique la revisión más reciente de MSI.dll. Esta revisión se describe en el siguiente artículo de Microsoft Knowledge Base:
927891  (http://support.microsoft.com/kb/927891/ ) Recibirá un error de infracción de acceso y el sistema puede parecer que dejan de responder cuando intenta instalar una actualización desde Windows Update o desde Microsoft Update

Información acerca de la sustitución de la revisión

Se ha reemplazado el hotfix que se describe en este artículo (916089) mediante una revisión más reciente (927891). La revisión 927891 incluye las actualizaciones que se enumeran en este artículo. Cuando Windows Update busca actualizaciones que usan a Windows Installer, el sistema puede dejar de responder. La revisión 927891 resuelve este problema.

Estado

Este problema se corrigió en Windows Update Agent 3.0 y la actualización 927891.

Más información

Esta actualización reduce la duración de una búsqueda que utiliza al agente de actualización de Windows. Sin embargo, un examen todavía es una operación intensivo de la CPU. El proceso Svchost.exe contiene el servicio actualizaciones automáticas. Al realizar un análisis, el proceso Svchost.exe puede provocar que uso de CPU llegar a 100 por ciento durante un tiempo prolongado. Por ejemplo, actualizaciones de Microsoft Office utilizan a Windows Installer. Cuando se detectan actualizaciones de Microsoft Office, estas actualizaciones pueden contribuir a 100 % de uso de CPU durante un tiempo prolongado.

Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Problemas similares y soluciones

Si todavía experimenta un problema que se asemeje al que se describe en este artículo, puede ser un problema diferente. Para obtener más información acerca de problemas similares y soluciones, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
939273  (http://support.microsoft.com/kb/939273/ ) No se puede implementar actualizaciones de software en un equipo que ejecuta Windows XP o Windows Server 2003
932762  (http://support.microsoft.com/kb/932762/ ) El proceso de host del servicio puede detenerse inesperadamente en Windows Server 2003
931852  (http://support.microsoft.com/kb/931852/ ) Mensajes de error al iniciar un equipo basado en Windows XP y a continuación, intente descargar actualizaciones de Windows
910666  (http://support.microsoft.com/kb/910666/ ) El proceso puede terminar inesperadamente en un equipo basado en Windows Server 2003 de Svchost.exe
894538  (http://support.microsoft.com/kb/894538/ ) Cuando el servicio de autenticación de Internet recibe un atributo desconocido en un paquete, un servidor de servicio de autenticación de Internet basada en Windows Server 2003 deja de responder
927385  (http://support.microsoft.com/kb/927385/ ) Recibe un mensaje de error después de un equipo basado en Windows XP ejecuta una actualización automática y no podrá ejecutar ningún programa después de cerrar el "svchost.exe - Application Error" cuadro de diálogo mensaje de error
Si estos artículos no le ayudan a resolver el problema o si experimenta síntomas distintos de los que se describe en este artículo, busque la Microsoft Knowledge Base para obtener más información. Para realizar una búsqueda en Microsoft Knowledge Base, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com (http://support.microsoft.com/)
A continuación, escriba el texto de la mensaje de error que recibe o escriba una descripción del problema en el Soporte de búsqueda (KB) campo.

La información de este artículo se refiere a:
  • Microsoft Windows Installer 3.1
  • Microsoft Windows XP Professional sobre las siguientes plataformas
    • Microsoft Office XP Professional Edition
    • Microsoft Office XP Standard Edition
    • Microsoft Office XP Personal
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows 2000 Server SP4
  • Microsoft Update
Palabras clave: 
kbmt kbresolve kbwinserv2003sp2fix kbpubtypekc kbqfe kbhotfixserver KB916089 KbMtes
Traducción automáticaTraducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 916089  (http://support.microsoft.com/kb/916089/en-us/ )

Seleccione idioma

 

Related Support Centers