Al poner en desconexión el cliente para equipo portátil de Microsoft Dynamics CRM para Outlook recibe un mensaje que le indica que durante una acción de Insert no se pudieron mover datos de una entidad y debe contactar con el administrador del sistema

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Síntomas

Al poner en desconexión el cliente para equipo portátil de Microsoft Dynamics CRM para Outlook, puede recibir el mensaje de error siguiente:
No se pudieron mover los datos de la entidad nombreEntidad durante la acción saInsert, countRows=númeroCuenta. Póngase en contacto con el administrador del sistema para obtener ayuda.
Nota: en este mensaje, nombreEntidad es un marcador de posición para el nombre de una entidad real y númeroCuenta es un marcador de posición para el número real de filas.

Se registra un mensaje de error similar al siguiente en el registro de sucesos:

Tipo de suceso: error
Origen del suceso: MSCRMOfflineSync
Categoría del suceso: ninguna
Id. del suceso: 6000
Descripción: Se produjo un error durante la Sincronización sin conexión. Intente desconectar de nuevo o reinicie Microsoft Outlook. GetBCPFile() falló durante una acción Insert para la entidad <Case>, batchRows=0 con la excepción System.Net.WebException: El servidor remoto devolvió un error: (401) No autorizado. ---> System.ComponentModel.Win32Exception: El intento de inicio de sesión dio error en System.Net.NTAuthentication.GetOutgoingBlob(Byte[] incomingBlob, Boolean& handshakeComplete) at System.Net.NTAuthentication.GetOutgoingBlob(String incomingBlob, Boolean& handshakeComplete) at System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate) at System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate) at System.Net.NegotiateClient.Authenticate(String challenge, WebRequest webRequest, ICredentials credentials) at System.Net.AuthenticationManager.Authenticate(String challenge, WebRequest request, ICredentials credentials) at System.Net.AuthenticationState.AttemptAuthenticate(HttpWebRequest httpWebRequest, ICredentials authInfo) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.CheckFinalStatus() at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) at System.Net.HttpWebRequest.GetResponse() at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.GetBCPFile(String entityName, Action action, Int32 batchSize).
Para obtener más información al respecto, vea el Centro de ayuda y soporte técnico en http://support.microsoft.com.
Se registra un mensaje de advertencia similar al siguiente en el registro de sucesos:

Tipo de suceso: advertencia
Origen del suceso: MSCRMOfflineSync
Categoría del suceso: ninguna
Id. del suceso: 6001
Descripción: Se recibió un resultado inesperado durante la Sincronización sin conexión. La cuente de #temp<baseEntidad> inserta 54!=27 inserciones de cuentas solicitadas.
Para obtener más información al respecto, vea el Centro de ayuda y soporte técnico en http://support.microsoft.com.
Nota: en este mensaje, baseEntidad es un marcador para un nombre de tabla real para la entidad.

Causa

Este problema se produce cuando se cumplen una o varias de las siguientes condiciones:
  • El cliente para equipo portátil de Microsoft Dynamics CRM para Outlook no tiene permisos para el acceso a la carpeta BCP.
  • La versión de Microsoft XML (MSXML) en el cliente para equipo portátil de Microsoft Dynamics CRM para Outlook es incorrecta.
  • Los filtros de los datos sin conexión en el cliente para equipo portátil de Microsoft Dynamics CRM para Outlook son incorrectos.
  • La instalación del servidor de Microsoft CRM está dañada.
  • La cuenta de usuario que ejecuta el grupo de aplicaciones en el sitio Web de Microsoft CRM no tiene acceso a la carpeta de datos sin conexión en el servidor de Microsoft CRM.
  • Las bases de datos de Microsoft SQL Server se mueven a un nuevo servidor. El Origen de datos DSN de sistema ODBC de Microsoft CRM del servidor Microsoft CRM sigue señalando al servidor anterior que está ejecutando SQL Server.
  • El equipo que está ejecutando SQL Server y que contiene las bases de datos MSCRM está enviando más registros de lo que es habitual a la base de datos sin conexión.
  • Se ha agregado el modificador /3GB al archivo Boot.ini de Microsoft CRM Server. Este problema hace que el servidor se quede sin memoria cuando intenta implementar el proceso BCP.
  • Microsoft Data Access Components (MDAC) 2.8 Service Pack 1 (SP1) no está instalado.

Solución

Para resolver este problema, utilice uno o varios de los métodos siguientes.

Método 1

Conceder permisos para la carpeta BCP al usuario del cliente para el equipo portátil de Microsoft CRM para Outlook. Para ello, siga estos pasos:
  1. Inicie sesión en el cliente para equipo portátil de Microsoft CRM para Outlook y busque después la carpeta BCP. Normalmente, la carpeta BCP está ubicada en la siguiente ruta de acceso del equipo cliente:
    C:\Documents and Settings\ nombreUsuario\Datos de programa\Microsoft\MSCRM\BCP
    Notas
    • En un equipo con Windows Vista, la carpeta BCP está ubicada en la ruta de acceso siguiente:
      C:\Users\nombreUsuario\AppData\Roaming\Microsoft\MSCRM\BCP
    • En este paso, nombreUsuario es un marcador de posición para el nombre de usuario real.
  2. Busque la carpeta y haga clic en ella con el botón secundario del mouse (ratón). Haga clic después en Propiedades.
  3. Haga clic en la ficha Seguridad.
  4. En la lista Nombres de grupos o usuarios, seleccione el usuario del cliente para equipo portátil de Microsoft CRM para Outlook.
  5. En la lista Permisos paranombreUsuario, compruebe que está seleccionada la casilla de verificación Permitir de la fila Control total. Después haga clic en Aceptar.

    Nota: en este paso, nombreUsuario es un marcador de posición para el nombre de usuario real.

Método 2

Comprobar que la versión del archivo Msxml4.dll que hay en el equipo cliente es al menos la 4.20.9828. Para ello, siga estos pasos:
  1. Busque la carpeta system32. Normalmente esta carpeta está ubicada en la ruta de acceso siguiente:

    C:\WINDOWS\system32\
  2. Haga clic con el botón secundario en el archivo Msxml4.dll y, a continuación, haga clic en Propiedades. Haga clic en la ficha Versión.
  3. Compruebe si el valor de Versión de archivo es al menos 4.20.9828. Si el valor es anterior a esta versión, vaya al paso 4.
  4. Si la versión del archivo Msxml4.dll es anterior a 4.20.9828, el archivo deberá actualizarse. Para obtener información acerca de cómo obtener un archivo actualizado, visite el sitio Web de Microsoft siguiente:
    http://support.microsoft.com/kb/887606/es-es
    Notas
    • También puede obtener el archivo Msxml4.dll desde el CD de la instalación del cliente. Normalmente, el archivo Msxml4sp2-kb887606-x86-enu.exe está ubicado en la siguiente ruta de acceso:

      \Client\MSXML\KB887606\
    • Este arreglo no requiere que reinicie el equipo.

Método 3

Quitar todos los filtros de datos sin conexión y agregar y sincronizar esos filtros uno a uno en el equipo cliente. Para quitar los filtros de datos sin conexión, siga estos pasos:
  1. En el cliente para equipo portátil de Microsoft Dynamics CRM para Outlook, haga clic en Datos locales en el menú CRM.
  2. En el cuadro de diálogo Datos locales, resalte todos los filtros, haga clic en Desactivar y después en Aceptar.
Para agregar y sincronizar estos filtros, siga estos pasos:
  1. En el menú CRM, haga clic en Datos locales.
  2. Haga clic en la ficha Desactivar grupos de datos.
  3. Seleccione uno de los filtros. Después haga clic en Activar.
  4. Haga clic en Aceptar.
  5. Haga clic en Desconectarse para iniciar el proceso de sincronización. Después haga clic en Conectarse para completar el proceso de sincronización.
  6. Repita los pasos 3 a 5 por cada filtro desactivado.

Método 4

Ejecutar el proceso de reparación en el servidor de Microsoft CRM. Para ello, siga estos pasos:
  1. Inicie sesión en el servidor de Microsoft CRM. Haga clic en Inicio, en Panel de control y, después, en Agregar o quitar programas.
  2. Haga clic en Microsoft CRM Server. Haga clic en Cambiar o quitar.
  3. Haga clic en la opción Reparar. Después haga clic en Siguiente para iniciar el asistente para la instalación de Microsoft CRM Server.

Método 5

Comprobar que la cuenta de usuario que ejecuta el grupo de aplicaciones del sitio Web de Microsoft CRM tenga acceso a la carpeta OfflineData. Esta carpeta almacena los archivos de datos BCP (Bulk Copy Process) que el cliente obtiene del servidor que está ejecutando SQL Server. Para garantizar que se tenga acceso a la carpeta OfflineData, siga estos pasos:
  1. Determine la cuenta que está ejecutando el grupo de aplicaciones. Para ello, siga estos pasos:
    1. Inicie sesión en el servidor de Microsoft CRM.
    2. Haga clic en Inicio, en Herramientas administrativas y, a continuación, en el Administrador de Internet Information Services (IIS).
    3. Expanda el nombre del equipo local, expanda Grupos de aplicaciones, haga clic con el botón secundario en CRMAppPool y después haga clic en Propiedades.
    4. Haga clic en la ficha Identidad.
    5. Compruebe los permisos de acuerdo con las directrices siguientes:

      Si la opción Predefinida está seleccionada, las cuentas NetworkService y LocalSystem están representadas ambas por la cuenta nombreDominio\nombreEquipo$. Por tanto, cuando debe verificar los permisos parta la cuenta NetworkService o para la cuenta LocalSystem, deberá verificar también los permisos para la cuenta nombreDominio\nombreEquipo$.

      Si la opción Configurable está seleccionada, debe verificar permisos para la cuenta del usuario especificado.

      Nota: si está seleccionada la opción predefinida, use la cuenta nombreDominio\nombreEquipo$ como el usuario en el paso 5. Si es seleccionada la opción Configurable, use la cuenta de usuario especificado como el usuario del paso 5.
  2. En el servidor de Microsoft CRM, busque la carpeta siguiente:

    Unidad:\Archivos de programa\Microsoft CRM\Server\OfflineData\

    Nota: en este paso, Unidad es un marcador de posición para la unidad actual en la que instaló Microsoft CRM.
  3. Haga clic con el botón secundario en la carpeta. Haga clic después en Propiedades.
  4. Haga clic en la ficha Seguridad.
  5. Desde la lista Nombres de grupos o usuarios, seleccione el usuario que identificó en el paso 1.
  6. En la lista Permisos paranombreUsuario, compruebe que está seleccionada la casilla de verificación Permitir de la fila Control total. Después haga clic en Aceptar.

    Nota: en este paso, nombreUsuario es un marcador de posición para el nombre de usuario real.

Método 6

Modificar el Origen de datos DSN de sistema ODBC de Microsoft CRM del servidor Microsoft CRM para seleccionar el nuevo servidor que está ejecutando SQL Server. Para ello, siga estos pasos:
  1. Haga clic en Inicio, seleccione Herramientas administrativas y, a continuación, haga clic en Orígenes de datos (ODBC).
  2. En el cuadro de diálogo Administrador de orígenes de datos ODBC, haga clic en la ficha DSN de sistema, en la lista Microsoft CRM en los orígenes de datos de sistema y, después, haga clic en Configurar.
  3. En la primera ventana de Configuración DSN de Microsoft SQL Server busque la lista Servidor, que contiene los nombres de los equipos que están ejecutando SQL Server. Haga clic en el servidor con el que desea conectar.
  4. Haga clic en Siguiente tres veces para configurar el origen de datos.
  5. Haga clic en Finalizar.
  6. En la ventana Configuración de ODBC de Microsoft SQL Server, haga clic en Probar origen de datos para validar la conexión con el servidor.
  7. Haga clic en Aceptar dos veces para completar la configuración.
  8. Haga clic en Aceptar para cerrar el cuadro de diálogo Administrador de origen de datos ODBC.

Método 7

  1. Salir de Microsoft Dynamics CRM 3.0.
  2. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  3. Busque la siguiente subclave del Registro y haga clic en ella:
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
  4. Haga clic con el botón secundario del mouse en el valor DWORD OfflineRowsBatchSize y, a continuación, haga clic en Modificar.
  5. En el cuadro Información del valor, escriba un valor que sea más pequeño que el valor actual, como 10 o 1. Después, haga clic en Aceptar.

    Nota: de manera predeterminada, el valor DWORD OfflineRowsBatchSize está establecido en cero 100000.
  6. Salga del Editor del Registro.

Método 8

Quitar el modificador /3GB del archivo Boot.ini del servidor Microsoft CRM. Para que los cambios surtan efecto, debe reiniciar el equipo después de quitar el modificador.

Método 9

Instalar MDAC 2.8 Service Pack 1. Para instalar MDAC 2.8 SP1, visite el siguiente sitio web de Microsoft:
http://www.microsoft.com/downloads/details.aspx?displaylang=es&FamilyID=78cac895-efc2-4f8e-a9e0-3a1afbd5922e

Método 10

Si se aplicaron actualizaciones recientes al sistema operativo Windows en el servidor Microsoft Dynamics CRM que está ejecutando SQL Server, reiniciar el servidor.

Más información

Si sigue experimentando el problema que se describe en la sección "Síntomas", haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
918108 Recibe un mensaje de error cuando intenta ponerse sin conexión en un equipo para cliente portátil que esté ejecutando Microsoft Dynamics CRM 3.0: "No se pudieron mover datos para la entidad"

Referencias

Para obtener información adicional acerca de cómo mover bases de datos SQL de Microsoft Dynamics CRM 3.0 de un servidor a otro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
917948 Cómo mover las bases de datos de SQL de Microsoft Dynamics CRM 3.0 de un servidor a otro que esté en el mismo dominio

Propiedades

Id. de artículo: 916165 - Última revisión: lunes, 16 de mayo de 2011 - Versión: 8.0
La información de este artículo se refiere a:
  • Microsoft CRM client for Microsoft Office Outlook
  • Microsoft Dynamics CRM 4.0
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