Erro ao trabalhar offline no cliente de computador portátil Microsoft Dynamics CRM para Outlook: "Falha na deslocação de dados para a entidade <Nome_entidade> durante a acção saInsert, countRows=<Número>. Contacte o administrador do sistema para obter ass

Traduções de Artigos Traduções de Artigos
Artigo: 916165 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido). Quando tentar trabalhar offline no cliente de computador portátil Microsoft Dynamics CRM 3.0 para Microsoft Office Outlook, poderá receber a seguinte mensagem de erro:
Falha na deslocação de dados para a entidade Nome_entidade durante a acção saInsert, countRows=Número. Contacte o administrador do sistema para obter assistência.
Nota Nesta mensagem, Nome_entidade será substituído pelo nome real da entidade e Número é um marcador de posição do número real de linhas.

É registada uma mensagem de erro semelhante à seguinte no registo de eventos:

Tipo de evento: Erro
Origem do Evento: MSCRMOfflineSync
Categoria do Evento: Nenhuma
ID do Evento: 6000
Descrição: An error occurred during Offline Synchronization. Try going offline again, or restart Microsoft Outlook. GetBCPFile() failed during action Insert for entity <Case>, batchRows=0 with exception System.Net.WebException: The remote server returned an error: (401) Unauthorized. ---> System.ComponentModel.Win32Exception: The logon attempt failed at System.Net.NTAuthentication.GetOutgoingBlob(Byte[] incomingBlob, Boolean& handshakeComplete) at System.Net.NTAuthentication.GetOutgoingBlob(String incomingBlob, Boolean& handshakeComplete) at System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate) at System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate) at System.Net.NegotiateClient.Authenticate(String challenge, WebRequest webRequest, ICredentials credentials) at System.Net.AuthenticationManager.Authenticate(String challenge, WebRequest request, ICredentials credentials) at System.Net.AuthenticationState.AttemptAuthenticate(HttpWebRequest httpWebRequest, ICredentials authInfo) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.CheckFinalStatus() at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) at System.Net.HttpWebRequest.GetResponse() at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.GetBCPFile(String entityName, Action action, Int32 batchSize).
For more information, see Help and Support Center at http://support.microsoft.com.
É registada uma mensagem de aviso semelhante à seguinte no registo de eventos:

Tipo de evento: Aviso
Origem do Evento: MSCRMOfflineSync
Categoria do Evento: Nenhuma
ID do Evento: 6001
Descrição: An unexpected result was returned during Offline Synchronization. #temp<EntityBase> count inserts 54!=27 requested count inserts.
For more information, see Help and Support Center at http://support.microsoft.com.
Nota Nesta mensagem, Base_entidade será substituído pelo nome real da tabela da entidade.

Causa

Este erro ocorre por se verificar uma ou mais das seguintes condições:
  • O cliente de computador portátil Microsoft CRM para Outlook não tem permissões para aceder à pasta BCP.
  • A versão de Microsoft XML (MSXML) no cliente de computador portátil Microsoft CRM para Outlook é incorrecta.
  • Os filtros de dados offline do cliente de computador portátil Microsoft CRM para Outlook são incorrectos.
  • A instalação de servidor do Microsoft CRM está danificada.
  • A conta de utilizador que executa o agrupamento de aplicações no Web site do Microsoft CRM não consegue aceder à pasta de dados offline no servidor do Microsoft CRM.
  • As bases de dados do Microsoft SQL Server são movidas para um novo servidor. A origem de dados IDBC DSN de sistema do Microsoft CRM no servidor do Microsoft CRM continua a apontar para o servidor anterior que está a executar o SQL Server.
  • O computador com o SQL Server e que contém as bases de dados do MSCRM está a enviar mais registos do que é habitual para a base de dados offline.
  • O parâmetro /3GB foi adicionado ao ficheiro Boot.ini no Servidor do Microsoft CRM. Este problema faz com que o servidor fique sem memória quando tenta executar o processo BCP.
  • O Microsoft Data Access Components (MDAC) 2.8 Service Pack 1 (SP1) não está instalado.

Resolução

Para resolver este problema, utilize um ou mais dos métodos que se seguem.

Método 1

Conceda permissões para a pasta BCP ao utilizador do cliente de computador portátil Microsoft CRM para Outlook. Para o fazer, siga estes passos:
  1. Inicie sessão no computador do cliente de computador portátil Microsoft CRM para Outlook e localize a pasta BCP. Normalmente, a pasta BCP encontra-se no seguinte caminho do computador cliente:
    C:\Documents and Settings\NomeUtilizador\Application Data\Microsoft\MSCRM\BCP
    Notas
    • Num computador baseado no Windows Vista, a pasta BCP está localizada no seguinte caminho:
      C:\Users\Nome_Utilizador\AppData\Roaming\Microsoft\MSCRM\BCP
    • Neste passo, Nome_Utilizador será substituído pelo nome de utilizador real.
  2. Localize e clique com o botão direito do rato na pasta. Em seguida, clique em Propriedades.
  3. Clique no separador Segurança.
  4. Na lista Nomes de grupo ou de utilizador, seleccione o utilizador do cliente de computador portátil Microsoft CRM para Outlook.
  5. Na lista Permissões para Nome_Utilizador certifique-se de que a caixa de verificação Permitir da linha Controlo Total está seleccionada. Em seguida, clique em OK.

    Nota Neste passo, Nome_Utilizador será substituído pelo nome de utilizador real.

Método 2

Certifique-se de que a versão do ficheiro Msxml4.dll é pelo menos a 4.20.9828 no computador cliente. Para o fazer, siga estes passos:
  1. Localize a pasta system32. Normalmente, esta pasta encontra-se no seguinte caminho:

    C:\WINDOWS\system32\
  2. Localize e clique com o botão direito do rato no ficheiro Msxml4.dll e clique em Propriedades. Clique no separador Versão.
  3. Verifique se o valor de Versão do ficheiro é, pelo menos, 4.20.9828. Se o valor for anterior a esta versão, avance para o passo 4.
  4. Se a versão do ficheiro Msxml4.dll for anterior à 4.20.9828, este terá de ser actualizado. Para obter mais informações sobre como obter um ficheiro actualizado, visite o seguinte Web site da Microsoft:
    http://support.microsoft.com/kb/887606/pt
    Notas
    • Também pode obter o ficheiro Msxml4.dll a partir do CD de instalação do cliente. Normalmente, o ficheiro Msxml4sp2-kb887606-x86-enu.exe encontra-se no seguinte caminho:

      \Client\MSXML\KB887606\
    • Esta correcção não requer o reinício do computador.

Método 3

Remova todos os filtros de dados offline e, em seguida, adicione e sincronize estes filtros um a um no computador cliente.. Para remover os filtros de dados offline, siga estes passos:
  1. No cliente de computador portátil Microsoft CRM para Outlook, clique em Dados locais no menu CRM.
  2. Na caixa de diálogo Dados locais, realce todos os filtros, clique em Desactivar e clique em OK.
Para adicionar e sincronizar os filtros, siga estes passos:
  1. No menu CRM, clique em Dados locais.
  2. Clique no separador Grupos de dados inactivos.
  3. Seleccione um dos filtros. Em seguida, clique em Activar.
  4. Clique em OK.
  5. Clique em Trabalhar offline para iniciar o processo de sincronização. Em seguida, clique em Trabalhar online para concluir o processo de sincronização.
  6. 6. Repita os passos 3 a 5 para cada filtro desactivado.

Método 4

Execute o processo de reparação no servidor do Microsoft CRM. Para o fazer, siga estes passos:
  1. Inicie sessão no servidor do Microsoft CRM. Clique em Iniciar, clique em Painel de controlo e, em seguida, clique em Adicionar ou remover programas.
  2. Clique em Microsoft CRM Server. Em seguida, clique em Alterar/remover.
  3. Clique na opção Reparar. Clique em Seguinte para iniciar o assistente de configuração do Microsoft CRM 3.0 Server.

Método 5

Certifique-se de que a conta de utilizador que executa o conjunto aplicacional no Web site do Microsoft CRM consegue aceder à pasta OfflineData. Esta pasta armazena os ficheiros de dados BCP (Bulk Copy Process) que o cliente obtém do servidor com o SQL Server. Para se certificar de que a pasta OfflineData pode ser acedida, siga estes passos:
  1. Determine qual a conta que está a executar o agrupamento de aplicações. Para o fazer, siga estes passos:
    1. Inicie sessão no servidor do Microsoft CRM.
    2. Clique em Iniciar, clique em Ferramentas administrativas e clique em Gestor de 'Serviços de informação Internet' (IIS).
    3. Expanda o nome do computador local, expanda Agrupamentos de aplicações, clique com o botão do rato em CRMAppPool e clique em Propriedades.
    4. Clique no separador Identidade.
    5. Verifique as permissões de acordo com as seguintes directrizes:

      Se a opção Predefinida estiver seleccionada, as contas NetworkService e LocalSystem são representadas pela conta Nome_Domínio\Nome_Computador$. Por este motivo, quando tiver de verificar as permissões da conta NetworkService ou da conta LocalSystem, terá de verificar também as permissões da conta Nome_Domínio\Nome_Computador$.

      Se a opção Configurável estiver seleccionada, terá de verificar as permissões da conta de utilizador especificada.

      Nota Se a opção Predefinida estiver seleccionada, utilize a conta Nome_Domínio\Nome_Computador$ como utilizador no passo 5. Se a opção Configurável estiver seleccionada, utilize a conta de utilizador especificada como utilizador no passo 5.
  2. No servidor do Microsoft CRM, localize a seguinte pasta:

    Unidade:\Programas\Microsoft CRM\Server\OfflineData\

    Nota Neste passo, Unidade será substituída pela unidade real em que instalou o Microsoft CRM.
  3. Clique com o botão direito do rato na pasta. Em seguida, clique em Propriedades.
  4. Clique no separador Segurança.
  5. Na lista Nomes de grupo ou de utilizador, seleccione o utilizador que identificou no passo 1.
  6. Na lista Permissões para Nome_Utilizador certifique-se de que a caixa de verificação Permitir da linha Controlo Total está seleccionada. Em seguida, clique em OK.

    Nota Neste passo, Nome_Utilizador será substituído pelo nome de utilizador real.

Método 6

Modifique a Origem de Dados ODBC DSN de Sistema do Microsoft CRM no servidor do Microsoft CRM para apontar para o novo servidor que está a executar o SQL Server. Para o fazer, siga estes passos:
  1. Clique em Iniciar, aponte para Ferramentas administrativas e clique em Origens de dados (ODBC).
  2. Na caixa de diálogo Administrador da origem de dados ODBC, clique no separador DSN de sistema, clique na lista Microsoft CRM nas origens de dados de sistema e clique em Configurar.
  3. Na primeira janela de configuração de DSN do Microsoft SQL, localize a lista Servidor que contém os nomes dos computadores que estão a executar o SQL Server. Clique no servidor ao qual pretende ligar.
  4. Clique em Seguinte três vezes para configurar a origem de dados.
  5. Clique em Concluir.
  6. Na janela de configuração de ODBC do Microsoft SQL Server, clique em Testar origem de dados para validar a ligação ao servidor.
  7. Clique em OK duas vezes para concluir a configuração.
  8. Clique em OK para fechar a caixa de diálogo Administrador da origem de dados ODBC.

Método 7

  1. Saia do Microsoft Dynamics CRM 3.0.
  2. Clique em Iniciar, clique em Executar, escreva regedit e clique em OK.
  3. Localize e clique na seguinte subchave do registo:
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
  4. Clique com o botão direito do rato no valor de DWORD OfflineRowsBatchSize e clique em Modificar.
  5. Na caixa Dados do valor, escreva um valor inferior ao valor actual, tal como 10 ou 1. Clique em OK.

    Nota Por predefinição, o valor de DWORD OfflineRowsBatchSize é definido como 100000.
  6. Saia do Editor de Registo.

Método 8

Remova o parâmetro /3GB do ficheiro Boot.ini no servidor do Microsoft CRM. Para a alteração surtir efeito, terá de reiniciar o computador depois de remover o parâmetro.

Método 9

Instale o MDAC 2.8 Service Pack 1. Para instalar o MDAC 2.8 SP1, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/downloads/details.aspx?displaylang=pt-pt&FamilyID=78cac895-efc2-4f8e-a9e0-3a1afbd5922e

Método 10

Se tiverem sido aplicadas ao servidor do Microsoft Dynamics CRM ou ao servidor com o SQL Server actualizações recentes ao sistema operativo Windows, reinicie o servidor em questão.

Mais Informação

Se o problema descrito na secção "Sintomas" persistir, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:
918108 Error message when you try to go offline on a laptop client computer that is running Microsoft Dynamics CRM 3.0: "Failed move data for entity"

Referências

Para obter mais informações sobre como mover bases de dados do SQL Server do Microsoft Dynamics CRM 3.0 de um servidor para outro, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:
917948 Como mover bases de dados SQL do Microsoft Dynamics CRM 3.0 de um servidor para outro servidor no mesmo domínio

Propriedades

Artigo: 916165 - Última revisão: 16 de maio de 2011 - Revisão: 8.0
A informação contida neste artigo aplica-se a:
  • Microsoft CRM client for Microsoft Office Outlook
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbmbscrm40no kbcrmv3c kberrmsg kbmbsmigrate kbprb kbtshoot KB916165

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com