Mensagem de erro ao tentar ficar offline no cliente de laptop do Microsoft Dynamics CRM para Outlook: "Não foi possível mover dados para a entidade <EntityName> durante a ação saInsert, countRows=<CountNumber>. Contate o administrador do siste

Traduções deste artigo Traduções deste artigo
ID do artigo: 916165 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao tentar ficar offline no cliente de laptop do Microsoft Dynamics CRM 3.0 para Microsoft Office Outlook, você pode receber a seguinte mensagem de erro:
Não foi possível mover dados para a entidade Nome_da_Entidade durante a ação saInsert, countRows=Número_da_Contagem. Contate o administrador do sistema para obter assistência.
Observação: nessa mensagem, Nome_da_Entidade é um espaço reservado para o nome de uma entidade real, e Número_da_Contagem é um espaço reservado para o número real de linhas.

Uma mensagem de erro semelhante à seguinte é registrada no log de eventos:

Tipo de Evento: Erro
Origem do Evento: MSCRMOfflineSync
Categoria do Evento: Nenhuma
Identificação do Evento: 6000
Descrição: ocorreu um erro durante a Sincronização Offline. Tente voltar ao modo offline ou reiniciar o Microsoft Outlook. Falha de GetBCPFile() durante a ação Insert para a entidade <Ocorrência>, batchRows=0 com a exceção System.Net.WebException: O servidor remoto retornou um erro: (401) Não autorizado. ---> System.ComponentModel.Win32Exception: Falha na tentativa de logon em System.Net.NTAuthentication.GetOutgoingBlob(Byte[] incomingBlob, Boolean& handshakeComplete) em System.Net.NTAuthentication.GetOutgoingBlob(String incomingBlob, Boolean& handshakeComplete) em System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate) em System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate) em System.Net.NegotiateClient.Authenticate(String challenge, WebRequest webRequest, ICredentials credentials) em System.Net.AuthenticationManager.Authenticate(String challenge, WebRequest request, ICredentials credentials) em System.Net.AuthenticationState.AttemptAuthenticate(HttpWebRequest httpWebRequest, ICredentials authInfo) --- Fim do rastreamento da pilha de exceção interna --- em System.Net.HttpWebRequest.CheckFinalStatus() em System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) em System.Net.HttpWebRequest.GetResponse() em Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.GetBCPFile(String entityName, Action action, Int32 batchSize).
Para obter mais informações, consulte o Centro de Ajuda e Suporte em http://support.microsoft.com.
Uma mensagem de aviso semelhante à seguinte é registrada no log de eventos:

Tipo de Evento: Aviso
Origem do Evento: MSCRMOfflineSync
Categoria do Evento: Nenhuma
Identificação do Evento: 6001
Descrição: foi retornado um resultado inesperado durante a Sincronização Offline. #tempInserções de contagem da <Base_da_Entidade> 54!=27 inserções de contagem selecionadas.
Para obter mais informações, consulte o Centro de Ajuda e Suporte em http://support.microsoft.com.
Observação: nessa mensagem, Base_da_Entidade é um espaço reservado para um nome de tabela real da entidade.

Causa

Esse problema ocorre porque uma ou mais das seguintes condições são verdadeiras:
  • O cliente de laptop do Microsoft CRM para Outlook não tem as permissões para acessar a pasta BCP.
  • A versão do Microsoft XML (MSXML) no cliente de laptop do Microsoft CRM para Outlook está incorreta.
  • Os filtros de dados offline do cliente de laptop do Microsoft CRM para Outlook estão incorretos.
  • A instalação do servidor do Microsoft CRM está corrompida.
  • A conta de usuário que executa o pool de aplicativos no site do Microsoft CRM não pode acessar a pasta de dados offline no servidor do Microsoft CRM.
  • Os bancos de dados do Microsoft SQL Server são movidos para um novo servidor. A Fonte de Dados ODBC do DSN de sistema do Microsoft CRM no servidor do Microsoft CRM continua a apontar para o servidor anterior que está executando o SQL Server.
  • O computador que está executando o SQL Server e que contém os bancos de dados do MSCRM está enviando mais registros que o normal para o banco de dados offline.
  • A opção /3GB foi adicionada ao arquivo Boot.ini no servidor do Microsoft CRM. Esse problema faz com que o servidor fique sem memória ao tentar executar o processo BCP.
  • O MDAC (Microsoft Data Access Components) 2.8 Service Pack 1 (SP1) não está instalado.

Resolução

Para resolver esse problema, use um ou mais dos métodos a seguir.

Método 1:

conceda permissões para a pasta BCP ao usuário do cliente de laptop do Microsoft CRM para Outlook. Para fazer isso, siga estas etapas:
  1. Faça logon no computador com o cliente de laptop do Microsoft CRM para Outlook e localize a pasta BCP. Geralmente, a pasta BCP fica no seguinte caminho do computador cliente:
    C:\Documents and Settings\Nome_do_Usuário\Dados de Aplicativos\Microsoft\MSCRM\BCP
    Observações
    • Em um computador com o Windows Vista, a pasta BCP fica no seguinte caminho:
      C:\Users\Nome_do_Usuário\AppData\Roaming\Microsoft\MSCRM\BCP
    • Nessa etapa, Nome_do_Usuário é um espaço reservado para o nome de usuário real.
  2. Localize e clique com o botão direito do mouse na pasta. Em seguida, clique em Propriedades.
  3. Clique na guia Segurança.
  4. Na lista Nomes de grupo ou de usuário, selecione o usuário do cliente de laptop do Microsoft CRM para Outlook.
  5. Na lista Permissões para Nome_do_Usuário, verifique se a caixa de seleção Permitir está selecionada na linha Controle Total. Em seguida, clique em OK.

    Observação: nessa etapa, Nome_do_Usuário é um espaço reservado para o nome de usuário real.

Método 2:

verifique se a versão do arquivo Msxml4.dll é 4.20.9828 ou posterior no computador cliente. Para fazer isso, siga estas etapas:
  1. Localize a pasta system32. Geralmente, essa pasta fica no seguinte caminho:

    C:\WINDOWS\system32\
  2. Localize e clique com o botão direito do mouse no arquivo Msxml4.dll e clique em Propriedades. Clique na guia Versão.
  3. Verifique se o valor de Versão do arquivo é a 4.20.9828 ou posterior. Se o valor for anterior a essa versão, continue na etapa 4.
  4. Se a versão do arquivo Msxml4.dll for anterior a 4.20.9828, ele deverá ser atualizado. Para obter mais informações sobre como obter um arquivo atualizado, visite o seguinte site da Microsoft:
    http://support.microsoft.com/kb/887606/
    Observações
    • Você também pode obter o arquivo Msxml4.dll no CD de instalação do cliente. Geralmente, o arquivo Msxml4sp2-kb887606-x86-enu.exe está no seguinte caminho:

      \Client\MSXML\KB887606\
    • Essa correção não requer a reinicialização do computador.

Método 3:

remova todos os filtros de dados offline e adicione e sincronize esses filtros, um a um, no computador cliente. Para remover os filtros de dados offline, siga estas etapas:
  1. No cliente de laptop do Microsoft CRM para Outlook, clique em Dados Locais no menu CRM.
  2. Na caixa de diálogo Dados Locais, realce todos os filtros, clique em Desativar e clique em OK.
Para adicionar e sincronizar os filtros, siga estas etapas:
  1. No menu CRM, clique em Dados Locais.
  2. Clique na guia Grupos de Dados Inativos.
  3. Selecione um dos filtros. Em seguida, clique em Ativar.
  4. Clique em OK.
  5. Clique em Modo Offline para iniciar o processo de sincronização. Em seguida, clique em Entrar Online para concluir o processo de sincronização.
  6. Repita as etapas de 3 a 5 para cada filtro desativado.

Método 4:

execute o processo de reparo no servidor do Microsoft CRM. Para fazer isso, siga estas etapas:
  1. Faça logon no servidor do Microsoft CRM. Clique em Iniciar, Painel de Controle e Adicionar ou Remover Programas.
  2. Clique em Servidor do Microsoft CRM. Em seguida, clique em Alterar/Remover.
  3. Clique na opção Reparar. Em seguida, clique em Avançar para iniciar o Assistente para Instalação do Servidor do Microsoft CRM 3.0.

Método 5:

verifique se a conta de usuário que executa o pool de aplicativos no site do Microsoft CRM pode acessar a pasta OfflineData. Essa pasta armazena os arquivos de dados de BCP (Processo de cópia em massa) que o cliente obtém do servidor que está executando o SQL Server. Para verificar se a pasta OfflineData pode ser acessada, siga estas etapas:
  1. Determine qual conta está executando o pool de aplicativos. Para fazer isso, siga estas etapas:
    1. Faça logon no servidor do Microsoft CRM.
    2. Clique em Iniciar, Ferramentas Administrativas e Gerenciador dos Serviços de Informações da Internet (IIS).
    3. Expanda o nome do computador local, expanda Pools de Aplicativos, clique com o botão direito do mouse em CRMAppPool e clique em Propriedades.
    4. Clique na guia Identidade.
    5. Verifique as permissões de acordo com as seguintes diretrizes:

      Se a opção Predefinida estiver selecionada, ambas a contas NetworkService e LocalSystem serão representadas pela conta Nome_do_Domínio\Nome_do_Computador$. Portanto, quando for preciso verificar permissões para a conta NetworkService ou LocalSystem, você também deverá verificar as permissões para a conta Nome_do_Domínio\Nome_do_Computador$.

      Se a opção Configurável estiver selecionada, você deverá verificar as permissões para a conta de usuário especificada.

      Observação: se a opção Predefinida estiver selecionada, use a conta Nome_do_Domínio\Nome_do_Computador$ como o usuário na etapa 5. Se a opção Configurável estiver selecionada, use a conta de usuário especificada como o usuário na etapa 5.
  2. No servidor do Microsoft CRM, localize a seguinte pasta:

    Unidade:\Arquivos de Programas\Microsoft CRM\Server\OfflineData\

    Observação: nessa etapa, Unidade é um espaço reservado para a unidade real na qual o Microsoft CRM foi instalado.
  3. Clique com o botão direito do mouse na pasta. Em seguida, clique em Propriedades.
  4. Clique na guia Segurança.
  5. Na lista Nomes de grupo ou de usuário, selecione o usuário identificado na etapa 1.
  6. Na lista Permissões para Nome_do_Usuário, verifique se a caixa de seleção Permitir está selecionada na linha Controle Total. Em seguida, clique em OK.

    Observação: nessa etapa, Nome_do_Usuário é um espaço reservado para o nome de usuário real.

Método 6:

modifique a Fonte de Dados ODBC do DSN de sistema do Microsoft CRM no servidor do Microsoft CRM para que ela aponte para o novo servidor que está executando o SQL Server. Para fazer isso, siga estas etapas:
  1. Clique em Iniciar, aponte para Ferramentas Administrativas e clique em Fontes de Dados (ODBC).
  2. Na caixa de diálogo Administrador de Fonte de Dados ODBC, clique na guia DSN de sistema, clique em Microsoft CRM na lista Fontes de Dados do Sistema e clique em Configurar.
  3. Na primeira janela de configuração de DSN do Microsoft SQL Server, localize a lista Servidor que contém os nomes dos computadores que estão executando o SQL Server. Clique no servidor ao qual deseja se conectar.
  4. Clique em Avançar três vezes para configurar a fonte de dados.
  5. Clique em Concluir.
  6. Na janela de configuração de ODBC do Microsoft SQL Server, clique em Testar Fonte de Dados para validar a conexão com o servidor.
  7. Clique em OK duas vezes para concluir a configuração.
  8. Clique em OK para fechar a caixa de diálogo Administrador de fonte de dados ODBC.

Método 7:

  1. saia do Microsoft Dynamics CRM 3.0.
  2. Clique em Iniciar, Executar, digite regedit e clique em OK.
  3. Localize e clique na seguinte subchave do Registro:
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
  4. Clique com o botão direito do mouse no valor DWORD OfflineRowsBatchSize e clique em Modificar.
  5. Na caixa Dados do valor, digite um valor que seja inferior ao valor atual, como 10 ou 1. Em seguida, clique em OK.

    Observação: por padrão, o valor DWORD OfflineRowsBatchSize é definido como 100000.
  6. Saia do Editor do Registro.

Método 8:

remova a opção /3GB do arquivo Boot.ini no servidor do Microsoft CRM. Para que a alteração entre em vigor, você deve reiniciar o computador após remover a opção.

Método 9:

instale o MDAC 2.8 Service Pack 1. Para fazer isso, visite o seguinte site da Microsoft:
http://www.microsoft.com/downloads/details.aspx?displaylang=pt-br&FamilyID=78cac895-efc2-4f8e-a9e0-3a1afbd5922e

Método 10:

se tiverem sido aplicadas atualizações do sistema operacional Windows recentemente ao servidor do Microsoft Dynamics CRM ou ao servidor que está executando o SQL Server, reinicie o servidor afetado.

Mais Informações

Se você continuar a ter o problema descrito na seção "Sintomas", clique no número do artigo a seguir para exibir o artigo na Base de Dados de Conhecimento Microsoft:
918108 Mensagem de erro ao tentar ficar offline em um computador cliente de laptop que está executando o Microsoft Dynamics CRM 3.0: "Não foi possível mover dados para a entidade"

Referências

Para obter mais informações sobre como mover bancos de dados SQL do Microsoft Dynamics CRM 3.0 de um servidor para outro, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento Microsoft:
917948 Como mover bancos de dados SQL do Microsoft Dynamics CRM 3.0 de um servidor para outro, no mesmo domínio

Propriedades

ID do artigo: 916165 - Última revisão: quinta-feira, 10 de janeiro de 2008 - Revisão: 7.2
A informação contida neste artigo aplica-se a:
  • Microsoft CRM client for Microsoft Office Outlook nas seguintes plataformas
    • Microsoft Dynamics CRM 3.0
  • Microsoft Dynamics CRM 3.0
Palavras-chave: 
kberrmsg kbtshoot kbprb kbmbsmigrate kbcrmv3c kbmbscrm40no KB916165

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com