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A COM client application no longer runs as expected on a Windows XP SP2-based computer, and you may receive the following error message: "E_ACCESSDENIED"

Article ID:916189
Last Review:August 29, 2007
Revision:2.0
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SYMPTOMS

On a Microsoft Windows XP Service Pack 2 (SP2)-based computer, a Component Object Model (COM) client application no longer runs as expected. Specifically, the COM client or server process is unusable. Additionally, the COM client may receive the following error message:
E_ACCESSDENIED

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CAUSE

This problem occurs if the client or server process is removed from an internal table in the Rpcss.dll file.

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RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Prerequisites

You must have Windows XP SP2 installed to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the hotfix in the following Microsoft Knowledge Base article:
914301 (http://support.microsoft.com/kb/914301/) The CoCreateInstance function may return an HRESULT failure on a Windows XP Professional Service Pack 2-based or Windows Server 2003-based computer

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.1.2600.2863582,14408-Mar-200606:12x86

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Windows XP Service Pack 2, when used with:
  Microsoft Windows XP Professional
  Microsoft Windows XP Home Edition

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Keywords: 
kbbug kbfix kbqfe kbpubtypekc kbhotfixserver KB916189

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