文書番号: 916248 - 最終更新日: 2006年6月30日 - リビジョン: 2.4

マイクロソフト Windows Update の Web サイト、または Windows XP ベースのコンピューターには、Microsoft Update Web サイトから更新をダウンロードしようとすると、エラー メッセージ:"0x80070003"

すべて展開する | すべて折りたたむ

現象

Microsoft Windows XP のクリーン インストールを実行した後、Microsoft Windows の更新プログラムの Web サイトや、Microsoft Update Web サイトから更新をダウンロードしようと。 ただし、更新プログラムは正常に実行されません。 代わりに、バックグラウンド インテリジェンス転送サービス (BITS) をインストールする求められます。

赤い X は、更新プログラムに隣接した見えます。 この場合は、次のエラー コードが表示されます。
0x80070003
メモ エラー メッセージを表示するのには障害が発生した更新プログラム 、更新履歴の確認 Web ページ上に隣接する赤い閉じるボタン クリックします。

原因

この問題は、次の条件のいずれかに該当する場合に発生します:
  • BITS は、コンピューターに正しく登録されていません。
  • いくつかの.dll ファイルは正しく登録されません。

解決方法

この問題を解決するには、次の手順に従います。
  1. 開始 実行 cmd ] を入力 [ OK] をクリックします。
  2. net stop wuauserv を入力して Enter を押します。
  3. コマンド プロンプト ウィンドウを閉じる 終了 を入力します。
  4. エクスプローラを起動して、Windows\System32 フォルダを開きます。
  5. 各ファイルを次の一覧を右クリックして 名前の変更 ] をクリックして、各ファイル名の拡張子.old に変更します。
    • Msxml3.dll
    • Wuaueng.dll
    • Wuapi.dll
    • Atl.dll
    • Wucltui.dll
    • Wups.dll
  6. Windows\System32、フォルダーを開きし、DLL キャッシュから手順 5 のファイルが置き換えられることを確認します。 ファイルが置き換えられない場合元ファイルをもう一度名変更してください。
  7. .dll のファイルの名前を変更したを登録します。 これを行うには、次の手順を実行します。
    1. 開始 ] をクリックして [ 実行 ] をクリックして、 regsvr32 msxml3.dll と入力して [OK] をクリックします。 DllRegisterServer 関数が成功した RegSvr32 確認が表示されたら、 [OK] をクリックします。
    2. ファイルごとに手順 5 に記載された手順 7a を繰り返します。
  8. 開始 実行 cmd ] を入力 [ OK] をクリックします。
  9. %windir% を入力して Enter を押します。
  10. SoftwareDistribution SDTemp の名 を入力して Enter を押します。

    %windir%\softwaredistribution フォルダーを削除すると履歴リストには、Windows Update Web サイトの your 更新を確認する」セクションから消去されます。 この操作には、コンピューターに現在インストールされている更新プログラムは変わりません。 以降の更新は履歴一覧に表示します。
  11. net start wuauserv を入力して Enter を押します。 ダウンロードして、更新プログラムをインストールすることがされます。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows Update Corporate Edition 1.0
  • Microsoft Update
キーワード:?
kbmt kbwindowsupdate kbwinupdwebsite kbtshoot kbprb KB916248 KbMtja
機械翻訳機械翻訳
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:916248? (http://support.microsoft.com/kb/916248/en-us/ )
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
 

サポート技術情報の翻訳

 

Related Support Centers