Messaggio di errore quando si tenta di scaricare aggiornamenti dal sito Windows Update o dal sito Microsoft Update, o quando si tenta di avviare il servizio trasferimento intelligente in background

Traduzione articoli Traduzione articoli
Identificativo articolo: 916251 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di scaricare aggiornamenti dal sito Microsoft Windows Update o dal sito Microsoft Update, viene potrebbe essere visualizzato il seguente messaggio di errore:
0 x 80246008
Inoltre, quando si tenta di avviare il servizio trasferimento intelligente in background (BITS), non si avvia il servizio e viene visualizzato uno dei seguenti messaggi di errore:
Codice di errore 2
-2147024894

Cause

Questo problema si verifica quando una delle seguenti condizioni è vera:
  • BITS non è registrato correttamente nel computer.
  • Alcuni file sono danneggiati nella cartella %allusersprofile% \Application Data\Microsoft\Network\Downloader.

Risoluzione

Per risolvere il problema, utilizzare uno dei seguenti metodi.

Metodo 1

Nota I passaggi 3 e 4 è valida solo per i computer che eseguono Microsoft Windows XP.
  1. Verificare che sia installata la versione più recente di BITS. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
    842773È disponibile per Windows Server 2003, Windows XP e Windows 2000 un pacchetto di aggiornamento che include BITS 2.0 e WinHTTP 5.1
  2. Registrare nuovamente il Qmgr.dll e i file di BITS Qmgrprxy.dll. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic su Start , scegliere Esegui , digitare regsvr32 qmgr.dll e quindi fare clic su OK due volte.
    2. Fare clic su Start , scegliere Esegui , digitare regsvr32 qmgrprxy.dll e quindi fare clic su OK due volte.
    3. Riavviare il computer.
  3. Fare clic su Start , scegliere Esegui , digitare cmd e quindi fare clic su OK .
  4. Al prompt dei comandi, digitare il seguente comando e quindi fare clic su OK :
    %windir%\System32\rundll32.exe setupapi, InstallHinfSection DefaultInstall 132 %windir%\inf\qmgr.inf
    Nota Se viene chiesto di inserire il CD del sistema operativo, digitare %windir% \ServicePackFiles\i386 nella casella copiare i file da e quindi fare clic su OK .
  5. Riavviare il computer.
  6. Avviare manualmente il servizio. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic su Start , scegliere Esegui , digitare services.msc e quindi fare clic su OK .
    2. Fare doppio clic su Background Intelligent Transfer Service .
    3. Nell'area stato del servizio , fare clic su Start .
    4. Se BITS non viene avviato correttamente, procedere al passaggio 7.
  7. Fare clic su Start , scegliere Esegui , digitare il seguente comando e quindi fare clic su OK :
    reg aggiungere HKLM\SYSTEM\CurrentControlSet\Services\BITS\Parameters /v ServiceDll /t REG_EXPAND_SZ /d %windir%\System32\qmgr.dll
  8. Riavviare il computer.
  9. Provare ad avviare manualmente BITS. Se il servizio persiste, procedere al passaggio 11.
  10. Fare clic su Start , scegliere Esegui , digitare cmd e quindi fare clic su OK .
  11. Al prompt dei comandi, digitare il seguente comando e quindi fare clic su OK :
    reg aggiungere HKLM\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup
  12. Riavviare il computer e tentare di avviare manualmente il servizio.

    Nota Consente di impostare il tipo di avvio BITS su "Automatico" anziché "Manuale" non appena è risolvere il problema. Per modificare il tipo di avvio, attenersi alla seguente procedura:
    1. Fare clic su Start , scegliere Esegui , digitare services.msc e quindi fare clic su OK .
    2. Fare doppio clic su Background Intelligent Transfer Service .
    3. Nella casella tipo di avvio , fare clic su automatico e quindi fare clic su OK .

Metodo 2

Eliminare la cartella di \Application Data\Microsoft\Network\Downloader %allusersprofile%.

Workaround

Per aggirare il problema, rimuovere BITS, riavviare il computer, reinstalla BITS e riavviare il computer. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare appwiz.cpl e quindi fare clic su OK .
  2. Nell'elenco Programmi attualmente installati , fare clic su Windows XP Hotfix - KB842773 e quindi scegliere Rimuovi .
  3. Seguire le istruzioni nell'Aggiunta guidata di rimozione di Windows XP KB842773 per rimuovere l'aggiornamento dal computer.
  4. Dopo l'aggiornamento di aggiornamento rapido è stato rimosso, riavviare il computer.
  5. Reinstallare BITS. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
    842773È disponibile per Windows Server 2003, Windows XP e Windows 2000 un pacchetto di aggiornamento che include BITS 2.0 e WinHTTP 5.1
  6. Riavviare il computer.

Proprietà

Identificativo articolo: 916251 - Ultima modifica: mercoledì 2 agosto 2006 - Revisione: 2.4
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Update
  • Microsoft Update
Chiavi: 
kbmt kbwindowsupdate kbtshoot kberrmsg kbprb KB916251 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 916251
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com