FIX: Error message when you use a distributed application to marshal user-defined data types that contain a SAFEARRAY data type to a Windows XP Service Pack 2-based server: "0x800706F7"

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Article ID: 917423 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario. You create a distributed application that uses a custom channel. The custom channel implements the IRpcChannelBuffer interface. However, the custom channel does not implement the IRpcChannelBuffer2 interface. A Microsoft Windows 2000 client application makes a Microsoft Component Object Model (COM) call. This COM call must marshal user-defined data types that contain a SAFEARRRAY data type to a Microsoft Windows XP Service Pack 2 (SP2)-based COM server.

In this scenario, the Windows XP SP2-based server may reject the call, and the Windows 2000 client application may receive an error message that resembles the following:
0x800706F7 (The stub received bad data)

CAUSE

This problem occurs because the Oleaut32.dll file cannot determine the version of the negotiated Network Data Representation (NDR) protocol. Therefore, the Oleaut32.dll file cannot determine whether the server supports UDTs, and the Oleaut32.dll file incorrectly marshals the SAFEARRAY data type.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTime
Asycfilt.dll2.40.4530.0143,63228-Mar-200616:41
Oleaut32.dll2.40.4530.0631,05628-Mar-200616:41
Olepro32.dll5.0.4530.0164,11228-Mar-200616:41

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 917423 - Last Review: October 9, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbautohotfix kbwin2000fixnosp kbfix kbbug kbHotfixServer kbqfe KB917423

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