Message d'erreur lorsque vous essayez d'afficher le calendrier de service dans Microsoft Dynamics CRM 3.0: « une exception non gérée a été générée pendant l'exécution de la demande web actuelle »

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Numéro d'article: 917545 - Voir les produits auxquels s'applique cet article
important Cet article contient des informations sur la modification du Registre. Assurez-vous de sauvegarder le Registre avant de le modifier. Vérifiez que vous connaissez comment restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows


Le correctif décrits dans cet article n'est pas disponible pour la version chinoise de Microsoft Dynamics CRM ou pour la version japonaise de Microsoft Dynamics CRM.
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Symptômes

Vous ne pouvez pas afficher le calendrier Services dans Microsoft Dynamics CRM 3.0. De plus, le message d'erreur suivant s'affiche :
Une exception non gérée a été générée pendant l'exécution de la demande web actuelle. Informations concernant l'origine et l'emplacement de l'exception peuvent être identifiées à l'aide de la trace de pile d'exception ci-dessous.

Cause

Ce problème se produit lorsque vous avez Nbre d'heures requises définies dans Microsoft Dynamics CRM 3.0 et lorsqu'une des conditions suivantes est remplie :
  • Vous changez de fuseau horaire sur votre ordinateur.
  • Vous modifiez de passage à l'heure en heure standard, ou bien vous modifier d'une durée standard en heure.

Résolution

Ce problème est résolu dans Microsoft Dynamics CRM 3.0 mise à jour le correctif cumulatif 1. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
922815 Update Rollup 1 pour Microsoft Dynamics CRM 3.0 est disponible

Plus d'informations

Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.

Pour activer le correctif logiciel, ajoutez la valeur DWORD ForceTimeZone à la sous-clé de Registre suivante :
HKLM\Software\Microsoft\MSCRM
La valeur DWORD ForceTimeZone doit avoir une valeur de 1 décimal. Pour ajouter la valeur DWORD ForceTimeZone, procédez comme suit :
  1. Sur le serveur Microsoft Dynamics CRM, cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
  2. Cliquez avec le bouton droit sur la clé de Registre HKLM\Software\Microsoft\MSCRM , cliquez sur Nouveau , puis cliquez sur valeur DWORD .
  3. Tapez ForceTimeZone et puis appuyez sur ENTRÉE.
  4. Double-cliquez sur ForceTimeZone , tapez 1 dans la zone données de la valeur et puis cliquez sur OK .
Ce correctif résout le problème va vers l'avant. Toutefois, vous devez corriger manuellement certains enregistrements du calendrier. Vous devez corriger manuellement certains enregistrements du calendrier si vous recevez les messages d'erreur suivants lorsque vous cliquez sur heures de travail après avoir ouvert un enregistrement d'utilisateur dans Microsoft Dynamics CRM.
Message d'erreur 1
Échec de la demande SOAP :
>Url:http://n30/MSCRMServices/Calendar.asmx
>MethodName : développer
>Response: >
<? xml version = "1.0" codage = "utf-8"? > >
< soap : Enveloppe xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/ "xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema " >
> <soap:Body>
> <soap:Fault>
> <faultcode> soap : Server </faultcode>
> <faultstring> System.Web.Services.Protocols.SoapException : serveur n'a pas pu traiter la demande---. &gt; System.InvalidOperationException : périodicité par rapport généré un intervalle qui ne figure pas par l'étendue. > au Microsoft.Crm.Scheduling.RelativeRecurrenceRule.Expand (étendues TimeIntervalCollection) >
Message d'erreur 2
>CrmSoapExtension détecté CrmException non - rapport sera envoyé à Watson : System.Web.Services.Protocols.SoapException : serveur n'a pas pu traiter la demande. ---> System.InvalidOperationException : périodicité par rapport généré un intervalle qui ne figure pas par l'étendue. à Microsoft.Crm.Scheduling.RelativeRecurrenceRule.Expand (étendues TimeIntervalCollection) à Microsoft.Crm.Scheduling.Engine.LeafCalendarRule.ExpandRecurrence (TimeIntervalCollection effectiveScopeIntervals TimeIntervalCollection instanceIntervals, int32 effectiveTimeZoneCode) à Microsoft.Crm.Scheduling.Engine.CalendarRule.Expand (TimeIntervalCollection scopeIntervals TimeIntervalCollection instanceIntervals, int32 fallbackTimeZoneCode)
note Vous recevez ces messages d'erreur si vous activez le paramètre DevErrors ou si vous examinez les fichiers de journaux de suivi de plate-forme.

Pour résoudre ce problème immédiatement, contactez services de support technique Microsoft. Pour une liste complète des numéros de téléphone services de support technique Microsoft et des informations sur les frais engendrés, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note Dans certains cas, les frais aucuns de support peuvent être facturés si un technicien du support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par la mise à jour en question.

Pour plus d'informations sur la terminologie mise à jour logicielles, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft
887283 Package correctif de logiciel Microsoft Business Solutions CRM et mise à jour de normes d'affectation de noms

Propriétés

Numéro d'article: 917545 - Dernière mise à jour: vendredi 11 janvier 2008 - Version: 4.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft CRM 3.0
Mots-clés : 
kbmt kbfix kbbug kberrmsg kbhotfixserver kbqfe kbmbsmigrate KB917545 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 917545
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